summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans')
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog.bb12
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend24
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend24
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend88
8 files changed, 78 insertions, 78 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
index d71b378cf..4673c44c0 100644
--- a/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "busybox"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "busybox"
RESET_SERVICE = "reset-fan-watchdog.service"
TGTFMT = "obmc-chassis-poweron@0.target"
@@ -17,7 +17,7 @@ MONITOR_SERVICE = "fan-watchdog-monitor@.service"
WATCHDOG_SERVICE = "fan-watchdog.service"
WATCHDOG_FMT = "../${WATCHDOG_SERVICE}:${TGTFMT}.requires/${WATCHDOG_SERVICE}"
-SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}"
-SYSTEMD_LINK_${PN} += "${RESET_FMT} ${WATCHDOG_FMT}"
-SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/reset-fan-watchdog.conf"
-SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/fan-watchdog.conf"
+SYSTEMD_SERVICE:${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}"
+SYSTEMD_LINK:${PN} += "${RESET_FMT} ${WATCHDOG_FMT}"
+SYSTEMD_ENVIRONMENT_FILE:${PN} += "obmc/fan-watchdog/reset-fan-watchdog.conf"
+SYSTEMD_ENVIRONMENT_FILE:${PN} += "obmc/fan-watchdog/fan-watchdog.conf"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
index 8f2097cc1..9accc57ef 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
index 8f2097cc1..9accc57ef 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
index 8f2097cc1..9accc57ef 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
index 8f2097cc1..9accc57ef 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 2c15e034a..85cc4d82e 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1,18 +1,18 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-SRC_URI_witherspoon = "file://config.json"
-SRC_URI_p10bmc = "file://rainier-2u/config.json \
+SRC_URI:witherspoon = "file://config.json"
+SRC_URI:p10bmc = "file://rainier-2u/config.json \
file://rainier-4u/config.json \
file://rainier-1s4u/config.json \
file://everest/config.json \
"
-do_install_witherspoon() {
+do_install:witherspoon() {
install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
}
-do_install_p10bmc() {
+do_install:p10bmc() {
# Install Rainier-2U/4U fan monitor config files
install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/
install -d ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/
@@ -26,11 +26,11 @@ do_install_p10bmc() {
install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/ibm,everest/
}
-FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
-FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml"
+FILES:${PN}:append:witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
+FILES:${PN}:remove:witherspoon = "${monitor_datadir}/monitor.yaml"
-FILES_${PN}_remove_p10bmc = "${monitor_datadir}/monitor.yaml"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/config.json"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/config.json"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/config.json"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,everest/config.json"
+FILES:${PN}:remove:p10bmc = "${monitor_datadir}/monitor.yaml"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-2u/config.json"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-4u/config.json"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,rainier-1s4u/config.json"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/monitor/ibm,everest/config.json"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index 2306ee509..64dbc758b 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -1,17 +1,17 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-SRC_URI_witherspoon = "file://config.json"
-SRC_URI_p10bmc = "file://rainier-2u/config.json \
+SRC_URI:witherspoon = "file://config.json"
+SRC_URI:p10bmc = "file://rainier-2u/config.json \
file://rainier-4u/config.json \
file://rainier-1s4u/config.json \
file://everest/config.json \
"
-do_install_witherspoon() {
+do_install:witherspoon() {
install -d ${D}/${datadir}/phosphor-fan-presence/presence/
install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
}
-do_install_p10bmc() {
+do_install:p10bmc() {
# Install Rainier-2U/4U fan presence config files
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
@@ -25,11 +25,11 @@ do_install_p10bmc() {
install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
}
-FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
-FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
+FILES:${PN}:append:witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
+FILES:${PN}:remove:witherspoon = "${presence_datadir}/config.yaml"
-FILES_${PN}_remove_p10bmc = "${presence_datadir}/config.yaml"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
-FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"
+FILES:${PN}:remove:p10bmc = "${presence_datadir}/config.yaml"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
+FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 0d8b3b872..469f76539 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,74 +1,74 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
# Package configuration
-FAN_PACKAGES_append_ibm-ac-server = " \
+FAN_PACKAGES:append:ibm-ac-server = " \
phosphor-cooling-type \
"
-FAN_PACKAGES_append_mihawk = " \
+FAN_PACKAGES:append:mihawk = " \
phosphor-cooling-type \
"
-PACKAGECONFIG_append_ibm-ac-server = " cooling-type"
-PACKAGECONFIG_append_mihawk = " cooling-type"
+PACKAGECONFIG:append:ibm-ac-server = " cooling-type"
+PACKAGECONFIG:append:mihawk = " cooling-type"
TMPL_COOLING = "phosphor-cooling-type@.service"
INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
MULTI_USR_TGT = "multi-user.target"
FMT_COOLING = "../${TMPL_COOLING}:${MULTI_USR_TGT}.requires/${INSTFMT_COOLING}"
-FILES_phosphor-cooling-type_append_ibm-ac-server = " ${bindir}/phosphor-cooling-type"
-SYSTEMD_SERVICE_phosphor-cooling-type_append_ibm-ac-server = " ${TMPL_COOLING}"
-SYSTEMD_LINK_phosphor-cooling-type_append_ibm-ac-server = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
-FILES_phosphor-cooling-type_append_mihawk = " ${bindir}/phosphor-cooling-type"
-SYSTEMD_SERVICE_phosphor-cooling-type_append_mihawk = " ${TMPL_COOLING}"
-SYSTEMD_LINK_phosphor-cooling-type_append_mihawk = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
+FILES:phosphor-cooling-type:append:ibm-ac-server = " ${bindir}/phosphor-cooling-type"
+SYSTEMD_SERVICE:phosphor-cooling-type:append:ibm-ac-server = " ${TMPL_COOLING}"
+SYSTEMD_LINK:phosphor-cooling-type:append:ibm-ac-server = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
+FILES:phosphor-cooling-type:append:mihawk = " ${bindir}/phosphor-cooling-type"
+SYSTEMD_SERVICE:phosphor-cooling-type:append:mihawk = " ${TMPL_COOLING}"
+SYSTEMD_LINK:phosphor-cooling-type:append:mihawk = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_ibm-ac-server = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_mihawk = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE:phosphor-cooling-type:append:ibm-ac-server = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE:phosphor-cooling-type:append:mihawk = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
#These services are protected by the watchdog
-SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-control_p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-control_p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-monitor_p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-monitor_p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-control:witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-control:witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-monitor:witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-monitor:witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-control:p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-control:p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-monitor:p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-monitor:p10bmc += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf"
#These services need to be stopped when watchdog expires
-SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-control_p10bmc += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf"
-SYSTEMD_OVERRIDE_phosphor-fan-monitor_p10bmc += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-control:witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-monitor:witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-control:p10bmc += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf"
+SYSTEMD_OVERRIDE:phosphor-fan-monitor:p10bmc += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf"
# Witherspoon fan control service linking
# Link fan control init service
-SYSTEMD_SERVICE_${PN}-control_witherspoon += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
-SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE:${PN}-control:witherspoon += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
+SYSTEMD_LINK:${PN}-control:witherspoon += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}"
# Link fan control service to be started at standby
-FMT_CONTROL_STDBY_witherspoon = "../${TMPL_CONTROL}:${MULTI_USR_TGT}.wants/${INSTFMT_CONTROL}"
-SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_STDBY', 'OBMC_CHASSIS_INSTANCES')}"
+FMT_CONTROL_STDBY:witherspoon = "../${TMPL_CONTROL}:${MULTI_USR_TGT}.wants/${INSTFMT_CONTROL}"
+SYSTEMD_LINK:${PN}-control:witherspoon += "${@compose_list(d, 'FMT_CONTROL_STDBY', 'OBMC_CHASSIS_INSTANCES')}"
# Link fan control service to also start at poweron
-FMT_CONTROL_PWRON_witherspoon = "../${TMPL_CONTROL}:${POWERON_TGT}.requires/${INSTFMT_CONTROL}"
-SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON', 'OBMC_CHASSIS_INSTANCES')}"
+FMT_CONTROL_PWRON:witherspoon = "../${TMPL_CONTROL}:${POWERON_TGT}.requires/${INSTFMT_CONTROL}"
+SYSTEMD_LINK:${PN}-control:witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON', 'OBMC_CHASSIS_INSTANCES')}"
# Enable the use of JSON on the fan applications that support it
-PACKAGECONFIG_append_witherspoon = " json"
-EXTRA_OECONF_append_witherspoon = " --disable-json-control"
-RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config"
-RDEPENDS_${PN}-monitor_append_witherspoon = " phosphor-fan-monitor-config"
+PACKAGECONFIG:append:witherspoon = " json"
+EXTRA_OECONF:append:witherspoon = " --disable-json-control"
+RDEPENDS:${PN}-presence-tach:append:witherspoon = " phosphor-fan-presence-config"
+RDEPENDS:${PN}-monitor:append:witherspoon = " phosphor-fan-monitor-config"
-PACKAGECONFIG_append_p10bmc = " json sensor-monitor"
-FAN_PACKAGES_append_p10bmc = " sensor-monitor"
-RDEPENDS_${PN}-presence-tach_append_p10bmc = " phosphor-fan-presence-config"
-RDEPENDS_${PN}-monitor_append_p10bmc = " phosphor-fan-monitor-config"
+PACKAGECONFIG:append:p10bmc = " json sensor-monitor"
+FAN_PACKAGES:append:p10bmc = " sensor-monitor"
+RDEPENDS:${PN}-presence-tach:append:p10bmc = " phosphor-fan-presence-config"
+RDEPENDS:${PN}-monitor:append:p10bmc = " phosphor-fan-monitor-config"
# Install fan control JSON config files
-SRC_URI_append_p10bmc = " \
+SRC_URI:append:p10bmc = " \
file://manager.json \
file://rainier/fans.json \
file://rainier-1s4u/fans.json \
@@ -77,7 +77,7 @@ SRC_URI_append_p10bmc = " \
file://rainier-1s4u/zones.json \
file://everest/fans.json \
file://everest/zones.json"
-do_install_append_p10bmc() {
+do_install:append:p10bmc() {
# Install fan control manager config file
install -d ${D}/${datadir}/phosphor-fan-presence/control/
install -m 0644 ${WORKDIR}/manager.json ${D}/${datadir}/phosphor-fan-presence/control/
@@ -100,7 +100,7 @@ do_install_append_p10bmc() {
install -m 0644 ${WORKDIR}/everest/fans.json ${D}/${datadir}/phosphor-fan-presence/control/ibm,everest/
install -m 0644 ${WORKDIR}/everest/zones.json ${D}/${datadir}/phosphor-fan-presence/control/ibm,everest/
}
-FILES_${PN}-control_append_p10bmc = " \
+FILES:${PN}-control:append:p10bmc = " \
${datadir}/phosphor-fan-presence/control/manager.json \
${datadir}/phosphor-fan-presence/control/ibm,rainier/fans.json \
${datadir}/phosphor-fan-presence/control/ibm,rainier-1s4u/fans.json \
@@ -112,5 +112,5 @@ FILES_${PN}-control_append_p10bmc = " \
# Set the appropriate i2c address used within the overridden phosphor-fan-control@.service
# file that's used for witherspoon type(including witherspoon-tacoma) machines
-SYSTEMD_SUBSTITUTIONS_witherspoon = "ADDR:100:phosphor-fan-control@.service"
-SYSTEMD_SUBSTITUTIONS_witherspoon-tacoma = "ADDR:200:phosphor-fan-control@.service"
+SYSTEMD_SUBSTITUTIONS:witherspoon = "ADDR:100:phosphor-fan-control@.service"
+SYSTEMD_SUBSTITUTIONS:witherspoon-tacoma = "ADDR:200:phosphor-fan-control@.service"