summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config/mihawk/events.yaml50
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend10
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json121
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/monitor.yaml73
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend5
6 files changed, 185 insertions, 76 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config/mihawk/events.yaml b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config/mihawk/events.yaml
index 2efbb0c7d..721e99aca 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config/mihawk/events.yaml
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-control-events-config/mihawk/events.yaml
@@ -174,6 +174,18 @@ groups:
- /temperature/nvme21
- /temperature/nvme22
- /temperature/nvme23
+ - name: zone0_250soc
+ description: Group of nvme temperature sensors for zone 0
+ type: /xyz/openbmc_project/sensors
+ members:
+ - /temperature/250_soc0
+ - /temperature/250_soc1
+ - /temperature/250_soc2
+ - /temperature/250_soc3
+ - /temperature/250_soc4
+ - /temperature/250_soc5
+ - /temperature/250_soc6
+ - /temperature/250_soc7
matches:
- name: propertiesChanged
parameters:
@@ -582,6 +594,11 @@ events:
property:
name: Value
type: int64_t
+ - name: zone0_250soc
+ interface: xyz.openbmc_project.Sensor.Value
+ property:
+ name: Value
+ type: int64_t
triggers:
- name: init
method: getProperties
@@ -838,3 +855,36 @@ events:
delta:
value: 5
type: uint64_t
+ # Speed changes based on 250soc temps
+ - name: set_net_increase_speed
+ groups:
+ - name: zone0_250soc
+ interface: xyz.openbmc_project.Sensor.Value
+ property:
+ name: Value
+ type: int64_t
+ property:
+ value: 80000
+ type: int64_t
+ factor:
+ value: 1000
+ type: int64_t
+ delta:
+ value: 13
+ type: uint64_t
+ - name: set_net_decrease_speed
+ groups:
+ - name: zone0_250soc
+ interface: xyz.openbmc_project.Sensor.Value
+ property:
+ name: Value
+ type: int64_t
+ property:
+ value: 77000
+ type: int64_t
+ factor:
+ value: 3000
+ type: int64_t
+ delta:
+ value: 5
+ type: uint64_t
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 8f2097cc1..cb29a7483 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_witherspoon = "file://config.json"
+
+do_install_witherspoon() {
+ install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
+ install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
+}
+
+FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
+FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json
new file mode 100644
index 000000000..5923ccc42
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/config.json
@@ -0,0 +1,121 @@
+{
+ "fans": [
+ {
+ "inventory": "/system/chassis/motherboard/fan0",
+ "functional_delay": 5,
+ "allowed_out_of_range_time": 30,
+ "deviation": 15,
+ "num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "sensors": [
+ {
+ "name": "fan0_0",
+ "has_target": true
+ },
+ {
+ "name": "fan0_1",
+ "has_target": false
+ }
+ ]
+ },
+ {
+ "inventory": "/system/chassis/motherboard/fan1",
+ "functional_delay": 5,
+ "allowed_out_of_range_time": 30,
+ "deviation": 15,
+ "num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "sensors": [
+ {
+ "name": "fan1_0",
+ "has_target": true
+ },
+ {
+ "name": "fan1_1",
+ "has_target": false
+ }
+ ],
+ "condition": {
+ "name": "propertiesMatch",
+ "properties": [
+ {
+ "object": "/xyz/openbmc_project/inventory/system/chassis",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.CoolingType",
+ "property": {
+ "name": "WaterCooled",
+ "type": "bool",
+ "value": false
+ }
+ }
+ ]
+ }
+ },
+ {
+ "inventory": "/system/chassis/motherboard/fan2",
+ "functional_delay": 5,
+ "allowed_out_of_range_time": 30,
+ "deviation": 15,
+ "num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "sensors": [
+ {
+ "name": "fan2_0",
+ "has_target": true
+ },
+ {
+ "name": "fan2_1",
+ "has_target": false
+ }
+ ]
+ },
+ {
+ "inventory": "/system/chassis/motherboard/fan3",
+ "functional_delay": 5,
+ "allowed_out_of_range_time": 30,
+ "deviation": 15,
+ "num_sensors_nonfunc_for_fan_nonfunc": 1,
+ "sensors": [
+ {
+ "name": "fan3_0",
+ "has_target": true
+ },
+ {
+ "name": "fan3_1",
+ "has_target": false
+ }
+ ]
+ }
+ ],
+ "sensor_trust_groups": [
+ {
+ "class": "NonzeroSpeed",
+ "group": [
+ {
+ "name": "fan0_1"
+ },
+ {
+ "name": "fan1_1"
+ },
+ {
+ "name": "fan2_1"
+ },
+ {
+ "name": "fan3_1"
+ },
+ {
+ "name": "fan0_0",
+ "in_trust": false
+ },
+ {
+ "name": "fan1_0",
+ "in_trust": false
+ },
+ {
+ "name": "fan2_0",
+ "in_trust": false
+ },
+ {
+ "name": "fan3_0",
+ "in_trust": false
+ }
+ ]
+ }
+ ]
+}
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/monitor.yaml b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/monitor.yaml
deleted file mode 100644
index 5db7966fa..000000000
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config/witherspoon/monitor.yaml
+++ /dev/null
@@ -1,73 +0,0 @@
-fans:
- - inventory: /system/chassis/motherboard/fan0
- functional_delay: 5
- allowed_out_of_range_time: 30
- deviation: 15
- num_sensors_nonfunc_for_fan_nonfunc: 1
- sensors:
- - name: fan0_0
- has_target: true
- - name: fan0_1
- has_target: false
-
- - inventory: /system/chassis/motherboard/fan1
- functional_delay: 5
- allowed_out_of_range_time: 30
- deviation: 15
- num_sensors_nonfunc_for_fan_nonfunc: 1
- sensors:
- - name: fan1_0
- has_target: true
- - name: fan1_1
- has_target: false
- # Create fan1 inventory & sensors on air cooled only
- condition:
- name: propertiesMatch
- properties:
- - object: /xyz/openbmc_project/inventory/system/chassis
- interface: xyz.openbmc_project.Inventory.Decorator.CoolingType
- property:
- name: WaterCooled
- type: bool
- value: false
-
- - inventory: /system/chassis/motherboard/fan2
- functional_delay: 5
- allowed_out_of_range_time: 30
- deviation: 15
- num_sensors_nonfunc_for_fan_nonfunc: 1
- sensors:
- - name: fan2_0
- has_target: true
- - name: fan2_1
- has_target: false
-
- - inventory: /system/chassis/motherboard/fan3
- functional_delay: 5
- allowed_out_of_range_time: 30
- deviation: 15
- num_sensors_nonfunc_for_fan_nonfunc: 1
- sensors:
- - name: fan3_0
- has_target: true
- - name: fan3_1
- has_target: false
-
-sensor_trust_groups:
- - class: NonzeroSpeed
- group:
- # Include all _1 fans to determine trust
- - name: fan0_1
- - name: fan1_1
- - name: fan2_1
- - name: fan3_1
- # Add all _0 fans to be included in trust result effects,
- # but not in determining trust
- - name: fan0_0
- in_trust: false
- - name: fan1_0
- in_trust: false
- - name: fan2_0
- in_trust: false
- - name: fan3_0
- in_trust: false
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf b/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf
index e72de888f..38a37cbd1 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf
@@ -1,5 +1,3 @@
[Unit]
#These overrides allow the fan watchdog to take over when this service dies
OnFailure=fan-watchdog-monitor@%n.service
-StartLimitIntervalSec=5
-StartLimitBurst=3
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 10f3f2284..834768cee 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,3 +1,5 @@
+SRCREV = "8e1b382122fed73e788d44f3a67cecbfbcc6972e"
+
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
# Package configuration
@@ -56,8 +58,9 @@ FMT_CONTROL_PWRON_witherspoon = "../${TMPL_CONTROL}:${POWERON_TGT}.requires/${IN
SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON', 'OBMC_CHASSIS_INSTANCES')}"
# Enable the use of JSON on the fan applications that support it
-EXTRA_OECONF_append_witherspoon = " --enable-json"
+EXTRA_OECONF_append_witherspoon = " --enable-json --disable-json-control"
RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config"
+RDEPENDS_${PN}-monitor_append_witherspoon = " phosphor-fan-monitor-config"
# Set the appropriate i2c address used within the overridden phosphor-fan-control@.service
# file that's used for witherspoon type(including witherspoon-tacoma) machines