summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/fans
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor/fans')
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog.bb (renamed from meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog.bb)12
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/fan-watchdog-monitor@.service (renamed from meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-fan-watchdog-monitor@.service)0
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/fan-watchdog.service (renamed from meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-fan-watchdog.service)4
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/fan-watchdog.conf (renamed from meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/obmc/witherspoon-fan-watchdog/fan-watchdog.conf)0
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/reset-fan-watchdog.conf4
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/reset-fan-watchdog.service (renamed from meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service)4
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/fan-watchdog.conf3
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/reset-fan-watchdog.conf (renamed from meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/obmc/witherspoon-fan-watchdog/reset-fan-watchdog.conf)0
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/fan-watchdog.conf3
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/reset-fan-watchdog.conf4
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/fan-watchdog.conf3
-rw-r--r--meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/reset-fan-watchdog.conf4
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf2
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend6
14 files changed, 38 insertions, 11 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog.bb b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
index 93c8d457b..d71b378cf 100644
--- a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Witherspoon fan watchdog services"
+SUMMARY = "Fan watchdog services"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
@@ -8,16 +8,16 @@ inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
RDEPENDS_${PN} += "busybox"
-RESET_SERVICE = "witherspoon-reset-fan-watchdog.service"
+RESET_SERVICE = "reset-fan-watchdog.service"
TGTFMT = "obmc-chassis-poweron@0.target"
RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}"
-MONITOR_SERVICE = "witherspoon-fan-watchdog-monitor@.service"
+MONITOR_SERVICE = "fan-watchdog-monitor@.service"
-WATCHDOG_SERVICE = "witherspoon-fan-watchdog.service"
+WATCHDOG_SERVICE = "fan-watchdog.service"
WATCHDOG_FMT = "../${WATCHDOG_SERVICE}:${TGTFMT}.requires/${WATCHDOG_SERVICE}"
SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}"
SYSTEMD_LINK_${PN} += "${RESET_FMT} ${WATCHDOG_FMT}"
-SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/reset-fan-watchdog.conf"
-SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/witherspoon-fan-watchdog/fan-watchdog.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/reset-fan-watchdog.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/fan-watchdog.conf"
diff --git a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-fan-watchdog-monitor@.service b/meta-ibm/recipes-phosphor/fans/fan-watchdog/fan-watchdog-monitor@.service
index 945561b50..945561b50 100644
--- a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-fan-watchdog-monitor@.service
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/fan-watchdog-monitor@.service
diff --git a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-fan-watchdog.service b/meta-ibm/recipes-phosphor/fans/fan-watchdog/fan-watchdog.service
index 597ee03cb..3f941836d 100644
--- a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-fan-watchdog.service
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/fan-watchdog.service
@@ -1,11 +1,11 @@
[Unit]
-Description=Witherspoon Fan Watchdog Daemon
+Description=Fan Watchdog Daemon
Wants=phosphor-fan-monitor-init@0.service
Before=phosphor-fan-monitor-init@0.service
Conflicts=obmc-fan-watchdog-takeover.target
[Service]
-EnvironmentFile={envfiledir}/obmc/witherspoon-fan-watchdog/fan-watchdog.conf
+EnvironmentFile={envfiledir}/obmc/fan-watchdog/fan-watchdog.conf
ExecStart=/sbin/watchdog -T ${{TIMEOUT}} -t ${{INTERVAL}} -F ${{DEVICE}}
KillSignal=SIGKILL
diff --git a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/obmc/witherspoon-fan-watchdog/fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/fan-watchdog.conf
index ce7824ccb..ce7824ccb 100644
--- a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/obmc/witherspoon-fan-watchdog/fan-watchdog.conf
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/fan-watchdog.conf
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/reset-fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/reset-fan-watchdog.conf
new file mode 100644
index 000000000..98cb60288
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/rainier/obmc/fan-watchdog/reset-fan-watchdog.conf
@@ -0,0 +1,4 @@
+GPIO_PATH=/dev/gpiochip0
+GPIO=114
+DELAY=1
+ACTION=low_high
diff --git a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service b/meta-ibm/recipes-phosphor/fans/fan-watchdog/reset-fan-watchdog.service
index 675a67269..f6248f0ee 100644
--- a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/witherspoon-reset-fan-watchdog.service
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/reset-fan-watchdog.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Witherspoon Fan Watchdog Reset
+Description=Fan Watchdog Reset
Wants=phosphor-fan-monitor-init@0.service
Before=phosphor-fan-monitor-init@0.service
Conflicts=obmc-chassis-poweroff@0.target
@@ -7,6 +7,6 @@ Conflicts=obmc-chassis-poweroff@0.target
[Service]
Type=oneshot
RemainAfterExit=yes
-EnvironmentFile={envfiledir}/obmc/witherspoon-fan-watchdog/reset-fan-watchdog.conf
+EnvironmentFile={envfiledir}/obmc/fan-watchdog/reset-fan-watchdog.conf
ExecStart=/usr/bin/env phosphor-gpio-util -p ${{GPIO_PATH}} -g ${{GPIO}} -a ${{ACTION}} -d ${{DELAY}}
SyslogIdentifier=phosphor-gpio-util
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/fan-watchdog.conf
new file mode 100644
index 000000000..ce7824ccb
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/fan-watchdog.conf
@@ -0,0 +1,3 @@
+TIMEOUT=5
+INTERVAL=1
+DEVICE=/dev/watchdog0
diff --git a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/obmc/witherspoon-fan-watchdog/reset-fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/reset-fan-watchdog.conf
index b4e5ce74e..b4e5ce74e 100644
--- a/meta-ibm/recipes-phosphor/fans/witherspoon-fan-watchdog/obmc/witherspoon-fan-watchdog/reset-fan-watchdog.conf
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/swift/obmc/fan-watchdog/reset-fan-watchdog.conf
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/fan-watchdog.conf
new file mode 100644
index 000000000..ce7824ccb
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/fan-watchdog.conf
@@ -0,0 +1,3 @@
+TIMEOUT=5
+INTERVAL=1
+DEVICE=/dev/watchdog0
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/reset-fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/reset-fan-watchdog.conf
new file mode 100644
index 000000000..98cb60288
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon-tacoma/obmc/fan-watchdog/reset-fan-watchdog.conf
@@ -0,0 +1,4 @@
+GPIO_PATH=/dev/gpiochip0
+GPIO=114
+DELAY=1
+ACTION=low_high
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/fan-watchdog.conf
new file mode 100644
index 000000000..ce7824ccb
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/fan-watchdog.conf
@@ -0,0 +1,3 @@
+TIMEOUT=5
+INTERVAL=1
+DEVICE=/dev/watchdog0
diff --git a/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/reset-fan-watchdog.conf b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/reset-fan-watchdog.conf
new file mode 100644
index 000000000..b4e5ce74e
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/fan-watchdog/witherspoon/obmc/fan-watchdog/reset-fan-watchdog.conf
@@ -0,0 +1,4 @@
+GPIO_PATH=/dev/gpiochip0
+GPIO=109
+DELAY=1
+ACTION=low_high
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf b/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf
index 023e61a64..e72de888f 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan/fan-watchdog-monitor.conf
@@ -1,5 +1,5 @@
[Unit]
#These overrides allow the fan watchdog to take over when this service dies
-OnFailure=witherspoon-fan-watchdog-monitor@%n.service
+OnFailure=fan-watchdog-monitor@%n.service
StartLimitIntervalSec=5
StartLimitBurst=3
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 713c0c6a2..10f3f2284 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -34,10 +34,16 @@ SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:
SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf"
SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf"
SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE_phosphor-fan-control_rainier += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE_phosphor-fan-control_rainier += "fan-watchdog-monitor.conf:phosphor-fan-control@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE_phosphor-fan-monitor_rainier += "fan-watchdog-monitor.conf:phosphor-fan-monitor-init@0.service.d/fan-watchdog-monitor.conf"
+SYSTEMD_OVERRIDE_phosphor-fan-monitor_rainier += "fan-watchdog-monitor.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-monitor.conf"
#These services need to be stopped when watchdog expires
SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf"
SYSTEMD_OVERRIDE_phosphor-fan-monitor_witherspoon += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf"
+SYSTEMD_OVERRIDE_phosphor-fan-control_rainier += "fan-watchdog-conflicts.conf:phosphor-fan-control@0.service.d/fan-watchdog-conflicts.conf"
+SYSTEMD_OVERRIDE_phosphor-fan-monitor_rainier += "fan-watchdog-conflicts.conf:phosphor-fan-monitor@0.service.d/fan-watchdog-conflicts.conf"
# Witherspoon fan control service linking
# Link fan control init service