summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/logging
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor/logging')
-rw-r--r--meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb b/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
index 43a20c0f3..89f8e35dd 100644
--- a/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
+++ b/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
@@ -16,10 +16,11 @@ inherit obmc-phosphor-systemd
inherit phosphor-dbus-yaml
DEPENDS += " \
+ ${PYTHON_PN}-pyyaml-native \
+ autoconf-archive-native \
ibm-dbus-interfaces \
- phosphor-logging \
nlohmann-json \
- autoconf-archive-native \
+ phosphor-logging \
sdbusplus \
"
@@ -58,19 +59,10 @@ do_report(){
${S}/create_error_reports.py \
-p ${D}/${datadir}/ibm-logging/policy.json \
- -y ${STAGING_DIR_NATIVE}${yaml_dir} \
+ -y ${STAGING_DIR_TARGET}${yaml_dir} \
-e ${WORKDIR}/build/all_errors.json \
-x ${WORKDIR}/build/policy_crosscheck.txt
}
-addtask report
-
-#Collect all of the error YAML files into our recipe-sysroot-native dir.
-do_report[depends] = " \
- ibm-logging:do_install \
- phosphor-logging-error-logs-native:do_populate_sysroot \
- phosphor-dbus-interfaces-native:do_populate_sysroot \
- openpower-occ-control-native:do_populate_sysroot \
- openpower-debug-collector-native:do_populate_sysroot \
- "
+addtask report after do_install