summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/settings
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor/settings')
-rw-r--r--meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml74
-rw-r--r--meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml41
-rw-r--r--meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend4
3 files changed, 118 insertions, 1 deletions
diff --git a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml
new file mode 100644
index 000000000..ecc95317f
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-rainier.override.yml
@@ -0,0 +1,74 @@
+/xyz/openbmc_project/network/hypervisor:
+ - Interface: xyz.openbmc_project.Network.SystemConfiguration
+ Properties:
+ HostName:
+ Default: '""'
+ DefaultGateway:
+ Default: '"0.0.0.0"'
+
+/xyz/openbmc_project/network/hypervisor/eth0:
+ - Interface: xyz.openbmc_project.Network.MACAddress
+ Properties:
+ MACAddress:
+ Default: '"00:00:00:00:00:00"'
+ Validation:
+ Type: "regex"
+ Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
+ - Interface: xyz.openbmc_project.Network.EthernetInterface
+ Properties:
+ DHCPEnabled:
+ Default: EthernetInterface::DHCPConf::none
+
+/xyz/openbmc_project/network/hypervisor/eth0/ipv4/addr0:
+ - Interface: xyz.openbmc_project.Network.IP
+ Properties:
+ Address:
+ Default: '"0.0.0.0"'
+ PrefixLength:
+ Default: 0
+ Validation:
+ Type: "range"
+ Validator: 0..32
+ Unit: "bits"
+ Origin:
+ Default: IP::AddressOrigin::Static
+ Type:
+ Default: IP::Protocol::IPv4
+ - Interface: xyz.openbmc_project.Object.Enable
+ Properties:
+ Enabled:
+ Default: 'false'
+
+/xyz/openbmc_project/network/hypervisor/eth1:
+ - Interface: xyz.openbmc_project.Network.MACAddress
+ Properties:
+ MACAddress:
+ Default: '"00:00:00:00:00:00"'
+ Validation:
+ Type: "regex"
+ Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
+ - Interface: xyz.openbmc_project.Network.EthernetInterface
+ Properties:
+ DHCPEnabled:
+ Default: EthernetInterface::DHCPConf::none
+
+/xyz/openbmc_project/network/hypervisor/eth1/ipv4/addr0:
+ - Interface: xyz.openbmc_project.Network.IP
+ Properties:
+ Address:
+ Default: '"0.0.0.0"'
+ PrefixLength:
+ Default: 0
+ Validation:
+ Type: "range"
+ Validator: 0..32
+ Unit: "bits"
+ Origin:
+ Default: IP::AddressOrigin::Static
+ Type:
+ Default: IP::Protocol::IPv4
+ - Interface: xyz.openbmc_project.Object.Enable
+ Properties:
+ Enabled:
+ Default: 'false'
+
diff --git a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml
new file mode 100644
index 000000000..e452cbf68
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager/HypervisorInterface-default-tacoma.override.yml
@@ -0,0 +1,41 @@
+/xyz/openbmc_project/network/hypervisor:
+ - Interface: xyz.openbmc_project.Network.SystemConfiguration
+ Properties:
+ HostName:
+ Default: '""'
+ DefaultGateway:
+ Default: '"0.0.0.0"'
+
+/xyz/openbmc_project/network/hypervisor/eth0:
+ - Interface: xyz.openbmc_project.Network.MACAddress
+ Properties:
+ MACAddress:
+ Default: '"00:00:00:00:00:00"'
+ Validation:
+ Type: "regex"
+ Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
+ - Interface: xyz.openbmc_project.Network.EthernetInterface
+ Properties:
+ DHCPEnabled:
+ Default: EthernetInterface::DHCPConf::none
+
+/xyz/openbmc_project/network/hypervisor/eth0/ipv4/addr0:
+ - Interface: xyz.openbmc_project.Network.IP
+ Properties:
+ Address:
+ Default: '"0.0.0.0"'
+ PrefixLength:
+ Default: 0
+ Validation:
+ Type: "range"
+ Validator: 0..32
+ Unit: "bits"
+ Origin:
+ Default: IP::AddressOrigin::Static
+ Type:
+ Default: IP::Protocol::IPv4
+ - Interface: xyz.openbmc_project.Object.Enable
+ Properties:
+ Enabled:
+ Default: 'false'
+
diff --git a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
index 1068e1d00..3c658ae0c 100644
--- a/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -1,5 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_append_ibm-ac-server = " file://TPMEnable-default-true.override.yml"
-SRC_URI_append_ibm-ac-server += " file://ClearHostSecurityKeys-default-zero.override.yml"
+SRC_URI_append_ibm-ac-server = " file://ClearHostSecurityKeys-default-zero.override.yml"
SRC_URI_append_mihawk = " file://TPMEnable-default-true.override.yml"
SRC_URI_append = " file://ibm_settings.override.yml"
+SRC_URI_append_rainier = " file://HypervisorInterface-default-rainier.override.yml"
+SRC_URI_append_witherspoon-tacoma = " file://HypervisorInterface-default-tacoma.override.yml"