summaryrefslogtreecommitdiff
path: root/meta-inspur/meta-on5263m5
diff options
context:
space:
mode:
Diffstat (limited to 'meta-inspur/meta-on5263m5')
-rw-r--r--meta-inspur/meta-on5263m5/conf/layer.conf2
-rw-r--r--meta-inspur/meta-on5263m5/conf/local.conf.sample17
-rw-r--r--meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb2
-rw-r--r--meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb26
-rw-r--r--meta-inspur/meta-on5263m5/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend6
5 files changed, 25 insertions, 28 deletions
diff --git a/meta-inspur/meta-on5263m5/conf/layer.conf b/meta-inspur/meta-on5263m5/conf/layer.conf
index 59a0a8a6a..2dcf54c88 100644
--- a/meta-inspur/meta-on5263m5/conf/layer.conf
+++ b/meta-inspur/meta-on5263m5/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "on5263m5-layer"
BBFILE_PATTERN_on5263m5-layer = "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_on5263m5-layer = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_on5263m5-layer = "hardknott honister"
diff --git a/meta-inspur/meta-on5263m5/conf/local.conf.sample b/meta-inspur/meta-on5263m5/conf/local.conf.sample
index 56a7e9621..6e212f30c 100644
--- a/meta-inspur/meta-on5263m5/conf/local.conf.sample
+++ b/meta-inspur/meta-on5263m5/conf/local.conf.sample
@@ -114,7 +114,7 @@ PACKAGE_CLASSES ?= "package_rpm"
# running the build on (i.e. building i686 packages on an x86_64 host).
# Supported values are i686 and x86_64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
+SANITY_TESTED_DISTROS:append ?= " RedHatEnterpriseWorkstation-6.*"
#
# Extra image configuration defaults
@@ -138,7 +138,7 @@ SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
#
# Additional image features
@@ -190,7 +190,7 @@ PATCHRESOLVE = "noop"
# files and damages the build in ways which may not be easily recoverable.
# It's necessary to monitor /tmp, if there is no space left the build will fail
# with very exotic errors.
-BB_DISKMON_DIRS = "\
+BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
@@ -224,17 +224,14 @@ BB_DISKMON_DIRS = "\
# By default qemu will build with a builtin VNC server where graphical output can be
# seen. The two lines below enable the SDL backend too. This assumes there is a
# libsdl library available on your build system.
-PACKAGECONFIG_append_pn-qemu-native = " sdl"
-PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+PACKAGECONFIG:append:pn-qemu-native = " sdl"
+PACKAGECONFIG:append:pn-nativesdk-qemu = " sdl"
#ASSUME_PROVIDED += "libsdl-native"
# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
-CONF_VERSION = "1"
+CONF_VERSION = "2"
# Set the root password to '0penBmc'
-INHERIT += "extrausers"
-EXTRA_USERS_PARAMS = " \
- usermod -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' root; \
- "
+# Defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc
diff --git a/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb b/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
index 2174da950..441f21819 100644
--- a/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
+++ b/meta-inspur/meta-on5263m5/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
@@ -17,7 +17,7 @@ DEPENDS += "phosphor-logging"
DEPENDS += "gpioplus"
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.inspur.identify_led.controller.service"
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.inspur.identify_led.controller.service"
SRC_URI = "git://github.com/inspur-bmc/inspur-uuid.git"
diff --git a/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb b/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb
index 517b9eb77..68a2184cf 100644
--- a/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb
+++ b/meta-inspur/meta-on5263m5/recipes-inspur/packagegroups/packagegroup-inspur-apps.bb
@@ -16,31 +16,31 @@ PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
-SUMMARY_${PN}-chassis = "Inspur Chassis"
-RDEPENDS_${PN}-chassis = " \
+SUMMARY:${PN}-chassis = "Inspur Chassis"
+RDEPENDS:${PN}-chassis = " \
obmc-control-chassis \
obmc-op-control-power \
obmc-host-failure-reboots \
"
-SUMMARY_${PN}-fans = "Inspur Fans"
-RDEPENDS_${PN}-fans = ""
+SUMMARY:${PN}-fans = "Inspur Fans"
+RDEPENDS:${PN}-fans = ""
-SUMMARY_${PN}-flash = "Inspur Flash"
-RDEPENDS_${PN}-flash = " \
+SUMMARY:${PN}-flash = "Inspur Flash"
+RDEPENDS:${PN}-flash = " \
obmc-flash-bmc \
obmc-mgr-download \
obmc-control-bmc \
"
-SUMMARY_${PN}-system = "Inspur System"
-RDEPENDS_${PN}-system = " \
+SUMMARY:${PN}-system = "Inspur System"
+RDEPENDS:${PN}-system = " \
bmcweb \
entity-manager \
- phosphor-webui \
+ webui-vue \
"
diff --git a/meta-inspur/meta-on5263m5/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-inspur/meta-on5263m5/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index ac03883e8..863f59c38 100644
--- a/meta-inspur/meta-on5263m5/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-inspur/meta-on5263m5/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-EXTRA_OEMESON_append_on5263m5= " -Dnegative-errno-on-fail=true"
+EXTRA_OEMESON:append:on5263m5= " -Dnegative-errno-on-fail=true"
CHIPS = " \
bus@1e78a000/i2c-bus@1c0/tmp112@48 \
@@ -16,4 +16,4 @@ ITEMS += "iio-hwmon.conf"
ENVS = "obmc/hwmon/{0}"
-SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'ITEMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN} += "${@compose_list(d, 'ENVS', 'ITEMS')}"