summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-openbmc/conf')
-rw-r--r--meta-intel-openbmc/conf/layer.conf12
-rw-r--r--meta-intel-openbmc/conf/machine/include/intel.inc23
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-intel-openbmc/conf/layer.conf b/meta-intel-openbmc/conf/layer.conf
new file mode 100644
index 000000000..e515b5f57
--- /dev/null
+++ b/meta-intel-openbmc/conf/layer.conf
@@ -0,0 +1,12 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "intel"
+BBFILE_PATTERN_intel = "^${LAYERDIR}/"
+LAYERVERSION_intel = "1"
+LAYERSERIES_COMPAT_intel = "dunfell gatesgarth"
+LAYERDEPENDS_intel = "phosphor-layer"
diff --git a/meta-intel-openbmc/conf/machine/include/intel.inc b/meta-intel-openbmc/conf/machine/include/intel.inc
new file mode 100644
index 000000000..738d103e5
--- /dev/null
+++ b/meta-intel-openbmc/conf/machine/include/intel.inc
@@ -0,0 +1,23 @@
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-ctl \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= "obmc-op-control-host"
+PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
+#PREFERRED_PROVIDER_virtual/obmc-gpio-monitor ?= "phosphor-gpio-monitor"
+
+OVERRIDES .= ":intel"