summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc/meta-common/recipes-intel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-openbmc/meta-common/recipes-intel')
-rwxr-xr-xmeta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb10
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb24
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb2
3 files changed, 18 insertions, 18 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index 7327630f5..77d945c45 100755
--- a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -21,12 +21,12 @@ LIBRARY_NAMES = "libzinteloemcmds.so"
HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
-do_install_append(){
+do_install:append(){
install -d ${D}${includedir}/intel-ipmi-oem
install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
}
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
index 8c0dfbf1c..098a91eb7 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
@@ -16,29 +16,29 @@ PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
-SUMMARY_${PN}-chassis = "Intel Chassis"
-RDEPENDS_${PN}-chassis = " \
+SUMMARY:${PN}-chassis = "Intel Chassis"
+RDEPENDS:${PN}-chassis = " \
x86-power-control \
obmc-host-failure-reboots \
"
-SUMMARY_${PN}-fans = "Intel Fans"
-RDEPENDS_${PN}-fans = " \
+SUMMARY:${PN}-fans = "Intel Fans"
+RDEPENDS:${PN}-fans = " \
phosphor-pid-control \
"
-SUMMARY_${PN}-flash = "Intel Flash"
-RDEPENDS_${PN}-flash = " \
+SUMMARY:${PN}-flash = "Intel Flash"
+RDEPENDS:${PN}-flash = " \
obmc-control-bmc \
"
-SUMMARY_${PN}-system = "Intel System"
-RDEPENDS_${PN}-system = " \
+SUMMARY:${PN}-system = "Intel System"
+RDEPENDS:${PN}-system = " \
bmcweb \
entity-manager \
intel-ipmi-oem \
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
index effd89b40..76d125ce8 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
@@ -12,7 +12,7 @@ SRCREV = "bcc7ce1f418c1a16a7868fee62499fa677242254"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.PFR.Manager.service"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.PFR.Manager.service"
DEPENDS += " \
sdbusplus \