summaryrefslogtreecommitdiff
path: root/meta-intel/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel/conf')
-rw-r--r--meta-intel/conf/layer.conf10
-rw-r--r--meta-intel/conf/machine/include/intel.inc21
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-intel/conf/layer.conf b/meta-intel/conf/layer.conf
new file mode 100644
index 000000000..b19eca204
--- /dev/null
+++ b/meta-intel/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "intel"
+BBFILE_PATTERN_intel = ""
+LAYERVERSION_intel = "1"
diff --git a/meta-intel/conf/machine/include/intel.inc b/meta-intel/conf/machine/include/intel.inc
new file mode 100644
index 000000000..088429419
--- /dev/null
+++ b/meta-intel/conf/machine/include/intel.inc
@@ -0,0 +1,21 @@
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-ctl \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-intel-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= "obmc-op-control-host"
+PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = ""
+#PREFERRED_PROVIDER_virtual/obmc-gpio-monitor ?= "phosphor-gpio-monitor"