summaryrefslogtreecommitdiff
path: root/meta-intel/meta-common/recipes-intel/pfr/pfr-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel/meta-common/recipes-intel/pfr/pfr-manager_git.bb')
-rw-r--r--meta-intel/meta-common/recipes-intel/pfr/pfr-manager_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-intel/pfr/pfr-manager_git.bb b/meta-intel/meta-common/recipes-intel/pfr/pfr-manager_git.bb
new file mode 100644
index 000000000..45e288dc0
--- /dev/null
+++ b/meta-intel/meta-common/recipes-intel/pfr/pfr-manager_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "PFR Manager Service"
+DESCRIPTION = "Daemon to handle all PFR functionalities"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake systemd
+
+SRC_URI = "git://github.com/openbmc/pfr-manager"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "67d184ce46b59d413302b95f1a06cfed342c4bc8"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.PFR.Manager.service"
+
+DEPENDS += " \
+ sdbusplus \
+ phosphor-logging \
+ boost \
+ i2c-tools \
+ "