summaryrefslogtreecommitdiff
path: root/meta-lenovo/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-lenovo/conf/layer.conf')
-rw-r--r--meta-lenovo/conf/layer.conf18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-lenovo/conf/layer.conf b/meta-lenovo/conf/layer.conf
new file mode 100644
index 000000000..30d2bbc8e
--- /dev/null
+++ b/meta-lenovo/conf/layer.conf
@@ -0,0 +1,18 @@
+#"Copyright ? 2019-present Lenovo
+#Licensed under BSD-3, see COPYING.BSD file for details."
+
+
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "lenovo-layer"
+BBFILE_PATTERN_lenovo-layer = ""
+LAYERVERSION_lenovo-layer = "1"
+LAYERSERIES_COMPAT_lenovo-layer = "thud warrior"
+
+# Provide a variable that points the base of the lenovo layer.
+LENOVOBASE = '${@os.path.normpath("${LAYERDIR}/")}'