summaryrefslogtreecommitdiff
path: root/meta-lenovo/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-lenovo/conf')
-rw-r--r--meta-lenovo/conf/layer.conf18
-rw-r--r--meta-lenovo/conf/machine/include/lenovo.inc14
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-lenovo/conf/layer.conf b/meta-lenovo/conf/layer.conf
new file mode 100644
index 000000000..30d2bbc8e
--- /dev/null
+++ b/meta-lenovo/conf/layer.conf
@@ -0,0 +1,18 @@
+#"Copyright ? 2019-present Lenovo
+#Licensed under BSD-3, see COPYING.BSD file for details."
+
+
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "lenovo-layer"
+BBFILE_PATTERN_lenovo-layer = ""
+LAYERVERSION_lenovo-layer = "1"
+LAYERSERIES_COMPAT_lenovo-layer = "thud warrior"
+
+# Provide a variable that points the base of the lenovo layer.
+LENOVOBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-lenovo/conf/machine/include/lenovo.inc b/meta-lenovo/conf/machine/include/lenovo.inc
new file mode 100644
index 000000000..9ae182a76
--- /dev/null
+++ b/meta-lenovo/conf/machine/include/lenovo.inc
@@ -0,0 +1,14 @@
+#"Copyright ? 2019-present Lenovo
+#Licensed under BSD-3, see COPYING.BSD file for details."
+
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"