summaryrefslogtreecommitdiff
path: root/meta-lenovo/meta-hr630
diff options
context:
space:
mode:
Diffstat (limited to 'meta-lenovo/meta-hr630')
-rw-r--r--meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json25
-rw-r--r--meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend4
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..d0441a69b
--- /dev/null
+++ b/meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,25 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ ],
+ "reset_outs": [
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "PGOOD",
+ "pin": "Z1",
+ "direction": "in"
+ },
+ {
+ "name": "POWER_UP_PIN",
+ "pin": "I0",
+ "direction": "both"
+ }
+ ]
+}
diff --git a/meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
new file mode 100644
index 000000000..5bb2557a2
--- /dev/null
+++ b/meta-lenovo/meta-hr630/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -0,0 +1,4 @@
+#"Copyright (c) 2019-present Lenovo
+#Licensed under BSD-3, see COPYING.BSD file for details."
+
+FILESEXTRAPATHS_prepend_hr630 := "${THISDIR}/${PN}:"