summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/MAINTAINERS2
-rw-r--r--meta-nuvoton/conf/layer.conf2
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc2
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton.inc4
-rw-r--r--meta-nuvoton/recipes-kernel/linux/linux-nuvoton.inc2
-rw-r--r--meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb6
-rw-r--r--meta-nuvoton/recipes-nuvoton/loadsvf/loadsvf_git.bb14
7 files changed, 26 insertions, 6 deletions
diff --git a/meta-nuvoton/MAINTAINERS b/meta-nuvoton/MAINTAINERS
index 3bc2ef64b..3698cf2e6 100644
--- a/meta-nuvoton/MAINTAINERS
+++ b/meta-nuvoton/MAINTAINERS
@@ -43,3 +43,5 @@ START OF MAINTAINERS LIST
-------------------------
M: Benjamin Fair <benjaminfair@google.com> <benjaminfair!>
+R: Fran Hsu <fran.hsu@quantatw.com> <franhsu!>
+R: Tomer Maimon <tmaimon77@gmail.com>
diff --git a/meta-nuvoton/conf/layer.conf b/meta-nuvoton/conf/layer.conf
index 19af7e976..eaf9a52bd 100644
--- a/meta-nuvoton/conf/layer.conf
+++ b/meta-nuvoton/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "nuvoton-layer"
BBFILE_PATTERN_nuvoton-layer = ""
LAYERVERSION_nuvoton-layer = "1"
-LAYERSERIES_COMPAT_nuvoton-layer = "warrior zeus dunfell"
+LAYERSERIES_COMPAT_nuvoton-layer = "dunfell gatesgarth"
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc b/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc
index 7ab0dedbd..ca05f2b65 100644
--- a/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-common-nuvoton.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
UBRANCH = "npcm7xx-v2019.01"
SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
-SRCREV = "adb4ac1af3f952ee6248e839af0c8600a0642d4b"
+SRCREV = "6870e66f6bf0653a1e2f2677c5f86b2056454032"
S = "${WORKDIR}/git"
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton.inc b/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton.inc
index 55d8b4787..60c722da5 100644
--- a/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton.inc
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton.inc
@@ -68,6 +68,10 @@ UBOOT_EXTLINUX_INSTALL_DIR ?= "/boot/extlinux"
UBOOT_EXTLINUX_CONF_NAME ?= "extlinux.conf"
UBOOT_EXTLINUX_SYMLINK ?= "${UBOOT_EXTLINUX_CONF_NAME}-${MACHINE}-${PR}"
+# Set Device tree from the machine config automatically
+UBOOT_MAKE_TARGET += '${@"" if d.getVar("UBOOT_DEVICETREE") is None \
+ else " DEVICE_TREE=" + d.getVar("UBOOT_DEVICETREE")}'
+
# returns all the elements from the src uri that are .cfg files
def find_cfgs(d):
sources=src_patches(d, True)
diff --git a/meta-nuvoton/recipes-kernel/linux/linux-nuvoton.inc b/meta-nuvoton/recipes-kernel/linux/linux-nuvoton.inc
index 5380478e8..fd680328a 100644
--- a/meta-nuvoton/recipes-kernel/linux/linux-nuvoton.inc
+++ b/meta-nuvoton/recipes-kernel/linux/linux-nuvoton.inc
@@ -18,4 +18,4 @@ inherit kernel
require recipes-kernel/linux/linux-yocto.inc
# From 4.16+ the COPYING file changed
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
diff --git a/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb b/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb
index 95981f4b3..10336753d 100644
--- a/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb
+++ b/meta-nuvoton/recipes-kernel/linux/linux-nuvoton_git.bb
@@ -1,6 +1,6 @@
-KBRANCH ?= "dev-5.4"
-LINUX_VERSION ?= "5.4.32"
+KBRANCH ?= "dev-5.8"
+LINUX_VERSION ?= "5.8.5"
-SRCREV="7dc9442bbe7d0d1512c64a97b7cc58fed2b38ba4"
+SRCREV="0dd0c8c492fa70707ca4f0d36dcb2e3c64105b16"
require linux-nuvoton.inc
diff --git a/meta-nuvoton/recipes-nuvoton/loadsvf/loadsvf_git.bb b/meta-nuvoton/recipes-nuvoton/loadsvf/loadsvf_git.bb
new file mode 100644
index 000000000..a0206da9c
--- /dev/null
+++ b/meta-nuvoton/recipes-nuvoton/loadsvf/loadsvf_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "CPLD/FPGA Programmer"
+PR = "r1"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/Nuvoton-Israel/loadsvf.git"
+SRCREV = "69d077629d5c85309c8dc17623d8586464db5c50"
+S = "${WORKDIR}/git/"
+
+inherit autotools pkgconfig
+
+DEPENDS += "autoconf-archive-native"
+