summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-arm/meta-qualcomm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-arm/meta-qualcomm')
-rw-r--r--meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb18
-rwxr-xr-xmeta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config/led.yaml15
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb
new file mode 100644
index 000000000..24cf27276
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for Centriq2400 REP"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config/led.yaml b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config/led.yaml
new file mode 100755
index 000000000..25d2ef48c
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/leds/centriq2400-rep-led-manager-config/led.yaml
@@ -0,0 +1,15 @@
+bmc_booted:
+power_on:
+ Power_ID_LED:
+ Action: 'On'
+ DutyOn: 50
+ Period: 0
+enclosure_fault:
+ RAS_ERROR_LED:
+ Action: 'On'
+ DutyOn: 50
+ Period: 0
+ System_FAULT:
+ Action: 'On'
+ DutyOn: 50
+ Period: 0