summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend22
1 files changed, 16 insertions, 6 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend b/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
index 134bab5f1..751940467 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,13 +1,23 @@
SRC_URI += "${@mf_enabled(d, 'openpower-ubi-fs', 'file://software.conf')}"
-do_install_append() {
-
+install_tmpfile() {
# /tmp/images is the software image upload directory.
# It should not be deleted since it is watched by the Image Manager for
- # new images. Don't install software.conf if obmc-ubi-fs is set since
- # the bbappend in the meta-phosphor layer already installs if
- # obmc-ubi-fs is set.
- if ${@bb.utils.contains('MACHINE_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)} && ! ${@bb.utils.contains('MACHINE_FEATURES', 'obmc-ubi-fs', 'true', 'false', d)}; then
+ # new images.
+
+ if ${@bb.utils.contains('MACHINE_FEATURES', 'openpower-ubi-fs', 'true', 'false', d)}; then
install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
fi
}
+
+install_tmpfile_df-obmc-ubi-fs() {
+ # Don't install software.conf if obmc-ubi-fs is set since
+ # the bbappend in the meta-phosphor layer already installs
+ # if obmc-ubi-fs is set.
+
+ :
+}
+
+do_install_append() {
+ install_tmpfile
+}