summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
deleted file mode 100644
index d05e67fb9..000000000
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "Witherspoon VRM Overrides"
-DESCRIPTION = "Sets Witherspoon VRMs to custom voltages"
-PR = "r1"
-
-inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
-
-RDEPENDS_${PN} += "i2c-tools bash"
-
-S = "${WORKDIR}"
-SRC_URI += "file://vrm-control.sh \
- file://ir35221-unbind-bind.sh"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/vrm-control.sh ${D}${bindir}/vrm-control.sh
- install -m 0755 ${WORKDIR}/ir35221-unbind-bind.sh ${D}${bindir}/ir35221-unbind-bind.sh
-}
-
-TMPL = "vrm-control@.service"
-INSTFMT = "vrm-control@{0}.service"
-TGTFMT_ON = "obmc-chassis-poweron@{0}.target"
-FMT_ON = "../${TMPL}:${TGTFMT_ON}.requires/${INSTFMT}"
-
-TMPL_ON_IRBIND = "ir35221-on-bind@.service"
-INSTFMT_ON_IRBIND = "ir35221-on-bind@{0}.service"
-FMT_ON_IRBIND = "../${TMPL_ON_IRBIND}:${TGTFMT_ON}.wants/${INSTFMT_ON_IRBIND}"
-
-TMPL_ON_IRUNBIND = "ir35221-on-unbind@.service"
-INSTFMT_ON_IRUNBIND = "ir35221-on-unbind@{0}.service"
-FMT_ON_IRUNBIND = "../${TMPL_ON_IRUNBIND}:${TGTFMT_ON}.requires/${INSTFMT_ON_IRUNBIND}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL} ${TMPL_ON_IRUNBIND} ${TMPL_ON_IRBIND}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON_IRBIND', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON_IRUNBIND', 'OBMC_CHASSIS_INSTANCES')}"