summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb')
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
new file mode 100644
index 000000000..8d12c4b34
--- /dev/null
+++ b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/bmcweb/bmcweb.bb
@@ -0,0 +1,34 @@
+inherit obmc-phosphor-systemd
+inherit useradd
+
+USERADD_PACKAGES = "${PN}"
+
+# add a user called httpd for the server to assume
+USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
+
+SRC_URI = "gitsm://github.com/openbmc/bmcweb.git"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "8db6e57bbad48443eb75ba3b13a5dad0abe06aec"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "dbus openssl zlib boost libpam boost-dbus gtest nlohmann-json libtinyxml2 "
+
+FILES_${PN} += "${datadir}/** "
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DBUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON"
+
+SYSTEMD_SERVICE_${PN} += "bmcweb.service"
+
+FULL_OPTIMIZATION = "-Os -pipe "
+
+do_install_append() {
+ rm -rf ${D}${includedir}/dbus
+ rm -rf ${D}${libdir}/cmake
+}