summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2500/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-ast2500/recipes-phosphor')
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json8
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json48
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json7
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console.conf3
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console@.service21
-rwxr-xr-xmeta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/sol-option-check.sh25
-rw-r--r--meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console_%.bbappend17
7 files changed, 52 insertions, 77 deletions
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json
index 793c790c8..44eda0e66 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/CPC-Baseboard.json
@@ -1884,6 +1884,12 @@
"PinType": "PIN_NONE"
},
"Type": "ASD"
+ },
+ {
+ "Address": "0x38",
+ "Bus": 4,
+ "Name": "PFR",
+ "Type": "PFR"
}
],
"Name": "CPC Baseboard",
@@ -1906,4 +1912,4 @@
"ProductId": 157
},
"xyz.openbmc_project.Inventory.Item.System": {}
-} \ No newline at end of file
+}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
index 041787147..12790632e 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Baseboard.json
@@ -1045,6 +1045,30 @@
"Type": "IpmbSensor"
},
{
+ "Address": 190,
+ "Class": "MESensor",
+ "Name": "Host Cpu Utilization",
+ "SensorType": "utilization",
+ "ScaleValue": 0.392,
+ "Type": "IpmbSensor"
+ },
+ {
+ "Address": 191,
+ "Class": "MESensor",
+ "Name": "Host Pci Bandwidth Utilization",
+ "SensorType": "utilization",
+ "ScaleValue": 0.392,
+ "Type": "IpmbSensor"
+ },
+ {
+ "Address": 192,
+ "Class": "MESensor",
+ "Name": "Host Memory Bandwidth Utilization",
+ "SensorType": "utilization",
+ "ScaleValue": 0.392,
+ "Type": "IpmbSensor"
+ },
+ {
"EthIndex": 0,
"Name": "Dedicated Management NIC",
"Type": "NIC"
@@ -1918,9 +1942,9 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "DIMM [ABC]\\d+ CPU1"
+ "DIMM [ABCD]\\d+ CPU1"
],
- "Name": "CPU1 DIMM ABC",
+ "Name": "CPU1 DIMM ABCD",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
@@ -1944,9 +1968,9 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "DIMM [DEF]\\d+ CPU1"
+ "DIMM [EFGH]\\d+ CPU1"
],
- "Name": "CPU1 DIMM DEF",
+ "Name": "CPU1 DIMM EFGH",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
@@ -1969,9 +1993,9 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "DIMM [ABC]\\d+ CPU2"
+ "DIMM [ABCD]\\d+ CPU2"
],
- "Name": "CPU2 DIMM ABC",
+ "Name": "CPU2 DIMM ABCD",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
@@ -1995,9 +2019,9 @@
"ILimitMax": 100,
"ILimitMin": 30,
"Inputs": [
- "DIMM [DEF]\\d+ CPU2"
+ "DIMM [EFGH]\\d+ CPU2"
],
- "Name": "CPU2 DIMM DEF",
+ "Name": "CPU2 DIMM EFGH",
"NegativeHysteresis": 5.0,
"OutLimitMax": 100,
"OutLimitMin": 30,
@@ -2399,6 +2423,12 @@
}
],
"Type": "XeonCPU"
+ },
+ {
+ "Address": "0x38",
+ "Bus": 4,
+ "Name": "PFR",
+ "Type": "PFR"
}
],
"Name": "WC Baseboard",
@@ -2421,4 +2451,4 @@
"ProductId": 145
},
"xyz.openbmc_project.Inventory.Item.System": {}
-}
+} \ No newline at end of file
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json
index a30626daa..12c2e6084 100644
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json
+++ b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/configuration/entity-manager/WC-Chassis.json
@@ -205,6 +205,11 @@
"Type": "ExitAirTempSensor"
},
{
+ "AllowedFailures": 1,
+ "Name": "FanRedundancy",
+ "Type": "FanRedundancy"
+ },
+ {
"Class": "temp",
"FFGainCoefficient": 0.0,
"FFOffCoefficient": 0.0,
@@ -452,4 +457,4 @@
"xyz.openbmc_project.Inventory.Decorator.AssetTag": {
"AssetTag": "$PRODUCT_ASSET_TAG"
}
-} \ No newline at end of file
+}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console.conf
deleted file mode 100644
index 1d332e2a2..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-baud = 921600
-local-tty = ttyS3
-local-tty-baud = 921600
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console@.service b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console@.service
deleted file mode 100644
index 7fb8f79d3..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/obmc-console@.service
+++ /dev/null
@@ -1,21 +0,0 @@
-[Unit]
-Description=Phosphor Console Muxer listening on device /dev/%I
-BindsTo=dev-%i.device
-After=dev-%i.device
-
-[Service]
-ExecStartPre=/usr/bin/sol-option-check.sh
-ExecStartPre=/bin/sh -c 'echo -n "uart3" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart1'
-ExecStartPre=/bin/sh -c 'echo -n "uart1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart3'
-ExecStartPre=/bin/sh -c 'echo -n "io1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart4'
-ExecStartPre=/bin/sh -c 'echo -n "uart4" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/io1'
-ExecStart=/usr/bin/env obmc-console-server --config {sysconfdir}/obmc-console.conf %i
-ExecStopPost=/bin/sh -c 'echo -n "io1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart1'
-ExecStopPost=/bin/sh -c 'echo -n "io3" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart3'
-ExecStopPost=/bin/sh -c 'echo -n "io4" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/uart4'
-ExecStopPost=/bin/sh -c 'echo -n "uart1" > /sys/bus/platform/drivers/aspeed-uart-routing/1e78909c.uart_routing/io1'
-SyslogIdentifier=obmc-console-server
-Restart=always
-
-[Install]
-WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/sol-option-check.sh b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/sol-option-check.sh
deleted file mode 100755
index ef32fcb9a..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console/sol-option-check.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-# Copyright 2017 Intel Corporation
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-#
-
-if [ $(grep 192000000 /sys/class/tty/ttyS0/uartclk | wc -l) != 0 ]; then
- echo "hs-uart"
- sed -i -e 's/115200/921600/g' /etc/obmc-console.conf
-else
- echo "normal uart"
- sed -i -e 's/921600/115200/g' /etc/obmc-console.conf
-fi
diff --git a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console_%.bbappend b/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console_%.bbappend
deleted file mode 100644
index 7baf1cabc..000000000
--- a/meta-openbmc-mods/meta-ast2500/recipes-phosphor/console/obmc-console_%.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
-FILESEXTRAPATHS_prepend_intel-ast2500 := "${THISDIR}/${PN}:"
-OBMC_CONSOLE_HOST_TTY = "ttyS2"
-SRC_URI += "file://sol-option-check.sh \
- file://obmc-console@.service \
- "
-inherit obmc-phosphor-systemd
-
-SYSTEMD_SERVICE_${PN} += " \
- ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
- "
-
-do_install_append() {
- rm -rf ${D}${base_libdir}/udev/rules.d/80-obmc-console-uart.rules
- install -m 0644 ${WORKDIR}/${PN}@.service ${D}${systemd_system_unitdir}
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/sol-option-check.sh ${D}${bindir}
-}