summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-ast2600/recipes-kernel/linux')
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed/intel-ast2600.cfg5
-rw-r--r--meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend5
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed/intel-ast2600.cfg b/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed/intel-ast2600.cfg
index a044ce6cd..7992be527 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed/intel-ast2600.cfg
+++ b/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed/intel-ast2600.cfg
@@ -4,6 +4,8 @@ CONFIG_SPI_ASPEED_SMC=y
CONFIG_SPI_FMC=y
CONFIG_I3C=y
CONFIG_DW_I3C_MASTER=y
+CONFIG_ASPEED_I3C_GLOBAL=y
+CONFIG_I3CDEV=y
CONFIG_JTAG_ASPEED=n
CONFIG_U_SERIAL_CONSOLE=n
CONFIG_KERNEL_LZO=y
@@ -14,5 +16,6 @@ CONFIG_DEBUG_LL=n
CONFIG_DEBUG_LL_UART_8250=n
CONFIG_EARLY_PRINTK=n
CONFIG_LOG_BUF_SHIFT=21
-CONFIG_DEBUG_PINCTRL=y
+CONFIG_DEBUG_PINCTRL=n
CONFIG_SUSPEND=n
+CONFIG_ASPEED_MCTP=y
diff --git a/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend
index d32f38611..07cafe94e 100644
--- a/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-openbmc-mods/meta-ast2600/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,9 +1,6 @@
COMPATIBLE_MACHINE = "intel-ast2600"
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-aspeed:"
-#SRCREV="f9e04c3157234671b9d5e27bf9b7025b8b21e0d4"
-#LINUX_VERSION="5.2.11"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-# TODO: the base kernel dtsi fixups patch should be pushed upstream
SRC_URI += " \
file://intel-ast2600.cfg \
file://0001-Add-a-workaround-to-cover-UART-interrupt-bug-in-AST2.patch \