summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch29
1 files changed, 11 insertions, 18 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch
index 47cb56062..9096b09b2 100644
--- a/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch
+++ b/meta-openbmc-mods/meta-common/recipes-bsp/u-boot/files/0024-IPMI-command-handler-implementation-in-uboot.patch
@@ -1,6 +1,6 @@
-From d770ea7a30742339b0692858847838dd2a738aeb Mon Sep 17 00:00:00 2001
+From 50d3a7264fc0ecdd61ae1686839b19091b124e8d Mon Sep 17 00:00:00 2001
From: AppaRao Puli <apparao.puli@linux.intel.com>
-Date: Fri, 5 Apr 2019 17:53:21 +0530
+Date: Tue, 21 May 2019 00:19:16 +0530
Subject: [PATCH] IPMI command handler implementation in uboot
IPMI command handler implemtation in uBoot.
@@ -22,10 +22,10 @@ Change-Id: I18b205bc45c34f7c4ef16adc29fa5bd494624ceb
Signed-off-by: AppaRao Puli <apparao.puli@linux.intel.com>
---
board/aspeed/ast-g5/Makefile | 1 +
- board/aspeed/ast-g5/ast-g5-kcs.c | 78 +++++++++++++-----------
+ board/aspeed/ast-g5/ast-g5-kcs.c | 77 +++++++++++++-----------
board/aspeed/ast-g5/ipmi-handler.c | 118 +++++++++++++++++++++++++++++++++++++
board/aspeed/ast-g5/ipmi-handler.h | 40 +++++++++++++
- 4 files changed, 202 insertions(+), 35 deletions(-)
+ 4 files changed, 202 insertions(+), 34 deletions(-)
create mode 100644 board/aspeed/ast-g5/ipmi-handler.c
create mode 100644 board/aspeed/ast-g5/ipmi-handler.h
@@ -39,7 +39,7 @@ index 05972b9..f28fcfe 100644
obj-y += ast-g5-kcs.o
+obj-y += ipmi-handler.o
diff --git a/board/aspeed/ast-g5/ast-g5-kcs.c b/board/aspeed/ast-g5/ast-g5-kcs.c
-index f983b4a..05b1cc2 100644
+index 7bff26f..98bf69b 100644
--- a/board/aspeed/ast-g5/ast-g5-kcs.c
+++ b/board/aspeed/ast-g5/ast-g5-kcs.c
@@ -1,7 +1,7 @@
@@ -49,9 +49,9 @@ index f983b4a..05b1cc2 100644
-#include "ast-g5-kcs.h"
+#include "ipmi-handler.h"
- #define DEBUG_KCS_ENABLED 0
#ifdef DEBUG_KCS_ENABLED
-@@ -10,11 +10,6 @@
+ #define DBG_KCS printf
+@@ -9,11 +9,6 @@
#define DBG_KCS(...)
#endif
@@ -63,22 +63,15 @@ index f983b4a..05b1cc2 100644
#define KCS_CHANNEL_NO_3 3
static const u16 enabled_kcs_channel[] = { KCS_CHANNEL_NO_3 };
-@@ -104,13 +99,13 @@ static void init_kcs_packet(u16 channel_num)
+@@ -103,6 +98,7 @@ static void init_kcs_packet(u16 channel_num)
static void process_kcs_request(u16 channel_num)
{
struct kcs_packet *kcs_pkt = NULL;
+ struct ipmi_cmd_data ipmi_data;
-
- kcs_pkt = get_kcs_packet(channel_num);
- if (!kcs_pkt->read_req_done)
- return;
-
- DBG_KCS("%s:- chan:%d\n", __func__, channel_num);
--
- #ifdef DEBUG_KCS_ENABLED
int i;
-@@ -119,37 +114,49 @@ static void process_kcs_request(u16 channel_num)
+ kcs_pkt = get_kcs_packet(channel_num);
+@@ -117,37 +113,49 @@ static void process_kcs_request(u16 channel_num)
DBG_KCS(" 0x%02x", kcs_pkt->data_in[i]);
DBG_KCS("\n");
#endif
@@ -156,7 +149,7 @@ index f983b4a..05b1cc2 100644
#ifdef DEBUG_KCS_ENABLED
DBG_KCS("Response data(Len:%d): ", kcs_pkt->data_out_len);
-@@ -158,6 +165,7 @@ static void process_kcs_request(u16 channel_num)
+@@ -156,6 +164,7 @@ static void process_kcs_request(u16 channel_num)
DBG_KCS("\n");
#endif