summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/bmcweb/bmcweb_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/bmcweb/bmcweb_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/bmcweb/bmcweb_%.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/bmcweb/bmcweb_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/bmcweb/bmcweb_%.bbappend
new file mode 100644
index 000000000..8d5a43c51
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/bmcweb/bmcweb_%.bbappend
@@ -0,0 +1,16 @@
+# add a user called bmcweb for the server to assume
+# bmcweb is part of group shadow for non-root pam authentication
+USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin -d /home/bmcweb -m -G shadow bmcweb"
+
+GROUPADD_PARAM_${PN} = "web; redfish "
+
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI += "file://0001-Refine-KVM-websock-proxy.patch"
+
+# Enable CPU Log and Raw PECI support
+EXTRA_OECMAKE += "-DBMCWEB_ENABLE_REDFISH_CPU_LOG=ON"
+EXTRA_OECMAKE += "-DBMCWEB_ENABLE_REDFISH_RAW_PECI=ON"
+
+# Enable Redfish BMC Journal support
+EXTRA_OECMAKE += "-DBMCWEB_ENABLE_REDFISH_BMC_JOURNAL=ON"