summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb b/meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb
index 118d6aab8..df7d6e7f1 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb
+++ b/meta-openbmc-mods/meta-common/recipes-core/fw-update/intel-fw-update.bb
@@ -3,13 +3,13 @@ DESCRIPTION = "At runtime, perform a firmware update and reboot"
PR = "r1"
# flash_eraseall
-RDEPENDS_intel-fw-update += "mtd-utils"
+RDEPENDS:intel-fw-update += "mtd-utils"
# wget tftp scp
-RDEPENDS_intel-fw-update += "busybox dropbear"
+RDEPENDS:intel-fw-update += "busybox dropbear"
# mkfs.vfat, parted
-RDEPENDS_intel-fw-update += "dosfstools dtc"
+RDEPENDS:intel-fw-update += "dosfstools dtc"
-RDEPENDS_intel-fw-update += "bash"
+RDEPENDS:intel-fw-update += "bash"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
@@ -18,7 +18,7 @@ PFR_EN = "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'pfr', '', d)}"
SRC_URI += "file://fwupd.sh"
SRC_URI += "file://usb-ctrl"
-FILES_${PN} += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', '${datadir}/pfr', '', d)}"
+FILES:${PN} += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', '${datadir}/pfr', '', d)}"
do_install() {
install -d ${D}${bindir}