summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/nv-overlay/nv-overlay.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/nv-overlay/nv-overlay.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/nv-overlay/nv-overlay.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/nv-overlay/nv-overlay.bb b/meta-openbmc-mods/meta-common/recipes-core/nv-overlay/nv-overlay.bb
new file mode 100644
index 000000000..78b0f80ca
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/nv-overlay/nv-overlay.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Limited NV overlay init script"
+DESCRIPTION = "At runtime, overlay a few directories with an NV COW"
+PR = "r1"
+
+inherit obmc-phosphor-systemd
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "file://nv-overlay.sh"
+SRC_URI += "file://nv-overlay.service"
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/nv-overlay.sh ${D}${bindir}
+}
+
+TMPL = "nv-overlay.service"
+SYSTEMD_SERVICE_${PN} += "${TMPL}"