summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0007-ipmi-whitelist-Allow-set-securitymode-cmd-from-KCS.patch49
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0008-Add-sufficient-delay-to-create-smbios2-file.patch39
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync/nv-sync-tmp.conf2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync_git.bb6
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend2
6 files changed, 98 insertions, 2 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0007-ipmi-whitelist-Allow-set-securitymode-cmd-from-KCS.patch b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0007-ipmi-whitelist-Allow-set-securitymode-cmd-from-KCS.patch
new file mode 100644
index 000000000..9519ee651
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0007-ipmi-whitelist-Allow-set-securitymode-cmd-from-KCS.patch
@@ -0,0 +1,49 @@
+From 5bdf25daa1c1857e5e24f8c7e593c303eff4285a Mon Sep 17 00:00:00 2001
+From: Jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
+Date: Mon, 23 Nov 2020 01:01:24 +0000
+Subject: [PATCH] ipmi-whitelist:Allow set securitymode cmd from KCS
+
+Issue: Issuing set security mode for Provisioned Host Disabled command
+ is restricted from KCS channel.
+
+Fix: Allow set security mode command execution from KCS interface by
+ adding channel mask in ipmi-whitelist.conf
+
+Tested:
+Verified using ipmitool raw command from Linux OS
+1. Set restriction mode as ProvisionedHostWhitelist
+Command: busctl set-property xyz.openbmc_project.RestrictionMode.Manager
+ /xyz/openbmc_project/control/security/restriction_mode
+ xyz.openbmc_project.Control.Security.RestrictionMode
+ RestrictionMode s
+ "xyz.openbmc_project.Control.Security.RestrictionMode.Modes.
+ ProvisionedHostWhitelist"
+Response: //Success
+2. Check the restriction mode
+Command: ipmitool raw 0x30 0xb3
+Response: 04 00
+3. Execute set security mode for Provisioned Host Disabled command from Linux OS terminal
+Command: ipmitool raw 0x30 0xb4 0x5
+Response: //Success
+
+Signed-off-by: Jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
+---
+ ipmi-whitelist.conf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ipmi-whitelist.conf b/ipmi-whitelist.conf
+index 6557b27..b7a3a8e 100644
+--- a/ipmi-whitelist.conf
++++ b/ipmi-whitelist.conf
+@@ -273,7 +273,7 @@
+ 0x30:0xb1:0x7f7f //<Intel General Application>:<Control BMC Services>
+ 0x30:0xb2:0xff7f //<Intel General Application>:<Get BMC Service Status>
+ 0x30:0xb3:0xff7f //<Intel General Application>:<Get BMC Security Control Mode>
+-0x30:0xb4:0x7f7f //<Intel General Application>:<Set BMC Security Control Mode>
++0x30:0xb4:0xff7f //<Intel General Application>:<Set BMC Security Control Mode>
+ 0x30:0xb5:0x7f7f //<Intel General Application>:<Manufacturing mode Keep Alive>
+ 0x30:0xbb:0xff7f //<Intel General Application>:<Get CPLD Revision ID>
+ 0x30:0xc2:0xff7f //<Intel General Application>:<Get OEM Extended Sys Info>
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0008-Add-sufficient-delay-to-create-smbios2-file.patch b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0008-Add-sufficient-delay-to-create-smbios2-file.patch
new file mode 100644
index 000000000..d918ae04c
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem/0008-Add-sufficient-delay-to-create-smbios2-file.patch
@@ -0,0 +1,39 @@
+From d935f43696149aeb047ff5adf15e22707903c215 Mon Sep 17 00:00:00 2001
+From: Jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
+Date: Wed, 2 Dec 2020 19:42:14 +0000
+Subject: [PATCH] Add sufficient delay to create smbios2 file
+
+Issue: Sometimes with existing defaultTimeout & sysClock delay, BIOS is
+not responding with required information to create smbios2 file which
+contains DIMM info.
+
+Fixed: Increase defaultTimeout & sysClock time to provide required delay
+to get response from SMBIOS in order to populate DIMM information.
+
+Tested:
+1. Verified for 100 DC cycles.
+2. smbios2 file is generated for each cycle with proper DIMM information
+
+Signed-off-by: Jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
+---
+ include/smbiosmdrv2handler.hpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/smbiosmdrv2handler.hpp b/include/smbiosmdrv2handler.hpp
+index 8356d26..6a1f850 100644
+--- a/include/smbiosmdrv2handler.hpp
++++ b/include/smbiosmdrv2handler.hpp
+@@ -57,8 +57,8 @@ static constexpr const size_t smbiosSMMemorySize =
+ 1024 * 1024; // Total size of VGA share memory
+ static constexpr const size_t smbiosTableStorageSize =
+ 64 * 1024; // Total size of smbios table
+-static constexpr const uint32_t defaultTimeout = 200;
+-static constexpr const uint8_t sysClock = 100;
++static constexpr const uint32_t defaultTimeout = 4000;
++static constexpr const uint16_t sysClock = 1000;
+ static constexpr const int lastAgentIndex = -1;
+ static constexpr const uint16_t lastAgentId = 0xFFFF;
+ constexpr const uint32_t invalidChecksum = 0xffffffff;
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend
index 5bbf35e70..96830529f 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-core/ipmi/intel-ipmi-oem_%.bbappend
@@ -13,4 +13,6 @@ SRC_URI += "file://0001-Fix-cold-redundancy-is-not-runing-as-user-configurat.pat
file://0004-firmware-update-Add-Support-to-get-fwSecurityVer.patch \
file://0005-oemcommands-Fix-for-set-security-mode-to-mfg-mode.patch \
file://0006-Update-Product-ID-for-EEPROM-FRU-platforms.patch \
+ file://0007-ipmi-whitelist-Allow-set-securitymode-cmd-from-KCS.patch \
+ file://0008-Add-sufficient-delay-to-create-smbios2-file.patch \
"
diff --git a/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync/nv-sync-tmp.conf b/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync/nv-sync-tmp.conf
new file mode 100644
index 000000000..e73e47129
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync/nv-sync-tmp.conf
@@ -0,0 +1,2 @@
+x /tmp/.rwfs - - - -
+x /tmp/.overlay - - - -
diff --git a/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync_git.bb b/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync_git.bb
index 420fc258b..fa74149d4 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-core/nv-sync/nv-sync_git.bb
@@ -4,6 +4,7 @@ DESCRIPTION = "Script to periodically sync the overlay to NV storage"
S = "${WORKDIR}"
SRC_URI = "file://nv-sync.service \
file://nv-syncd \
+ file://nv-sync-tmp.conf \
"
LICENSE = "Apache-2.0"
@@ -13,13 +14,16 @@ inherit systemd
RDEPENDS_${PN} += "bash"
-FILES_${PN} += "${systemd_system_unitdir}/nv-sync.service"
+FILES_${PN} += "${systemd_system_unitdir}/nv-sync.service \
+ ${libdir}/tmpfiles.d/nv-sync-tmp.conf"
do_install() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/nv-sync.service ${D}${systemd_system_unitdir}
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/nv-syncd ${D}${bindir}/nv-syncd
+ install -d ${D}${libdir}/tmpfiles.d
+ install -m 0644 ${WORKDIR}/nv-sync-tmp.conf ${D}${libdir}/tmpfiles.d/
}
SYSTEMD_SERVICE_${PN} += " nv-sync.service"
diff --git a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend
index 985a9e5ba..e6df605aa 100644
--- a/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,4 @@
-# add some configuration overrides for systemd default /usr/lib/tmpfiles.d/
+# add some configuration overrides for systemd defaults
LICENSE = "GPL-2.0"