summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-devtools')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-devtools/boost-url/boost-url_%.bbappend4
-rw-r--r--meta-openbmc-mods/meta-common/recipes-devtools/cjson/cjson_%.bbappend3
-rw-r--r--meta-openbmc-mods/meta-common/recipes-devtools/mtd-util/mtd-util.bb21
3 files changed, 28 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-devtools/boost-url/boost-url_%.bbappend b/meta-openbmc-mods/meta-common/recipes-devtools/boost-url/boost-url_%.bbappend
new file mode 100644
index 000000000..323788fe8
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-devtools/boost-url/boost-url_%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
+
+# Temporary pin to resolve build breaks
+SRCREV = "2c867fbe284ae532f1329b87a86ad3f8cd382867"
diff --git a/meta-openbmc-mods/meta-common/recipes-devtools/cjson/cjson_%.bbappend b/meta-openbmc-mods/meta-common/recipes-devtools/cjson/cjson_%.bbappend
new file mode 100644
index 000000000..c0e17b456
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-devtools/cjson/cjson_%.bbappend
@@ -0,0 +1,3 @@
+FILES:${PN}-dev += "${libdir}/cmake/cJSON/*"
+
+EXTRA_OECMAKE += " -DENABLE_CUSTOM_COMPILER_FLAGS=OFF -DENABLE_TARGET_EXPORT=OFF"
diff --git a/meta-openbmc-mods/meta-common/recipes-devtools/mtd-util/mtd-util.bb b/meta-openbmc-mods/meta-common/recipes-devtools/mtd-util/mtd-util.bb
new file mode 100644
index 000000000..5b59dd909
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-devtools/mtd-util/mtd-util.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "OpenBMC mtd-util"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b77c43ae4eaf67bd73fb6452b2f113a3"
+
+SRC_URI = "git://github.com/Intel-BMC/mtd-util;protocol=ssh"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "708072b62a3cecb520eeaacac88b4f2c2e101fe4"
+
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "dbus systemd sdbusplus openssl zlib boost microsoft-gsl i2c-tools"
+
+inherit cmake pkgconfig
+
+# Specify any options you want to pass to cmake using EXTRA_OECMAKE:
+EXTRA_OECMAKE = ""
+
+EXTRA_OECMAKE += "${@bb.utils.contains('EXTRA_IMAGE_FEATURES', 'debug-tweaks', '-DDEVELOPER_OPTIONS=ON', '', d)}"