summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/dbus')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0001-Reapply-Enhance-DHCP-beyond-just-OFF-and-IPv4-IPv6-e.patch47
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch61
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend6
3 files changed, 53 insertions, 61 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0001-Reapply-Enhance-DHCP-beyond-just-OFF-and-IPv4-IPv6-e.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0001-Reapply-Enhance-DHCP-beyond-just-OFF-and-IPv4-IPv6-e.patch
new file mode 100644
index 000000000..3344c27dd
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0001-Reapply-Enhance-DHCP-beyond-just-OFF-and-IPv4-IPv6-e.patch
@@ -0,0 +1,47 @@
+From 3789a98fda6e3cafd377b0f4fa1c0c40bb94297e Mon Sep 17 00:00:00 2001
+From: Johnathan Mantey <jonathanx.mantey@intel.com>
+Date: Wed, 20 Nov 2019 10:56:44 -0500
+Subject: [PATCH] Reapply: "Enhance DHCP beyond just OFF and IPv4/IPv6
+ enabled."
+
+DHCP is not a binary option. The network interface can have DHCP
+disabled, IPv4 only, IPv6 only, and IPv4/IPv6.
+
+Signed-off-by: Johnathan Mantey <jonathanx.mantey@intel.com>
+
+Reapplied ->
+Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
+Change-Id: I7654116aa3962de253225271190ce4a2fe229ce9
+---
+ .../Network/EthernetInterface.interface.yaml | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/xyz/openbmc_project/Network/EthernetInterface.interface.yaml b/xyz/openbmc_project/Network/EthernetInterface.interface.yaml
+index ee54145..56285ee 100644
+--- a/xyz/openbmc_project/Network/EthernetInterface.interface.yaml
++++ b/xyz/openbmc_project/Network/EthernetInterface.interface.yaml
+@@ -23,7 +23,7 @@ properties:
+ description: >
+ Domain names of the ethernet interface.
+ - name: DHCPEnabled
+- type: boolean
++ type: enum[self.DHCPConf]
+ description: >
+ Address mode of the ethernet interface.
+ - name: Nameservers
+@@ -69,4 +69,11 @@ enumerations:
+ - name: v4
+ - name: v6
+ - name: none
+-
++ - name: DHCPConf
++ description: >
++ A list of the permitted DHCP settings used by systemd.
++ values:
++ - name: both
++ - name: v4
++ - name: v6
++ - name: none
+--
+2.21.0
+
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch
index 7568f8ce9..4cfc4acc8 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch
@@ -1,15 +1,14 @@
From a30a09f58b9ebfb267c0b9cce9ae25994ea025ca Mon Sep 17 00:00:00 2001
From: cyang29 <cheng.c.yang@intel.com>
Date: Tue, 17 Jul 2018 16:04:58 +0800
-Subject: [PATCH] Add DBUS interface of CPU and Memory's properties Feature
- Support: SMBIOS service interface. CPU DIMM information redfish
+Subject: [PATCH] Add DBUS interface of CPU properties Feature
+ Support: SMBIOS service interface. CPU information redfish
interface. Base on smbios spec DSP0134_3.0.0
Signed-off-by: cyang29 <cheng.c.yang@intel.com>
---
.../Inventory/Item/Cpu.interface.yaml | 41 +++++++++++++++++++
- .../Inventory/Item/Dimm.interface.yaml | 46 +++++++++++++++++++++-
- 2 files changed, 86 insertions(+), 1 deletion(-)
+ 1 files changed, 41 insertions(+)
diff --git a/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml b/xyz/openbmc_project/Inventory/Item/Cpu.interface.yaml
index ab29cf3..313eada 100644
@@ -61,60 +60,6 @@ index ab29cf3..313eada 100644
+ The Count of Thread CPU Can Support
# vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4
-diff --git a/xyz/openbmc_project/Inventory/Item/Dimm.interface.yaml b/xyz/openbmc_project/Inventory/Item/Dimm.interface.yaml
-index d85326d..b750320 100644
---- a/xyz/openbmc_project/Inventory/Item/Dimm.interface.yaml
-+++ b/xyz/openbmc_project/Inventory/Item/Dimm.interface.yaml
-@@ -1,4 +1,48 @@
- description: >
- Implement to provide DIMM attributes.
--
-+properties:
-+ - name: MemoryDataWidth
-+ type: uint16
-+ description: >
-+ Data width of Memory.
-+ - name: MemorySizeInKB
-+ type: uint32
-+ description: >
-+ Memory size of DIMM in Kilobyte.
-+ - name: MemoryDeviceLocator
-+ type: string
-+ description: >
-+ Socket on base board where Memory located.
-+ - name: MemoryType
-+ type: string
-+ description: >
-+ Type of memory.
-+ - name: MemoryTypeDetail
-+ type: string
-+ description: >
-+ Additional detail on Memory.
-+ - name: MemorySpeed
-+ type: uint16
-+ description: >
-+ The maximun capable speed of Memory.
-+ - name: MemoryManufacturer
-+ type: string
-+ description: >
-+ Manufacturer of memory.
-+ - name: MemorySerialNum
-+ type: string
-+ description: >
-+ Memory Serial Number.
-+ - name: MemoryPartNum
-+ type: string
-+ description: >
-+ Memory Part Number.
-+ - name: MemoryAttributes
-+ type: byte
-+ description: >
-+ Rank attributes of Memory.
-+ - name: MemoryConfClockSpeed
-+ type: uint16
-+ description: >
-+ Configured clock speed to Memory.
- # vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4
--
2.16.2
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index c306e5afc..f21845ce6 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -1,6 +1,5 @@
-# todo Johnathan, undo nobranch once phosphor-networking is working
-SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git;nobranch=1"
-SRCREV = "9cb4a711cff999b373cf98b44cc18b9001c1395a"
+SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git"
+SRCREV = "4610bace070eb17c6e4ee015210dac44284c53a7"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -13,4 +12,5 @@ SRC_URI += "file://0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch
file://0022-Add-chassis-power-cycle-and-reset-to-Chassis-State.patch \
file://0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch \
file://0025-Add-PreInterruptFlag-properity-in-DBUS.patch \
+ file://0001-Reapply-Enhance-DHCP-beyond-just-OFF-and-IPv4-IPv6-e.patch \
"