summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/dbus')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0018-Define-post-code-interfaces-for-post-code-manager.patch64
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch80
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend7
3 files changed, 3 insertions, 148 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0018-Define-post-code-interfaces-for-post-code-manager.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0018-Define-post-code-interfaces-for-post-code-manager.patch
deleted file mode 100644
index ce23c222b..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0018-Define-post-code-interfaces-for-post-code-manager.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From f88cac8364d5312e29208018909827d2da4a0f87 Mon Sep 17 00:00:00 2001
-From: Kuiying Wang <kuiying.wang@intel.com>
-Date: Tue, 19 Feb 2019 16:52:51 +0800
-Subject: [PATCH] Define post code interfaces for post code manager
-
-It includes one method and 2 properties.
-properties:
- - name: CurrentBootCycleIndex
- description: >
- It is used to indicate current boot cycle index.
- - name: MaxBootCycleNum
- description: >
- The max cached boot cycles for post code.
-methods:
- - name: GetPostCodes
- description: >
- Method to get the cached post code for each boot cycle.
-TestBy: bitbake build
-
-Signeoff-by: Kuiying Wang <kuiying.wang@intel.com>
----
- .../State/Boot/PostCode.interface.yaml | 30 ++++++++++++++++++++++
- 1 file changed, 30 insertions(+)
- create mode 100644 xyz/openbmc_project/State/Boot/PostCode.interface.yaml
-
-diff --git a/xyz/openbmc_project/State/Boot/PostCode.interface.yaml b/xyz/openbmc_project/State/Boot/PostCode.interface.yaml
-new file mode 100644
-index 0000000..711749d
---- /dev/null
-+++ b/xyz/openbmc_project/State/Boot/PostCode.interface.yaml
-@@ -0,0 +1,30 @@
-+description: >
-+ Monitor Post code coming and buffer all of them based on boot cycle
-+ into file system.
-+
-+properties:
-+ - name: CurrentBootCycleIndex
-+ type: uint16
-+ description: >
-+ It is used to indicate current boot cycle index.
-+ - name: MaxBootCycleNum
-+ type: uint16
-+ description: >
-+ The max cached boot cycles for post code.
-+methods:
-+ - name: GetPostCodes
-+ description: >
-+ Method to get the cached post code for each boot cycle.
-+ parameters:
-+ - name: Index
-+ type: uint16
-+ description: >
-+ Index indicates which boot cycle of post codes is requested.
-+ returns:
-+ - name: codes
-+ type: array[uint64]
-+ description: >
-+ An array of post codes of one boot cycle.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - xyz.openbmc_project.Common.Error.InvalidArgument
---
-2.16.2
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch
deleted file mode 100644
index 62d5376d6..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 9b0630f40c7fb1143901f7d114c376426cc03501 Mon Sep 17 00:00:00 2001
-From: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
-Date: Sat, 15 Jun 2019 01:04:41 +0530
-Subject: [PATCH] [D-Bus Intf] Security modes property & intf update
-
-Defined new values for RestrictionMode property and defined
-SpecialMode interfaces to handle special cases like manufacturing
-and validation mode in OpenBMC.
-
-Note: Please refer Security mode design doc under review for more
-details
-https://gerrit.openbmc-project.xyz/#/c/openbmc/docs/+/21195/
-
-Change-Id: I270e7d23ca2ed260f2d121e3844c2ca79150070e
-Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
----
- .../Security/RestrictionMode.interface.yaml | 16 +++++++++++++
- .../Control/Security/SpecialMode.interface.yaml | 26 ++++++++++++++++++++++
- 2 files changed, 42 insertions(+)
- create mode 100644 xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml
-
-diff --git a/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml b/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
-index 8e4fd8d..afd2279 100644
---- a/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
-+++ b/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
-@@ -21,3 +21,19 @@ enumerations:
- - name: Blacklist
- description: >
- Prevent, if in the blacklist.
-+ - name: Provisioning
-+ description: >
-+ Indicate that system is in provisioning mode
-+ and all commands are allowed in system inteface
-+ in both pre and post BIOS boot.
-+ - name: ProvisionedHostWhitelist
-+ description: >
-+ Commands in the whitelist will only be executed
-+ through system interface after BIOS POST complete.
-+ All KCS commands are supported before POST complete.
-+ - name: ProvisionedHostDisabled
-+ description: >
-+ Commands through system interface are executed only
-+ till BIOS POST complete notification, after
-+ which no system interface commands will be executed(other
-+ than BIOS SMI based ones).
-diff --git a/xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml b/xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml
-new file mode 100644
-index 0000000..6760076
---- /dev/null
-+++ b/xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml
-@@ -0,0 +1,26 @@
-+description: >
-+ Implement to specify a special mode of operation
-+
-+properties:
-+ - name: SpecialMode
-+ type: enum[self.Modes]
-+ description: >
-+ The special mode.
-+
-+enumerations:
-+ - name: Modes
-+ description: >
-+ Possible modes available.
-+ values:
-+ - name: None
-+ description: >
-+ BMC is under normal working condition.
-+ - name: Manufacturing
-+ description: >
-+ Indicate that BMC is in manufacturing mode
-+ and is allowed to perform any manufacturing related
-+ activity
-+ - name: ValidationUnsecure
-+ description: >
-+ Indicate that BMC is in validation mode, and can
-+ execute any special validation related commands
---
-2.7.4
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index 79a67ee79..c306e5afc 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -1,5 +1,6 @@
-SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git"
-SRCREV = "ddc9e9f9d6ed0282ec6c1421a706b45f3c09ebcc"
+# todo Johnathan, undo nobranch once phosphor-networking is working
+SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git;nobranch=1"
+SRCREV = "9cb4a711cff999b373cf98b44cc18b9001c1395a"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -9,8 +10,6 @@ SRC_URI += "file://0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch
file://0012-Add-RestoreDelay-interface-for-power-restore-delay.patch \
file://0013-Add-ErrConfig.yaml-interface-for-processor-error-config.patch \
file://0016-Add-DBUS-interface-of-SMBIOS-MDR-V2.patch \
- file://0018-Define-post-code-interfaces-for-post-code-manager.patch \
- file://0021-D-Bus-Intf-Security-modes-property-intf-update.patch \
file://0022-Add-chassis-power-cycle-and-reset-to-Chassis-State.patch \
file://0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch \
file://0025-Add-PreInterruptFlag-properity-in-DBUS.patch \