summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index c40ecad7e..fd45b0e1c 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -18,16 +18,12 @@ EXTRA_OECONF:append = " --disable-ipmi-whitelist"
RDEPENDS:${PN}:remove = "clear-once"
# remove the softpoweroff service since we do not need it
-SYSTEMD_SERVICE:${PN}:remove += " \
+SYSTEMD_SERVICE:${PN}:remove = " \
xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
-SYSTEMD_LINK_${PN}:remove += " \
+SYSTEMD_LINK:${PN}:remove = " \
../xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service:obmc-host-shutdown@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service \
"
-FILES:${PN}:remove = " \
- ${D}${systemd_unitdir}/system/obmc-host-shutdown@0.target.requires/ \
- ${D}${systemd_unitdir}/system/obmc-host-shutdown@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service \
- "
do_compile:prepend(){
cp -f ${PROJECT_SRC_DIR}/transporthandler_oem.cpp ${S}