summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend27
1 files changed, 13 insertions, 14 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 84ae31e5c..c40ecad7e 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
PROJECT_SRC_DIR := "${THISDIR}/${PN}"
SRC_URI += "file://phosphor-ipmi-host.service \
@@ -8,33 +8,32 @@ SRC_URI += "file://phosphor-ipmi-host.service \
file://0060-Move-Get-SOL-config-parameter-to-host-ipmid.patch \
file://0062-Update-IPMI-Chassis-Control-command.patch \
file://0063-Save-the-pre-timeout-interrupt-in-dbus-property.patch \
- file://0064-chassishandler-Fix-for-BIOS-boot-type-Legacy.patch \
"
-EXTRA_OECONF_append = " --disable-i2c-whitelist-check"
-EXTRA_OECONF_append = " --enable-transport-oem=yes"
-EXTRA_OECONF_append = " --disable-boot-flag-safe-mode-support"
-EXTRA_OECONF_append = " --disable-ipmi-whitelist"
+EXTRA_OECONF:append = " --disable-i2c-whitelist-check"
+EXTRA_OECONF:append = " --enable-transport-oem=yes"
+EXTRA_OECONF:append = " --disable-boot-flag-safe-mode-support"
+EXTRA_OECONF:append = " --disable-ipmi-whitelist"
-RDEPENDS_${PN}_remove = "clear-once"
+RDEPENDS:${PN}:remove = "clear-once"
# remove the softpoweroff service since we do not need it
-SYSTEMD_SERVICE_${PN}_remove += " \
+SYSTEMD_SERVICE:${PN}:remove += " \
xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
-SYSTEMD_LINK_${PN}_remove += " \
+SYSTEMD_LINK_${PN}:remove += " \
../xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service:obmc-host-shutdown@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service \
"
-FILES_${PN}_remove = " \
- ${systemd_unitdir}/system/obmc-host-shutdown@0.target.requires/ \
- ${systemd_unitdir}/system/obmc-host-shutdown@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service \
+FILES:${PN}:remove = " \
+ ${D}${systemd_unitdir}/system/obmc-host-shutdown@0.target.requires/ \
+ ${D}${systemd_unitdir}/system/obmc-host-shutdown@0.target.requires/xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service \
"
-do_compile_prepend(){
+do_compile:prepend(){
cp -f ${PROJECT_SRC_DIR}/transporthandler_oem.cpp ${S}
}
-do_install_append(){
+do_install:append(){
rm -f ${D}/${bindir}/phosphor-softpoweroff
rm -f ${S}/transporthandler_oem.cpp
}