summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend16
1 files changed, 4 insertions, 12 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 2d47fdfff..f454f7ce9 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
# TODO: This should be removed, once up-stream bump up
# issue is resolved
#SRC_URI = "git://github.com/openbmc/phosphor-host-ipmid"
-SRCREV = "55768e3548ef7476d4fdbe7be7a3ddb4d4896f14"
+SRCREV = "11df4f6906edc0dfb23089a6e297158549c19ebd"
SRC_URI += "file://phosphor-ipmi-host.service \
file://0002-Modify-dbus-interface-for-power-control.patch \
@@ -13,25 +13,17 @@ SRC_URI += "file://phosphor-ipmi-host.service \
file://0012-ipmi-set-get-boot-options.patch \
file://0013-ipmi-add-set-bios-id-to-whitelist.patch \
file://0014-Enable-get-device-guid-ipmi-command.patch \
- file://0016-add-better-sdbusplus-exception-handling.patch \
- file://0018-Catch-sdbusplus-exceptions-in-IPMI-net.patch \
file://0021-Implement-IPMI-Commmand-Get-Host-Restart-Cause.patch \
file://0039-ipmi-add-oem-command-get-AIC-FRU-to-whitelist.patch \
file://0048-Implement-IPMI-Master-Write-Read-command.patch \
file://0049-Fix-Unspecified-error-on-ipmi-restart-cause-command.patch \
file://0050-enable-6-oem-commands.patch \
- file://0051-Fix-Set-LAN-Config-to-work-without-SetInProgress.patch \
file://0053-Fix-keep-looping-issue-when-entering-OS.patch \
file://0055-Implement-set-front-panel-button-enables-command.patch \
file://0056-add-SetInProgress-to-get-set-boot-option-cmd.patch \
file://0057-Add-timer-use-actions-support.patch \
+ file://0058-Add-AC-failed-bit-support-for-get-chassis-status-com.patch \
+ file://0059-Move-Set-SOL-config-parameter-to-host-ipmid.patch \
+ file://0060-Move-Get-SOL-config-parameter-to-host-ipmid.patch \
"
-do_install_append(){
- install -d ${D}${includedir}/phosphor-ipmi-host
- install -d ${D}${libdir}/phosphor-ipmi-host
- install -m 0644 -D ${S}/*.h ${D}${includedir}/phosphor-ipmi-host
- install -m 0644 -D ${S}/*.hpp ${D}${includedir}/phosphor-ipmi-host
- install -m 0644 -D ${S}/utils.cpp ${D}${libdir}/phosphor-ipmi-host
-
-}