summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/ipmi')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0053-Fix-keep-looping-issue-when-entering-OS.patch2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0064-chassishandler-Fix-for-BIOS-boot-type-Legacy.patch51
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend1
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend2
4 files changed, 54 insertions, 2 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0053-Fix-keep-looping-issue-when-entering-OS.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0053-Fix-keep-looping-issue-when-entering-OS.patch
index 941e356ed..0d86a4223 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0053-Fix-keep-looping-issue-when-entering-OS.patch
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0053-Fix-keep-looping-issue-when-entering-OS.patch
@@ -13,7 +13,7 @@ and fix the issue, clear SMS_ATN after every time power cycle happen.
Unit Test:
After entered OS, force reset system, after enter OS again, OS can start
normally without keep sending READ EVENT MESSAGE BUFFER command.
- After power on system, enter EFI SHELL, check cmdtool.efi can work
+ After power on system, enter EFI SHELL, check IPMI can work
correctly through KCS channel.
---
host-cmd-manager.cpp | 33 ++++++++++++++++++++++++---------
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0064-chassishandler-Fix-for-BIOS-boot-type-Legacy.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0064-chassishandler-Fix-for-BIOS-boot-type-Legacy.patch
new file mode 100644
index 000000000..ff1d0baea
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host/0064-chassishandler-Fix-for-BIOS-boot-type-Legacy.patch
@@ -0,0 +1,51 @@
+From 90df4bce744fdff6de98f63a320c50e24d40a0d4 Mon Sep 17 00:00:00 2001
+From: Jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
+Date: Mon, 2 Aug 2021 16:16:50 +0000
+Subject: [PATCH] Fix for BIOS boot type Legacy
+
+If user trying to set BIOS boot type as Legacy in Set System boot
+options IPMI command is getting success for boot option parameter 5
+(boot flags).
+Legacy boot type is not supported in Intel platforms, so returning
+InvalidFieldRequest. This can't be pushed to upstream as OEM's in
+community supports it.
+
+Tested:
+Verified using IPMI commands.
+//Set system boot options
+Command : ipmitool raw 0x00 0x08 0x05 0x80 0x18 0x00 0x00 0x00
+Response: Unable to send RAW command (channel=0x0 netfn=0x0 lun=0x0
+ cmd=0x8 rsp=0xcc): Invalid data field in request
+Command: ipmitool raw 0x00 0x08 0x05 0xa0 0x18 0x00 0x00 0x00
+Response: //Success
+//Get System boot options
+Command : ipmitool raw 0x00 0x09 0x05 0x00 0x00
+Response: 01 05 a0 18 00 00 00
+
+Signed-off-by: Jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
+---
+ chassishandler.cpp | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/chassishandler.cpp b/chassishandler.cpp
+index f7820af..abc84b6 100644
+--- a/chassishandler.cpp
++++ b/chassishandler.cpp
+@@ -1875,6 +1875,14 @@ ipmi::RspType<> ipmiChassisSetSysBootOptions(ipmi::Context::ptr ctx,
+ {
+ return ipmi::responseInvalidFieldRequest();
+ }
++ constexpr auto biosBootTypeLegacy = 0;
++ if (biosBootType == biosBootTypeLegacy)
++ {
++ // return error if BIOS boot type is legacy
++ log<level::ERR>("ipmiChassisSetSysBootOptions: BIOS boot type "
++ "Legacy is not supported");
++ return ipmi::responseInvalidFieldRequest();
++ }
+
+ using namespace chassis::internal;
+ using namespace chassis::internal::cache;
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 677641faf..84ae31e5c 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -8,6 +8,7 @@ SRC_URI += "file://phosphor-ipmi-host.service \
file://0060-Move-Get-SOL-config-parameter-to-host-ipmid.patch \
file://0062-Update-IPMI-Chassis-Control-command.patch \
file://0063-Save-the-pre-timeout-interrupt-in-dbus-property.patch \
+ file://0064-chassishandler-Fix-for-BIOS-boot-type-Legacy.patch \
"
EXTRA_OECONF_append = " --disable-i2c-whitelist-check"
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
index 7a36ac50e..759306cd0 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-net_%.bbappend
@@ -3,7 +3,7 @@ inherit useradd
# TODO: This should be removed, once up-stream bump up
# issue is resolved
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
-SRCREV = "ecc8efad10bc2101a434a0c1fbd253eeaa1a3a99"
+SRCREV = "b88599a2cef6b4fd2272f065a37ce0f70ca8dd38"
USERADD_PACKAGES = "${PN}"
# add a group called ipmi