summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctp-wrapper.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctp-wrapper.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctp-wrapper.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctp-wrapper.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctp-wrapper.bb
new file mode 100644
index 000000000..05e64ed46
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctp-wrapper.bb
@@ -0,0 +1,28 @@
+SUMMARY = "MCTP Wrapper Library"
+DESCRIPTION = "Implementation of MCTP Wrapper Library"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bcd9ada3a943f58551867d72893cc9ab"
+
+SRC_URI = "git://github.com/Intel-BMC/pmci.git;protocol=ssh"
+SRCREV = "94437a678a1d23b22dc179b5cb7b165e52a429c0"
+
+S = "${WORKDIR}/git/mctp_wrapper"
+
+PV = "1.0+git${SRCPV}"
+
+inherit cmake systemd
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+DEPENDS += " \
+ libmctp-intel \
+ systemd \
+ sdbusplus \
+ phosphor-logging \
+ gtest \
+ boost \
+ phosphor-dbus-interfaces \
+ "
+
+EXTRA_OECMAKE += "-DYOCTO_DEPENDENCIES=ON"