summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
index 740fd460e..d4c50b872 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
@@ -2,15 +2,17 @@ SUMMARY = "MCTP Daemon"
DESCRIPTION = "Implementation of MCTP (DTMF DSP0236)"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+LIC_FILES_CHKSUM = "file://${PN}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/Intel-BMC/pmci.git;protocol=ssh"
-SRCREV = "1bc2bddcff7104cc9040e9b2688761b2d9b32099"
+SRCREV = "108ce1250a9836a8751394ee3a4443ae821de3ec"
-S = "${WORKDIR}/git/mctpd/"
+S = "${WORKDIR}/git"
PV = "1.0+git${SRCPV}"
+OECMAKE_SOURCEPATH = "${S}/${PN}"
+
inherit cmake systemd
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -26,9 +28,7 @@ DEPENDS += " \
nlohmann-json \
gtest \
phosphor-dbus-interfaces \
+ udev \
"
-SMBUS_BINDING = "smbus"
-
FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.mctpd@.service"
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.mctpd@${SMBUS_BINDING}.service"
FILES_${PN} += "/usr/share/mctp/mctp_config.json"