summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/pmci
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/pmci')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/pmci/libmctp-intel_git.bb16
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb14
2 files changed, 26 insertions, 4 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/libmctp-intel_git.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/libmctp-intel_git.bb
new file mode 100644
index 000000000..f7bec2af9
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/libmctp-intel_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "libmctp_intel"
+DESCRIPTION = "Implementation of MCTP(DMTF DSP0236)"
+
+SRC_URI = "git://github.com/Intel-BMC/libmctp.git;protocol=ssh"
+SRCREV = "9f0aa081fdcc1ad5a8ca9025dbd0a559a68f4005"
+
+S = "${WORKDIR}/git/"
+
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0 | GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
+
+inherit cmake
+
+DEPENDS += "i2c-tools"
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
index 72acf3127..d9a2297ac 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/pmci/mctpd.bb
@@ -1,11 +1,11 @@
SUMMARY = "MCTP Daemon"
DESCRIPTION = "Implementation of MCTP (DTMF DSP0236)"
-LICENSE = "Apache-2.0 | GPLv2"
+LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://github.com/Intel-BMC/pmci.git;protocol=ssh"
-SRCREV = "df5eba0d1ea5a1e07d24eca95cc9ce5d25819c69"
+SRCREV = "34e98dc5e6bac78ccee86fb1ea1837b9ef1360a5"
S = "${WORKDIR}/git/mctpd/"
@@ -16,11 +16,17 @@ inherit cmake systemd
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEPENDS += " \
- libmctp \
+ libmctp-intel \
systemd \
sdbusplus \
phosphor-logging \
boost \
i2c-tools \
+ cli11 \
+ nlohmann-json \
+ gtest \
"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.mctpd.service"
+SMBUS_BINDING = "smbus"
+
+FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.mctpd@.service"
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.mctpd@${SMBUS_BINDING}.service"