summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
index 9c4a3c879..46f4a28a9 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -1,4 +1,14 @@
SRC_URI = "git://github.com/Intel-BMC/phosphor-webui;protocol=ssh;branch=intel2"
FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
-SRCREV = "9db94c5d0e61c6cd5935e770c14a9ad6231da497"
+SRCREV = "3b13f734a5f881b9b51346ba09fabea752b145f3"
+
+# Adding the code below as a workaround as
+# favicon gets corrupted during emit due to issue with html-webpack-plugin.
+# This workaround needs to be removed once this issue is fixed in the
+# newer version of html-webpack-plugin
+do_compile_append() {
+ rm -rf ${S}/dist/favicon.ico.gz
+ mv ${S}/dist/favicon.gz ${S}/dist/favicon.ico.gz
+ rm -rf ${S}/dist/app.bundle.js.LICENSE.txt.gz
+}