summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/webui
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/webui')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui/config.json9
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend4
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue/0001-Undo-the-unrelated-package-changes-from-the-axios-up.patch125
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue_%.bbappend12
4 files changed, 150 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui/config.json b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui/config.json
new file mode 100644
index 000000000..348a7792d
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui/config.json
@@ -0,0 +1,9 @@
+{
+ "customKeyEnable": true,
+ "keyType" : "VT100+",
+ "customConsoleDisplaySize": {
+ "width": 100,
+ "height": 32
+ },
+ "VirtualMediaEnabled" : true
+}
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
new file mode 100644
index 000000000..a403c4ec8
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -0,0 +1,4 @@
+SRC_URI = "git://github.com/Intel-BMC/phosphor-webui;protocol=ssh;branch=intel2"
+FILESEXTRAPATHS:prepend:intel := "${THISDIR}/${PN}:"
+
+SRCREV = "2397c142c0d75c7705757a52848945b00928232d"
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue/0001-Undo-the-unrelated-package-changes-from-the-axios-up.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue/0001-Undo-the-unrelated-package-changes-from-the-axios-up.patch
new file mode 100644
index 000000000..1068f8518
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue/0001-Undo-the-unrelated-package-changes-from-the-axios-up.patch
@@ -0,0 +1,125 @@
+From 3b32612a73088b48486d38f46c780dfe3b8d463f Mon Sep 17 00:00:00 2001
+From: "Jason M. Bills" <jason.m.bills@linux.intel.com>
+Date: Fri, 24 Sep 2021 14:46:36 -0700
+Subject: [PATCH] Undo the unrelated package changes from the axios update
+
+When I pushed the update to axios, the npm commands changed other
+packages as well. I assumed this was expected but have since been
+seeing issues with nlf able to get license information.
+
+This reverts the non-axios changes from the previous update.
+
+Tested:
+Built and logged into the web UI successfully. Also successfully
+ran nlf a few times to get node license info.
+
+Change-Id: Idc03c1154861ccd493322e226814b20cc988bb00
+Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
+---
+ package-lock.json | 62 ++++++++++++++++++++---------------------------
+ 1 file changed, 26 insertions(+), 36 deletions(-)
+
+diff --git a/package-lock.json b/package-lock.json
+index df71815..413dd62 100644
+--- a/package-lock.json
++++ b/package-lock.json
+@@ -4155,6 +4155,18 @@
+ "supports-color": "^7.0.0"
+ }
+ },
++ "loader-utils": {
++ "version": "2.0.0",
++ "resolved": "https://registry.npmjs.org/loader-utils/-/loader-utils-2.0.0.tgz",
++ "integrity": "sha512-rP4F0h2RaWSvPEkD7BLDFQnvSf+nK+wr3ESUjNTyAGobqrijmW92zc+SO6d4p4B1wh7+B/Jg1mkQe5NYUEHtHQ==",
++ "dev": true,
++ "optional": true,
++ "requires": {
++ "big.js": "^5.2.2",
++ "emojis-list": "^3.0.0",
++ "json5": "^2.1.2"
++ }
++ },
+ "source-map": {
+ "version": "0.6.1",
+ "resolved": "https://registry.npmjs.org/source-map/-/source-map-0.6.1.tgz",
+@@ -4188,6 +4200,18 @@
+ "webpack-sources": "^1.4.3"
+ }
+ },
++ "vue-loader-v16": {
++ "version": "npm:vue-loader@16.1.2",
++ "resolved": "https://registry.npmjs.org/vue-loader/-/vue-loader-16.1.2.tgz",
++ "integrity": "sha512-8QTxh+Fd+HB6fiL52iEVLKqE9N1JSlMXLR92Ijm6g8PZrwIxckgpqjPDWRP5TWxdiPaHR+alUWsnu1ShQOwt+Q==",
++ "dev": true,
++ "optional": true,
++ "requires": {
++ "chalk": "^4.1.0",
++ "hash-sum": "^2.0.0",
++ "loader-utils": "^2.0.0"
++ }
++ },
+ "wrap-ansi": {
+ "version": "6.2.0",
+ "resolved": "https://registry.npmjs.org/wrap-ansi/-/wrap-ansi-6.2.0.tgz",
+@@ -5552,14 +5576,7 @@
+ "resolved": "https://registry.npmjs.org/axios/-/axios-0.21.4.tgz",
+ "integrity": "sha512-ut5vewkiu8jjGBdqpM44XxjuCjq9LAKeHVmoVfHVzy8eHgxxq8SbAVQNovDA8mVi05kP0Ea/n/UzcSHcTJQfNg==",
+ "requires": {
+- "follow-redirects": "^1.14.0"
+- },
+- "dependencies": {
+- "follow-redirects": {
+- "version": "1.14.4",
+- "resolved": "https://registry.npmjs.org/follow-redirects/-/follow-redirects-1.14.4.tgz",
+- "integrity": "sha512-zwGkiSXC1MUJG/qmeIFH2HBJx9u0V46QGUe3YR1fXG8bXQxq7fLj0RjLZQ5nubr9qNJUZrH+xUcwXEoXNpfS+g=="
+- }
++ "follow-redirects": "^1.10.0"
+ }
+ },
+ "babel-code-frame": {
+@@ -10030,8 +10047,7 @@
+ "follow-redirects": {
+ "version": "1.13.1",
+ "resolved": "https://registry.npmjs.org/follow-redirects/-/follow-redirects-1.13.1.tgz",
+- "integrity": "sha512-SSG5xmZh1mkPGyKzjZP8zLjltIfpW32Y5QpdNJyjcfGxK3qo3NDDkZOZSFiGn1A6SclQxY9GzEwAHQ3dmYRWpg==",
+- "dev": true
++ "integrity": "sha512-SSG5xmZh1mkPGyKzjZP8zLjltIfpW32Y5QpdNJyjcfGxK3qo3NDDkZOZSFiGn1A6SclQxY9GzEwAHQ3dmYRWpg=="
+ },
+ "for-each": {
+ "version": "0.3.3",
+@@ -19486,32 +19502,6 @@
+ }
+ }
+ },
+- "vue-loader-v16": {
+- "version": "npm:vue-loader@16.8.1",
+- "resolved": "https://registry.npmjs.org/vue-loader/-/vue-loader-16.8.1.tgz",
+- "integrity": "sha512-V53TJbHmzjBhCG5OYI2JWy/aYDspz4oVHKxS43Iy212GjGIG1T3EsB3+GWXFm/1z5VwjdjLmdZUFYM70y77vtQ==",
+- "dev": true,
+- "optional": true,
+- "requires": {
+- "chalk": "^4.1.0",
+- "hash-sum": "^2.0.0",
+- "loader-utils": "^2.0.0"
+- },
+- "dependencies": {
+- "loader-utils": {
+- "version": "2.0.0",
+- "resolved": "https://registry.npmjs.org/loader-utils/-/loader-utils-2.0.0.tgz",
+- "integrity": "sha512-rP4F0h2RaWSvPEkD7BLDFQnvSf+nK+wr3ESUjNTyAGobqrijmW92zc+SO6d4p4B1wh7+B/Jg1mkQe5NYUEHtHQ==",
+- "dev": true,
+- "optional": true,
+- "requires": {
+- "big.js": "^5.2.2",
+- "emojis-list": "^3.0.0",
+- "json5": "^2.1.2"
+- }
+- }
+- }
+- },
+ "vue-router": {
+ "version": "3.5.1",
+ "resolved": "https://registry.npmjs.org/vue-router/-/vue-router-3.5.1.tgz",
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue_%.bbappend
new file mode 100644
index 000000000..ed29c89df
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/webui/webui-vue_%.bbappend
@@ -0,0 +1,12 @@
+# Enable downstream autobump
+SRC_URI = "git://github.com/openbmc/webui-vue.git"
+SRCREV = "6a192d526c9efebf7a614a9aa473eee62e555fc5"
+
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+SRC_URI += " \
+ file://0001-Undo-the-unrelated-package-changes-from-the-axios-up.patch \
+ "
+
+do_compile:prepend() {
+ cp -vf ${S}/.env.intel ${S}/.env
+}