summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gimp/gegl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gimp/gegl')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch28
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch32
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.30.bb (renamed from meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.28.bb)8
3 files changed, 33 insertions, 35 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch
new file mode 100644
index 000000000..b2f13afd5
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-Fix-build-with-OpenEXR-3.patch
@@ -0,0 +1,28 @@
+From 073d622fbf8564271cd9be87c2f619ea00498578 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 1 May 2021 08:25:24 -0700
+Subject: [PATCH] Fix build with OpenEXR 3
+
+Add a header that is no longer transitively included
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gegl/-/merge_requests/96]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ operations/external/exr-save.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/operations/external/exr-save.cc b/operations/external/exr-save.cc
+index 1e8c09d..87abed5 100644
+--- a/operations/external/exr-save.cc
++++ b/operations/external/exr-save.cc
+@@ -45,6 +45,7 @@ extern "C" {
+ #include <ImfChromaticities.h>
+ #include <ImfStandardAttributes.h>
+ #include <ImfArray.h>
++#include <ImfFrameBuffer.h>
+ #include "ImathRandom.h"
+
+
+--
+2.31.1
+
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch
deleted file mode 100644
index 6a49f1d7c..000000000
--- a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl/0001-meson.build-Give-note-if-sdl2-was-found.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 6bed199a73a7af39344cf8e799b665011553600c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Sat, 8 Feb 2020 14:29:52 +0100
-Subject: [PATCH] meson.build: Give note if sdl2 was found
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Configure output confused me a bit
-
-Upstream-Status: Pending
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- meson.build | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/meson.build b/meson.build
-index 9d5b484..296b5f3 100644
---- a/meson.build
-+++ b/meson.build
-@@ -374,6 +374,7 @@ message('\n'.join(['',
- ' OpenEXR: @0@'.format(openexr.found()),
- ' rsvg: @0@'.format(librsvg.found()),
- ' SDL: @0@'.format(sdl1.found()),
-+' SDL2: @0@'.format(sdl2.found()),
- ' libraw: @0@'.format(libraw.found()),
- ' Jasper: @0@'.format(jasper.found()),
- ' av libs: @0@'.format(avlibs_found),
---
-2.21.0
-
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.28.bb b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.30.bb
index 810036162..bb0cd1f8a 100644
--- a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.28.bb
+++ b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.30.bb
@@ -24,11 +24,11 @@ SHPV = "${@gnome_verdir("${PV}")}"
SRC_URI = " \
https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \
- file://0001-meson.build-Give-note-if-sdl2-was-found.patch \
+ file://0001-Fix-build-with-OpenEXR-3.patch \
"
-SRC_URI[sha256sum] = "1d110d8577d54cca3b34239315bd37c57ccb27dd4355655074a2d2b3fd897900"
+SRC_URI[sha256sum] = "c112782cf4096969e23217ccdfabe42284e35d5435ff0c43d40e4c70faeca8dd"
-PACKAGECONFIG ??= "gexiv2 jpeg libpng librsvg sdl2"
+PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg poppler sdl2"
PACKAGECONFIG_class-native = "libpng librsvg"
PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper"
@@ -38,7 +38,9 @@ PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg"
PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms"
PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav"
PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng"
+PACKAGECONFIG[libraw] = "-Dlibraw=enabled,-Dlibraw=disabled,libraw"
PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg"
+PACKAGECONFIG[poppler] = "-Dpoppler=enabled,-Dpoppler=disabled,poppler"
PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl"
PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2"
PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff"