summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gnome')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch25
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb2
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-tools_3.32.2.bb22
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-xsl_3.34.0.bb18
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb33
5 files changed, 100 insertions, 0 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch b/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch
new file mode 100644
index 000000000..485c46509
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf/fix-meson-0.52.patch
@@ -0,0 +1,25 @@
+With meson 0.52 the build fails due to duplicate symbols. There is a fix
+to meson but the dconf build also needs tweaking.
+
+https://gitlab.gnome.org/GNOME/dconf/issues/59
+https://github.com/mesonbuild/meson/pull/5936
+
+Despite the comments there about this being incorrect, libdconf is unchanged
+between 0.51 and 0.52 and this patch.
+
+Upstream-Status: Pending [under discussion, see above links]
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+
+Index: dconf-0.34.0/client/meson.build
+===================================================================
+--- dconf-0.34.0.orig/client/meson.build
++++ dconf-0.34.0/client/meson.build
+@@ -28,7 +28,7 @@ libdconf_client = static_library(
+
+ libdconf_client_dep = declare_dependency(
+ dependencies: gio_dep,
+- link_whole: libdconf_client,
++ link_with: libdconf_client,
+ )
+
+ libdconf = shared_library(
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb b/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
index a1996a1a3..ef549432e 100644
--- a/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
+++ b/meta-openembedded/meta-gnome/recipes-gnome/dconf/dconf_0.34.0.bb
@@ -12,6 +12,8 @@ GNOMEBASEBUILDCLASS = "meson"
inherit gnomebase bash-completion vala
+SRC_URI += "file://fix-meson-0.52.patch"
+
# I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
EXTRA_OEMESON = "-Dman=false"
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-tools_3.32.2.bb b/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-tools_3.32.2.bb
new file mode 100644
index 000000000..6a6397cee
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-tools_3.32.2.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Collection of scripts and build utilities for documentation"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=d67c6f9f1515506abfea4f0d920c0774 \
+ file://COPYING.GPL;md5=eb723b61539feef013de476e68b5c50a \
+"
+
+inherit gnomebase
+
+DEPENDS += " \
+ libxslt-native \
+ libxml2-native \
+ itstool-native \
+ yelp-xsl \
+"
+
+SRC_URI[archive.md5sum] = "7856f9ad0492aaf9adf097f5058bfc2e"
+SRC_URI[archive.sha256sum] = "183856b5ed0b0bb2c05dd1204af023946ed436943e35e789afb0295e5e71e8f9"
+
+RDEPENDS_${PN} += "yelp-xsl"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-xsl_3.34.0.bb b/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-xsl_3.34.0.bb
new file mode 100644
index 000000000..17994414e
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp-xsl_3.34.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "XSL stylesheets for the yelp help browser"
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=3e2bad3c5e3990988f9fa1bc5785b147 \
+ file://COPYING.GPL;md5=eb723b61539feef013de476e68b5c50a \
+ file://COPYING.LGPL;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+"
+
+inherit gnomebase gettext
+
+DEPENDS += "libxml2 itstool-native"
+
+SRC_URI[archive.md5sum] = "f8c4e777aee8b055251c333ef48a0cd0"
+SRC_URI[archive.sha256sum] = "e8063aee67d1df634f3d062f1c28130b2dabb3c0c66396b1af90388f34e14ee2"
+
+RDEPENDS_${PN} += "libxml2 itstool"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb b/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb
new file mode 100644
index 000000000..13c4e52bf
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/yelp/yelp_3.34.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Help browser for the GNOME desktop"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
+"
+
+inherit gnomebase autotools-brokensep gsettings gettext gtk-doc
+
+SRC_URI[archive.md5sum] = "776e29bd16424c8712cbf340cfe6429b"
+SRC_URI[archive.sha256sum] = "e3d6527c5963d73206891b32f1f23363164be57de248555513bd0be77a7bd045"
+
+DEPENDS += " \
+ libxml2-native \
+ glib-2.0-native \
+ itstool-native \
+ gtk+3 \
+ appstream-glib \
+ libxslt \
+ sqlite3 \
+ webkitgtk \
+ yelp-xsl \
+"
+
+do_configure_prepend() {
+ export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
+}
+
+FILES_${PN} += " \
+ ${datadir}/metainfo \
+ ${datadir}/yelp-xsl \
+"
+
+RDEPENDS_${PN} += "yelp-xsl"