summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-kernel/sysprof/files')
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch63
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch42
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch35
3 files changed, 0 insertions, 140 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch
deleted file mode 100644
index 1e2b3c92b..000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 4bd0d5d5dd6841fbac8385527617d18e7731244d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 15 Jan 2020 13:17:58 -0800
-Subject: [PATCH] libsysprof-ui: Rename environ to sys_environ
-
-This helps avoid namesapace conflict with glibc headers
-
-Fixes
-/usr/include/unistd.h:545:15: note: previous declaration is here
-
-extern char **environ;
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/libsysprof-ui/sysprof-profiler-assistant.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/libsysprof-ui/sysprof-profiler-assistant.c b/src/libsysprof-ui/sysprof-profiler-assistant.c
-index 22e3e24..c55d551 100644
---- a/src/libsysprof-ui/sysprof-profiler-assistant.c
-+++ b/src/libsysprof-ui/sysprof-profiler-assistant.c
-@@ -235,7 +235,7 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self,
- {
- g_auto(GStrv) argv = NULL;
- g_auto(GStrv) env = NULL;
-- SysprofEnviron *environ;
-+ SysprofEnviron *sys_environ;
- const gchar *command;
- gint argc;
-
-@@ -245,8 +245,8 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self,
- sysprof_profiler_set_spawn (profiler, TRUE);
- sysprof_profiler_set_spawn_argv (profiler, (const gchar * const *)argv);
-
-- environ = sysprof_environ_editor_get_environ (self->environ_editor);
-- env = sysprof_environ_get_environ (environ);
-+ sys_environ = sysprof_environ_editor_get_environ (self->environ_editor);
-+ env = sysprof_environ_get_environ (sys_environ);
- sysprof_profiler_set_spawn_env (profiler, (const gchar * const *)env);
-
- sysprof_profiler_set_spawn_inherit_environ (profiler,
-@@ -405,7 +405,7 @@ sysprof_profiler_assistant_class_init (SysprofProfilerAssistantClass *klass)
- static void
- sysprof_profiler_assistant_init (SysprofProfilerAssistant *self)
- {
-- g_autoptr(SysprofEnviron) environ = sysprof_environ_new ();
-+ g_autoptr(SysprofEnviron) sys_environ = sysprof_environ_new ();
-
- gtk_widget_init_template (GTK_WIDGET (self));
-
-@@ -445,7 +445,7 @@ sysprof_profiler_assistant_init (SysprofProfilerAssistant *self)
- self,
- G_CONNECT_SWAPPED);
-
-- sysprof_environ_editor_set_environ (self->environ_editor, environ);
-+ sysprof_environ_editor_set_environ (self->environ_editor, sys_environ);
- }
-
- void
---
-2.25.0
-
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
deleted file mode 100644
index 235489226..000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 43c39b5685445242d071b3706af2903efa508b4a Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Tue, 14 Jan 2020 12:58:27 +0100
-Subject: [PATCH] meson.build: do not hardcode 'linux' as
- host_machine().system() value
-
-In some build environmets such as OpenEmbedded this can be 'linux-gnueabi'
-or otherwise not exactly 'linux'.
-
-Upstream-Status: Pending
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- src/libsysprof/meson.build | 2 +-
- src/tools/meson.build | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/libsysprof/meson.build b/src/libsysprof/meson.build
-index 3449961..3c2d186 100644
---- a/src/libsysprof/meson.build
-+++ b/src/libsysprof/meson.build
-@@ -84,7 +84,7 @@ libsysprof_deps = [
- polkit_dep,
- ]
-
--if host_machine.system() == 'linux'
-+if host_machine.system().contains('linux')
- libsysprof_public_sources += [
- 'sysprof-memory-source.c',
- 'sysprof-perf-counter.c',
-diff --git a/src/tools/meson.build b/src/tools/meson.build
-index 670052a..3fb7f0c 100644
---- a/src/tools/meson.build
-+++ b/src/tools/meson.build
-@@ -2,7 +2,7 @@ tools_deps = [
- libsysprof_capture_dep,
- ]
-
--if get_option('libsysprof') and host_machine.system() == 'linux'
-+if get_option('libsysprof') and host_machine.system().contains('linux')
- polkit_agent_dep = dependency('polkit-agent-1')
- sysprof_cli = executable('sysprof-cli', 'sysprof-cli.c',
- dependencies: tools_deps + [libsysprof_dep, polkit_dep, polkit_agent_dep],
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch
deleted file mode 100644
index 75aa86cdb..000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3025d80aaacc5f67aa9eb1e6fde30f71d9c5b04b Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 18 Jul 2011 16:00:17 -0700
-Subject: [PATCH 1/2] sysprof: Define NT_GNU_BUILD_ID if undefined
-
-On uclibc elf.h does not have GNU extentions but we need this define
-so we define it locally if its not getting it from elf.h
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-%% original patch: define-NT_GNU_BUILD_ID.patch
----
- src/libsysprof/elfparser.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/libsysprof/elfparser.h b/src/libsysprof/elfparser.h
-index 160e4c9..94fa5c0 100644
---- a/src/libsysprof/elfparser.h
-+++ b/src/libsysprof/elfparser.h
-@@ -18,6 +18,10 @@
-
- #include <glib.h>
-
-+#ifndef NT_GNU_BUILD_ID
-+#define NT_GNU_BUILD_ID 3
-+#endif
-+
- typedef struct ElfSym ElfSym;
- typedef struct ElfParser ElfParser;
-
---
-2.17.1
-