summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-initramfs/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-initramfs/recipes-devtools')
-rw-r--r--meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb1
-rw-r--r--meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_git.bb1
-rw-r--r--meta-openembedded/meta-initramfs/recipes-devtools/klibc/klibc.inc2
3 files changed, 3 insertions, 1 deletions
diff --git a/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb b/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
index dc3a70bb5..7403cf64f 100644
--- a/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
+++ b/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
@@ -35,6 +35,7 @@ do_install_ptest() {
sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
}
+RDEPENDS_${PN} += "bash"
RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
diff --git a/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_git.bb b/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
index 8430b7e10..6d53f48cd 100644
--- a/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
+++ b/meta-openembedded/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
@@ -35,6 +35,7 @@ do_install_ptest() {
sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
}
+RDEPENDS_${PN} += "bash"
RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
diff --git a/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klibc.inc
index 7faf0cabb..86aae3340 100644
--- a/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klibc.inc
+++ b/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klibc.inc
@@ -34,7 +34,7 @@ ARMPATCHES_arm = "file://klibc-config-eabi.patch \
S = "${WORKDIR}/git"
OPTFLAGS = "${TUNE_CCARGS} -Os"
-OPTFLAGS_append_libc-musl_toolchain-clang = " -fno-builtin-bcmp"
+OPTFLAGS_append_toolchain-clang = " -fno-builtin-bcmp"
PARALLEL_MAKE = ""
EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \