summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-multimedia/recipes-multimedia')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.6.0.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb)7
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb21
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-Fix-musl-compatibility.patch30
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-cmu_indic_lang-Make-cst_rx_not_indic-as-extern-decla.patch29
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic_1.3.0.1.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic_1.2.0.2.bb)11
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc1
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch29
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/libmpdclient_2.19.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/libmpdclient_2.16.bb)2
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpc_0.33.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpc_0.31.bb)11
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.38.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.34.bb)2
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch30
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch12
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft_1.20.1.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb)3
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/opusfile/opusfile_0.12.bb (renamed from meta-openembedded/meta-multimedia/recipes-multimedia/opusfile/opusfile_0.10.bb)4
14 files changed, 147 insertions, 45 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.6.0.bb
index c96e4c52e..7f2674183 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/gerbera/gerbera_git.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.6.0.bb
@@ -6,12 +6,11 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=25cdec9afe3f1f26212ead6bd2f7fac8"
SRC_URI = "git://github.com/v00d00/gerbera.git;protocol=https \
"
-PV = "1.3.2"
-SRCREV = "42b035ea9098c02af503d6391a0ed56d973aaf23"
+SRCREV = "b219e22f09e346dd048f614a01ca2cbc55edd940"
S = "${WORKDIR}/git"
-DEPENDS = "expat zlib curl libupnp e2fsprogs sqlite3 libnsl2"
+DEPENDS = "expat fmt spdlog pugixml libebml libmatroska zlib curl libupnp e2fsprogs sqlite3 libnsl2"
SYSTEMD_SERVICE_${PN} = "gerbera.service"
@@ -27,3 +26,5 @@ do_install_append() {
}
FILES_${PN} += "/root/.config/"
+
+SECURITY_CFLAGS_riscv64 = "${SECURITY_NOPIE_CFLAGS}"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
index 00a5c480d..c66c93ec5 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
@@ -1,7 +1,7 @@
SUMMARY = "Linux libcamera framework"
SECTION = "libs"
-LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
+LICENSE = "GPL-2.0+ & LGPL-2.1+"
LIC_FILES_CHKSUM = "\
file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
@@ -18,13 +18,30 @@ PV = "202006+git${SRCPV}"
S = "${WORKDIR}/git"
-DEPENDS = "python3-pyyaml-native udev gnutls boost"
+DEPENDS = "python3-pyyaml-native udev gnutls boost chrpath-native"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
inherit meson pkgconfig python3native
+do_install_append() {
+ chrpath -d ${D}${libdir}/libcamera.so
+}
+
+addtask do_recalculate_ipa_signatures_package after do_package before do_packagedata
+do_recalculate_ipa_signatures_package() {
+ local modules
+ for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do
+ module="${module%.sign}"
+ if [ -f "${module}" ] ; then
+ modules="${modules} ${module}"
+ fi
+ done
+
+ ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}"
+}
+
FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
FILES_${PN} += " ${libdir}/libcamera.so"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-Fix-musl-compatibility.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-Fix-musl-compatibility.patch
new file mode 100644
index 000000000..1352fdde6
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-Fix-musl-compatibility.patch
@@ -0,0 +1,30 @@
+From d7d00ec681dc430192cf2192b3de7b7c30c4753d Mon Sep 17 00:00:00 2001
+From: Bart Ribbers <bribbers@disroot.org>
+Date: Sat, 9 May 2020 11:42:32 +0200
+Subject: [PATCH] Fix musl compatibility
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Backport [https://github.com/MycroftAI/mimic1/commit/5282ff075091c3d1a635fb20f2b8a35a377f4b42.patch]
+---
+ src/hts/hts_engine_API/lib/HTS_misc.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/hts/hts_engine_API/lib/HTS_misc.c b/src/hts/hts_engine_API/lib/HTS_misc.c
+index 72306cb..afcaaec 100644
+--- a/src/hts/hts_engine_API/lib/HTS_misc.c
++++ b/src/hts/hts_engine_API/lib/HTS_misc.c
+@@ -247,8 +247,10 @@ size_t HTS_ftell(HTS_File * fp)
+ fgetpos((FILE *) fp->pointer, &pos);
+ #if defined(_WIN32) || defined(__CYGWIN__) || defined(__APPLE__) || defined(__ANDROID__)
+ return (size_t) pos;
+-#else
++#elif defined(__GLIBC__)
+ return (size_t) pos.__pos;
++#else
++ return (size_t) ftell(fp->pointer);
+ #endif /* _WIN32 || __CYGWIN__ || __APPLE__ || __ANDROID__ */
+ } else if (fp->type == HTS_DATA) {
+ HTS_Data *d = (HTS_Data *) fp->pointer;
+--
+2.28.0
+
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-cmu_indic_lang-Make-cst_rx_not_indic-as-extern-decla.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-cmu_indic_lang-Make-cst_rx_not_indic-as-extern-decla.patch
new file mode 100644
index 000000000..e6bf9eb2b
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic/0001-cmu_indic_lang-Make-cst_rx_not_indic-as-extern-decla.patch
@@ -0,0 +1,29 @@
+From 7d38a72f9ae14a2416f7a78e28152aa33685aec7 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 16:47:27 -0700
+Subject: [PATCH] cmu_indic_lang: Make cst_rx_not_indic as extern declaration
+
+Fixes build with gcc-10 which has -fno-common turned on by default
+
+Upstream-Status: Submitted [https://github.com/MycroftAI/mimic1/pull/211]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lang/cmu_indic_lang/cmu_indic_lang.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lang/cmu_indic_lang/cmu_indic_lang.h b/lang/cmu_indic_lang/cmu_indic_lang.h
+index 75ee46c..83e2afa 100644
+--- a/lang/cmu_indic_lang/cmu_indic_lang.h
++++ b/lang/cmu_indic_lang/cmu_indic_lang.h
+@@ -51,7 +51,7 @@ void cmu_indic_lang_init(cst_voice *v);
+ extern const cst_phoneset cmu_indic_phoneset;
+ extern const cst_cart cmu_indic_phrasing_cart;
+
+-const cst_regex * const cst_rx_not_indic;
++extern const cst_regex * const cst_rx_not_indic;
+
+ #ifdef __cplusplus
+ } /* extern "C" */
+--
+2.28.0
+
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic_1.2.0.2.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic_1.3.0.1.bb
index b313b110c..0cac2bea5 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic_1.2.0.2.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mimic/mimic_1.3.0.1.bb
@@ -15,12 +15,15 @@ LICENSE = "MIT-X & \
BellBird & \
Apache-2.0 \
"
-LIC_FILES_CHKSUM = "file://COPYING;md5=416ef1ca5167707fe381d7be33664a33"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a2c2c7371b58b9cdeae0dc68846fe9f1"
-DEPENDS = "curl-native icu"
+DEPENDS = "curl-native libpcre2"
-SRCREV = "67e43bf0fa56008276b878ec3790aa5f32eb2a16"
-SRC_URI = "git://github.com/MycroftAI/mimic.git"
+SRCREV = "adf655da0399530ac1b586590257847eb61be232"
+SRC_URI = "git://github.com/MycroftAI/mimic1.git \
+ file://0001-Fix-musl-compatibility.patch \
+ file://0001-cmu_indic_lang-Make-cst_rx_not_indic-as-extern-decla.patch \
+ "
inherit autotools
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc b/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc
index 04648a5d2..433388759 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc
@@ -13,6 +13,7 @@ SRC_URI = "git://git.code.sf.net/p/minidlna/git;branch=master;module=git \
file://minidlna.service \
file://0001-Update-Gettext-version.patch \
file://0001-configure-Check-for-clock_gettime-seprately-from-__N.patch \
+ file://0001-Mark-setjmp_buffer-extern-declaration.patch \
"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch
new file mode 100644
index 000000000..0a1e800c8
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch
@@ -0,0 +1,29 @@
+From 1c6028f5f8bbfd3fd7327a43e1bb762c2c166167 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 18:10:54 -0700
+Subject: [PATCH] Mark setjmp_buffer extern declaration
+
+Fixes build with -fno-common
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ metadata.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/metadata.c b/metadata.c
+index 8a10c77..c114091 100644
+--- a/metadata.c
++++ b/metadata.c
+@@ -484,7 +484,7 @@ GetAudioMetadata(const char *path, const char *name)
+ }
+
+ /* For libjpeg error handling */
+-jmp_buf setjmp_buffer;
++extern jmp_buf setjmp_buffer;
+ static void
+ libjpeg_error_handler(j_common_ptr cinfo)
+ {
+--
+2.28.0
+
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/libmpdclient_2.16.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/libmpdclient_2.19.bb
index 235e63e48..32f9688ea 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/libmpdclient_2.16.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/libmpdclient_2.19.bb
@@ -8,7 +8,7 @@ inherit meson
SRC_URI = " \
git://github.com/MusicPlayerDaemon/libmpdclient \
"
-SRCREV = "4e8d990eb5239566ee948f1cd79b7248e008620a"
+SRCREV = "27767959442ef390aabb16790494ba93fed962ef"
S = "${WORKDIR}/git"
PACKAGECONFIG ??= "tcp"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpc_0.31.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpc_0.33.bb
index 41abe7108..dcfc3df0b 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpc_0.31.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/mpc_0.33.bb
@@ -5,12 +5,9 @@ HOMEPAGE = "https://www.musicpd.org/clients/mpc/"
inherit meson
-DEPENDS += " \
- libmpdclient \
-"
+DEPENDS += "libmpdclient"
+
+SRC_URI = "git://github.com/MusicPlayerDaemon/mpc"
+SRCREV = "ef16b280052ef0320cb80f79d74c8ce0324005ed"
-SRC_URI = " \
- git://github.com/MusicPlayerDaemon/mpc \
-"
-SRCREV = "59875acdf34e5f0eac0c11453c49daef54f78413"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.34.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.38.bb
index 0c99c7c69..ebf5d290b 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.34.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/musicpd/ncmpc_0.38.bb
@@ -33,5 +33,5 @@ PACKAGECONFIG[chat_screen] = "-Dchat_screen=true,-Dchat_screen=false"
SRC_URI = " \
git://github.com/MusicPlayerDaemon/ncmpc \
"
-SRCREV = "79cf9905355f25bc5cc6d5a05d2846d75342f554"
+SRCREV = "2c71add42152072c5e0490de2870315dfb3b71e1"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch
index 16f123fad..2bffd65c6 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch
@@ -13,21 +13,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
CMakeLists.txt | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 39b80250..d6bdf8ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1288,11 +1288,10 @@ FILE(MAKE_DIRECTORY "${NATIVE_BIN_DIR}")
- SET(BIN2H_COMMAND "${NATIVE_BIN_DIR}bin2h")
- SET(BSINCGEN_COMMAND "${NATIVE_BIN_DIR}bsincgen")
- ADD_CUSTOM_COMMAND(OUTPUT "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}"
-- COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" "${NATIVE_SRC_DIR}"
- COMMAND ${CMAKE_COMMAND} -E remove "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}"
-- COMMAND ${CMAKE_COMMAND} --build . --config "Release"
-+ COMMAND gcc "${NATIVE_SRC_DIR}bin2h.c" -o "${BIN2H_COMMAND}" -lm
-+ COMMAND gcc "${NATIVE_SRC_DIR}bsincgen.c" -o "${BSINCGEN_COMMAND}" -lm
- WORKING_DIRECTORY "${NATIVE_BIN_DIR}"
-- DEPENDS "${NATIVE_SRC_DIR}CMakeLists.txt"
- IMPLICIT_DEPENDS C "${NATIVE_SRC_DIR}bin2h.c"
- C "${NATIVE_SRC_DIR}bsincgen.c"
- VERBATIM
+@@ -1085,11 +1085,10 @@ ELSE()
+ SET(BIN2H_COMMAND "${NATIVE_BIN_DIR}/bin2h")
+ SET(BSINCGEN_COMMAND "${NATIVE_BIN_DIR}/bsincgen")
+ ADD_CUSTOM_COMMAND(OUTPUT "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}"
+- COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" "${NATIVE_SRC_DIR}"
+ COMMAND ${CMAKE_COMMAND} -E remove "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}"
+- COMMAND ${CMAKE_COMMAND} --build . --config "Release"
++ COMMAND gcc "${NATIVE_SRC_DIR}/bin2h.c" -o "${BIN2H_COMMAND}" -lm
++ COMMAND gcc "${NATIVE_SRC_DIR}/bsincgen.c" -o "${BSINCGEN_COMMAND}" -lm
+ WORKING_DIRECTORY "${NATIVE_BIN_DIR}"
+- DEPENDS "${NATIVE_SRC_DIR}/CMakeLists.txt"
+ IMPLICIT_DEPENDS
+ C "${NATIVE_SRC_DIR}/bin2h.c"
+ C "${NATIVE_SRC_DIR}/bsincgen.c"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch
index 8420386e3..607ddab8d 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch
@@ -6,14 +6,12 @@ Subject: [PATCH] makehrtf: Disable Wstringop-truncation
Upstream-Status: Inappropriate [Should be fixed in code]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- utils/makehrtf.c | 2 ++
+ utils/makemhr/makemhr.cpp | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/utils/makehrtf.c b/utils/makehrtf.c
-index 0bd36849..0abe4252 100644
---- a/utils/makehrtf.c
-+++ b/utils/makehrtf.c
-@@ -862,6 +862,7 @@ static int TrReadOperator(TokenReaderT *tr, const char *op)
+--- a/utils/makemhr/makemhr.cpp
++++ b/utils/makemhr/makemhr.cpp
+@@ -161,6 +161,7 @@ enum ChannelIndex : uint {
* pattern string are replaced with the replacement string. The result is
* truncated if necessary.
*/
@@ -21,7 +19,7 @@ index 0bd36849..0abe4252 100644
static int StrSubst(const char *in, const char *pat, const char *rep, const size_t maxLen, char *out)
{
size_t inLen, patLen, repLen;
-@@ -900,6 +901,7 @@ static int StrSubst(const char *in, const char *pat, const char *rep, const size
+@@ -199,6 +200,7 @@ static int StrSubst(const char *in, cons
return !truncated;
}
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft_1.20.1.bb
index a9cdfac8a..d283cb361 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/openal/openal-soft_1.20.1.bb
@@ -5,8 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0f159f19f9377e1895fbb477d5a7953e"
inherit cmake pkgconfig
-# openal-soft-1.19.1
-SRCREV = "6761218e51699f46bf25c377e65b3e9ea5e434b9"
+SRCREV = "f5e0eef34db3a3ab94b61a2f99f84f078ba947e7"
SRC_URI = "git://github.com/kcat/openal-soft \
file://0001-Use-BUILD_CC-to-compile-native-tools.patch \
file://0002-makehrtf-Disable-Wstringop-truncation.patch \
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/opusfile/opusfile_0.10.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/opusfile/opusfile_0.12.bb
index 3f6dbb8e9..c775cef5a 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/opusfile/opusfile_0.10.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/opusfile/opusfile_0.12.bb
@@ -8,7 +8,7 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=6ac22b992dde6a891f8949c3e2da8576"
SRC_URI = "https://downloads.xiph.org/releases/opus/${BP}.tar.gz"
-SRC_URI[md5sum] = "ab3f7d15d766f5b36b0951ee435f9ebf"
-SRC_URI[sha256sum] = "48e03526ba87ef9cf5f1c47b5ebe3aa195bd89b912a57060c36184a6cd19412f"
+SRC_URI[md5sum] = "45e8c62f6cd413395223c82f06bfa8ec"
+SRC_URI[sha256sum] = "118d8601c12dd6a44f52423e68ca9083cc9f2bfe72da7a8c1acb22a80ae3550b"
inherit autotools pkgconfig