summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-multimedia')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc4
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_git.bb11
-rw-r--r--meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch73
-rw-r--r--meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb18
-rw-r--r--meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb20
5 files changed, 25 insertions, 101 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc b/meta-openembedded/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
index 847a22311..74a2683ac 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
@@ -5,8 +5,8 @@ LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
SRC_URI = "git://github.com/FluidSynth/fluidsynth.git;branch=2.1.x"
-SRCREV = "fd9bf6a6b0d10a984d2eb0e0e549700b7aa590ec"
+SRCREV = "e2d67ea77237046b703d537aec90620c22f7f629"
S = "${WORKDIR}/git"
-PV = "2.1.6"
+PV = "2.1.7"
inherit cmake pkgconfig lib_package
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_git.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_git.bb
index d047caef5..94d05def3 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_git.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_git.bb
@@ -10,9 +10,9 @@ DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad "
SRCBRANCH ?= "master"
-PV = "0.6.1"
+PV = "0.7.2"
-SRCREV_base = "c41a05cc9e2310c2f73eda4b4f0b4477bf4479c5"
+SRCREV_base = "50e3dbd3b131de2a39d3917576e8f834631ec46b"
SRCREV_common = "88e512ca7197a45c4114f7fa993108f23245bf50"
SRC_URI = " \
@@ -22,7 +22,7 @@ SRC_URI = " \
S = "${WORKDIR}/git"
-PACKAGECONFIG_CONFARGS = " \
+EXTRA_OECONF += " \
--disable-graphviz \
--enable-gtk-doc=no \
"
@@ -33,8 +33,3 @@ FILES_${PN} += "\
"
inherit autotools gettext
-
-do_configure() {
- ${S}/autogen.sh --noconfigure
- oe_runconf
-}
diff --git a/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch b/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch
deleted file mode 100644
index b56c78959..000000000
--- a/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp/0001-Rename-conflicting-variable-mips.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 3dc8a678a844247d0afcf7e30fb3cbd5ccbd828f Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 29 Jun 2017 14:05:06 -0700
-Subject: [PATCH] Rename conflicting variable 'mips'
-
-Fixes
-test/srtp_driver.c:344:12: error: expected identifier or '(' before numeric constant
- double mips = mips_estimate(1000000000, &ignore);
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- test/srtp_driver.c | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/test/srtp_driver.c b/test/srtp_driver.c
-index 8872971..d38ea19 100644
---- a/test/srtp_driver.c
-+++ b/test/srtp_driver.c
-@@ -341,7 +341,7 @@ main (int argc, char *argv[]) {
- if (do_codec_timing) {
- srtp_policy_t policy;
- int ignore;
-- double mips = mips_estimate(1000000000, &ignore);
-+ double est = mips_estimate(1000000000, &ignore);
-
- crypto_policy_set_rtp_default(&policy.rtp);
- crypto_policy_set_rtcp_default(&policy.rtcp);
-@@ -353,33 +353,33 @@ main (int argc, char *argv[]) {
- policy.allow_repeat_tx = 0;
- policy.next = NULL;
-
-- printf("mips estimate: %e\n", mips);
-+ printf("mips estimate: %e\n", est);
-
- printf("testing srtp processing time for voice codecs:\n");
- printf("codec\t\tlength (octets)\t\tsrtp instructions/second\n");
- printf("G.711\t\t%d\t\t\t%e\n", 80,
-- (double) mips * (80 * 8) /
-+ (double) est * (80 * 8) /
- srtp_bits_per_second(80, &policy) / .01 );
- printf("G.711\t\t%d\t\t\t%e\n", 160,
-- (double) mips * (160 * 8) /
-+ (double) est * (160 * 8) /
- srtp_bits_per_second(160, &policy) / .02);
- printf("G.726-32\t%d\t\t\t%e\n", 40,
-- (double) mips * (40 * 8) /
-+ (double) est * (40 * 8) /
- srtp_bits_per_second(40, &policy) / .01 );
- printf("G.726-32\t%d\t\t\t%e\n", 80,
-- (double) mips * (80 * 8) /
-+ (double) est * (80 * 8) /
- srtp_bits_per_second(80, &policy) / .02);
- printf("G.729\t\t%d\t\t\t%e\n", 10,
-- (double) mips * (10 * 8) /
-+ (double) est * (10 * 8) /
- srtp_bits_per_second(10, &policy) / .01 );
- printf("G.729\t\t%d\t\t\t%e\n", 20,
-- (double) mips * (20 * 8) /
-+ (double) est * (20 * 8) /
- srtp_bits_per_second(20, &policy) / .02 );
- printf("Wideband\t%d\t\t\t%e\n", 320,
-- (double) mips * (320 * 8) /
-+ (double) est * (320 * 8) /
- srtp_bits_per_second(320, &policy) / .01 );
- printf("Wideband\t%d\t\t\t%e\n", 640,
-- (double) mips * (640 * 8) /
-+ (double) est * (640 * 8) /
- srtp_bits_per_second(640, &policy) / .02 );
- }
-
---
-2.13.2
-
diff --git a/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb b/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb
deleted file mode 100644
index 6c868185f..000000000
--- a/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_1.6.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "library implementing Secure RTP (RFC 3711)"
-HOMEPAGE = "https://github.com/cisco/libsrtp"
-SECTION = "libs"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=15bc16b9d2e305974dde47e733883714"
-
-S = "${WORKDIR}/git"
-SRCREV = "2b091a4fb21c9b06fc5d4b5763bdaec97542fcd7"
-SRC_URI = "git://github.com/cisco/libsrtp.git;protocol=https;branch=1_6_x_throttle; \
- file://0001-Rename-conflicting-variable-mips.patch \
- "
-
-inherit autotools pkgconfig
-
-EXTRA_OEMAKE += "shared_library"
-
-ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb b/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb
new file mode 100644
index 000000000..9d4c305fc
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-support/libsrtp/libsrtp_2.3.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "library implementing Secure RTP (RFC 3711)"
+HOMEPAGE = "https://github.com/cisco/libsrtp"
+SECTION = "libs"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2909fcf6f09ffff8430463d91c08c4e1"
+
+S = "${WORKDIR}/git"
+SRCREV = "d02d21111e379c297e93a9033d7b653135f732ee"
+SRC_URI = "git://github.com/cisco/libsrtp.git"
+
+inherit autotools pkgconfig
+
+EXTRA_OEMAKE += "shared_library"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR_NATIVE}/automake-*/ar-lib ${S}
+}
+
+ALLOW_EMPTY_${PN} = "1"