summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-multimedia')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb11
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb3
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb98
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb2
4 files changed, 88 insertions, 26 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
index c66c93ec5..5505626d3 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
@@ -12,15 +12,20 @@ SRC_URI = " \
git://linuxtv.org/libcamera.git;protocol=git \
"
-SRCREV = "5f2f9406cebc668f0d69007d1ea59ef3c56ef28c"
+SRCREV = "1e8c91b65695449c5246d17ba7dc439c8058b781"
-PV = "202006+git${SRCPV}"
+PV = "202008+git${SRCPV}"
S = "${WORKDIR}/git"
DEPENDS = "python3-pyyaml-native udev gnutls boost chrpath-native"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
+PACKAGES =+ "${PN}-gst"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
+
RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
inherit meson pkgconfig python3native
@@ -44,4 +49,4 @@ do_recalculate_ipa_signatures_package() {
FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
FILES_${PN} += " ${libdir}/libcamera.so"
-
+FILES_${PN}-gst = "${libdir}/gstreamer-1.0/libgstlibcamera.so"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
index 62d1ad7f7..2db30dda0 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.8.1.bb
@@ -84,4 +84,7 @@ RDEPENDS_${PN} += "flac mpg123"
# Mycroft can do this itself on the target, but it's quicker to do it here
RDEPENDS_${PN} += "mimic"
+# pgrep is used by stop-mycroft.sh
+RDEPENDS_${PN} += "procps"
+
SYSTEMD_SERVICE_${PN} = "mycroft-setup.service mycroft.service"
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
index e0cb415e3..2bf8877bb 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
@@ -20,33 +20,87 @@ RDEPENDS_packagegroup-meta-multimedia = "\
"
RDEPENDS_packagegroup-meta-multimedia = "\
- libdvbpsi libdc1394 gstd gst-shark \
- bigbuckbunny-720p tearsofsteel-1080p bigbuckbunny-1080p bigbuckbunny-480p \
- openal-soft dleyna-core dleyna-renderer dleyna-server dleyna-connector-dbus \
- alsa-equal libdvdnav libmusicbrainz tinyalsa \
- fluidsynth cdparanoia vorbis-tools tremor caps libao libavc1394 \
- opusfile gerbera libdvdcss webrtc-audio-processing \
- rtmpdump libopenmpt schroedinger mpd mpc libmpdclient \
- ncmpc libmpd dcadec libiec61883 \
- ${@bb.utils.contains("DISTRO_FEATURES", "pam", "", "", d)} \
- ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "minidlna vlc", "", d)} \
- ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "vo-aacenc sox libde265", "", d)} \
- ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "streamripper", "", d)} \
- ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "openh264 opencore-amr faac vo-amrwbenc", "", d)} \
- "
+ alsa-equal \
+ caps \
+ cdparanoia \
+ dcadec \
+ dleyna-connector-dbus \
+ dleyna-core \
+ dleyna-renderer \
+ dleyna-server \
+ dvb-apps \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "faac", "", d)} \
+ fdk-aac \
+ gerbera \
+ libao \
+ libavc1394 \
+ libdc1394 \
+ libdvbpsi \
+ libdvdnav \
+ libiec61883 \
+ fluidsynth \
+ libmusicbrainz \
+ libmpdclient \
+ mpc \
+ mpd \
+ ncmpc \
+ libmpd \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "opencore-amr vo-aacenc vo-amrwbenc", "", d)} \
+ gst-shark \
+ gstd \
+ rtmpdump \
+ bigbuckbunny-1080p \
+ bigbuckbunny-480p \
+ bigbuckbunny-720p \
+ tearsofsteel-1080p \
+ schroedinger \
+ projucer \
+ libcamera \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libde265 openh264", "", d)} \
+ vorbis-tools \
+ libdvbcsa \
+ libopenmpt \
+ mimic \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "minidlna", "", d)} \
+ mycroft \
+ openal-soft \
+ opusfile \
+ libdvdcss \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "vlc", "", d)} \
+ ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "sox streamripper", "", d)} \
+ tinyalsa \
+ tremor \
+ webrtc-audio-processing \
+ ${@bb.utils.contains_any("TRANSLATED_TARGET_ARCH", "i586 x86-64", "x265", "", d)} \
+"
+RDEPENDS_packagegroup-meta-multimedia_remove_libc-musl = "projucer"
RDEPENDS_packagegroup-meta-multimedia-connectivity = "\
- rygel gupnp gupnp-igd gssdp gupnp-dlna gupnp-av libupnp \
+ gssdp \
+ gupnp-av \
+ gupnp-dlna \
+ gupnp-igd \
${@bb.utils.contains("DISTRO_FEATURES", "x11", "gupnp-tools", "", d)} \
- "
-
+ gupnp \
+ libupnp \
+ rygel \
+"
RDEPENDS_packagegroup-meta-multimedia-dvb = "\
- oscam "
+ oscam \
+ tvheadend \
+"
RDEPENDS_packagegroup-meta-multimedia-mkv = "\
- libmatroska libebml \
- "
+ libebml \
+ libmatroska \
+"
RDEPENDS_packagegroup-meta-multimedia-support = "\
- libmediaart libmediaart-2.0 gst-instruments libsrtp crossguid \
- "
+ crossguid \
+ libmediaart-2.0 \
+ libmediaart \
+ gst-instruments \
+ libsrtp \
+"
+# devel headers/libraries only packages
+# libsquish
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb
index d026c69a8..2f1fda341 100644
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d91a46405fc074b88c963cc4f2a0aae9 \
DEPENDS = "orc-native orc"
-SRC_URI = "http://www.diracvideo.org/download/schroedinger/${BP}.tar.gz \
+SRC_URI = "https://download.videolan.org/contrib/${BPN}/${BP}.tar.gz \
file://configure.ac.patch"
SRC_URI[md5sum] = "da6af08e564ca1157348fb8d92efc891"