summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity/firewalld
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity/firewalld')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/firewalld/firewalld_0.9.1.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/firewalld/firewalld_0.7.3.bb)12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/firewalld/firewalld_0.7.3.bb b/meta-openembedded/meta-networking/recipes-connectivity/firewalld/firewalld_0.9.1.bb
index 4dea848f4..eca926ee4 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/firewalld/firewalld_0.7.3.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/firewalld/firewalld_0.9.1.bb
@@ -8,16 +8,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
file://firewalld.init \
"
-SRC_URI[md5sum] = "05ec772cbdc0a2b3df081e4beca5599d"
-SRC_URI[sha256sum] = "414c46202c12334cd5c986214e5e2575d18e743c5531a97ace1c0cd94341c60d"
+SRC_URI[sha256sum] = "7e3db6ed84919dd10add39cc7a28d97b5a9e27a53aeb73abf8af01ef082b74f9"
# glib-2.0-native is needed for GSETTINGS_RULES autoconf macro from gsettings.m4
-DEPENDS = "intltool-native glib-2.0-native libxslt-native docbook-xsl-stylesheets-native"
+DEPENDS = "intltool-native glib-2.0-native"
inherit gettext autotools bash-completion python3native gsettings systemd update-rc.d
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd"
+PACKAGECONFIG[docs] = "--with-xml-catalog=${STAGING_ETCDIR_NATIVE}/xml/catalog,--disable-docs,libxslt-native docbook-xsl-stylesheets-native"
PACKAGES += "${PN}-zsh-completion"
@@ -28,7 +28,6 @@ PACKAGES += "${PN}-zsh-completion"
# /etc/sysconfig/firewalld is a Red Hat-ism, only referenced by
# the Red Hat-specific init script which we aren't using, so we disable that.
EXTRA_OECONF = "\
- --with-nft=${sbindir}/nft \
--without-ipset \
--with-iptables=${sbindir}/iptables \
--with-iptables-restore=${sbindir}/iptables-restore \
@@ -37,7 +36,6 @@ EXTRA_OECONF = "\
--without-ebtables \
--without-ebtables-restore \
--disable-sysconfig \
- --with-xml-catalog=${STAGING_ETCDIR_NATIVE}/xml/catalog \
"
INITSCRIPT_NAME = "firewalld"
@@ -62,6 +60,9 @@ do_install_append() {
fi
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g \
${D}${bindir}/* ${D}${sbindir}/* ${D}${sysconfdir}/firewalld/*.xml
+
+ # This file contains Red Hat-isms. Modules get loaded without it.
+ rm -f ${D}${sysconfdir}/modprobe.d/firewalld-sysctls.conf
}
FILES_${PN} += "\
@@ -86,4 +87,5 @@ RDEPENDS_${PN} = "\
python3-slip-dbus \
python3-decorator \
python3-pygobject \
+ nftables-python \
"