summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb)2
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch43
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch32
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb)9
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/freeradius/files/0001-workaround-error-with-autoconf-2.7.patch42
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.20.bb1
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls/0001-ssl_tls-Increase-size-of-padbuf-to-64.patch34
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.25.0.bb1
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/1571.patch2
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch14
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.8.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb)18
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.28.0.bb2
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.10.18.bb4
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.7.0.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.6.0.bb)2
14 files changed, 96 insertions, 110 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb b/meta-openembedded/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb
index 75f303068..76df27851 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/adcli/adcli_0.8.2.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "A helper library and tools for Active Directory client operations
HOMEPAGE = "http://cgit.freedesktop.org/realmd/adcli"
SECTION = "net"
-SRCREV = "cc3ef52884a48863a81acbfc741735fe09cd85f7"
+SRCREV = "1b1528038e084a9f81ea108cffca9c2707623b9c"
SRC_URI = "git://gitlab.freedesktop.org/realmd/adcli;branch=master \
file://Fixed-build-error-on-musl.patch \
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch b/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch
deleted file mode 100644
index b78f0b329..000000000
--- a/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From c74f04dbab4d586287347b1d5517f36e2f0c3d8e Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 Dec 2019 15:52:34 -0800
-Subject: [PATCH] Use GNUInstallDirs instead of hard-coding paths
-
-Bump minimum cmake version to be >= 3.1
-
-Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 51b354f..958e0eb 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 2.6)
-+cmake_minimum_required(VERSION 3.1)
- project(cannelloni)
-
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
-@@ -60,6 +60,8 @@ set_target_properties ( cannelloni-common
- SOVERSION 0
- )
-
-+include(GNUInstallDirs)
-+
- if(SCTP_SUPPORT)
- add_library(sctpthread STATIC sctpthread.cpp)
- target_link_libraries(sctpthread addsources sctp)
-@@ -68,5 +70,5 @@ endif(SCTP_SUPPORT)
- set_target_properties(addsources PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
- target_link_libraries(cannelloni addsources cannelloni-common pthread)
-
--install(TARGETS cannelloni DESTINATION bin)
--install(TARGETS cannelloni-common DESTINATION lib)
-+install(TARGETS cannelloni DESTINATION ${CMAKE_INSTALL_BINDIR})
-+install(TARGETS cannelloni-common DESTINATION ${CMAKE_INSTALL_LIBDIR})
---
-2.24.1
-
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch b/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
deleted file mode 100644
index 55f28dd67..000000000
--- a/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 1788762863cd1f657697575f6e73a22e661ccb43 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 23 Dec 2019 10:32:54 -0800
-Subject: [PATCH 2/2] include missing <stdexcept> for runtime_error
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes
-error: ‘runtime_error’ is not a member of ‘std’
-
-Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- parser.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/parser.cpp b/parser.cpp
-index 4afb9e0..5bcdbde 100644
---- a/parser.cpp
-+++ b/parser.cpp
-@@ -2,6 +2,7 @@
-
- #include <arpa/inet.h>
- #include <string.h>
-+#include <stdexcept>
-
- void parseFrames(uint16_t len, const uint8_t* buffer, std::function<canfd_frame*()> frameAllocator,
- std::function<void(canfd_frame*, bool)> frameReceiver)
---
-2.24.1
-
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb b/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb
index d4a62bd92..0cf57ccdb 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.0.0.bb
@@ -2,13 +2,8 @@ SUMMARY = "a SocketCAN over Ethernet tunnel"
HOMEPAGE = "https://github.com/mguentner/cannelloni"
LICENSE = "GPLv2"
-SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \
- file://0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch \
- file://0002-include-missing-stdexcept-for-runtime_error.patch \
- "
-SRCREV = "82aa49b417b96fe46bb3f017ae1bfea928f20f9a"
-
-PV = "20160414+${SRCPV}"
+SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https"
+SRCREV = "0bd7e27db35bdef361226882ae04205504f7b2f4"
LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/freeradius/files/0001-workaround-error-with-autoconf-2.7.patch b/meta-openembedded/meta-networking/recipes-connectivity/freeradius/files/0001-workaround-error-with-autoconf-2.7.patch
new file mode 100644
index 000000000..80c571df9
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/freeradius/files/0001-workaround-error-with-autoconf-2.7.patch
@@ -0,0 +1,42 @@
+From 3b4ba29c7c5800df87eecd65214244619e01162b Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Sun, 7 Feb 2021 16:02:36 +0800
+Subject: [PATCH] workaround error with autoconf 2.7
+
+While using autoconf 2.7, the AM_MISSING_PROG caused unexpected error:
+...
+configure.ac: error: required file 'missing' not found
+...
+
+Since these tools were explicitly added by autotools bbclass,
+remove the testing to workaround the error with autoconf 2.7
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ configure.ac | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 609efb104b..2d761cf62c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -693,14 +693,6 @@ fi
+
+ AC_PATH_PROG(RUSERS, rusers, /usr/bin/rusers)
+
+-dnl #
+-dnl # FIXME This is truly gross.
+-dnl #
+-missing_dir=`cd $ac_aux_dir && pwd`
+-AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
+-AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
+-AM_MISSING_PROG(AUTOHEADER, autoheader, $missing_dir)
+-
+ AC_PATH_PROG(LOCATE,locate)
+ AC_PATH_PROG(DIRNAME,dirname)
+ AC_PATH_PROG(GREP,grep)
+--
+2.27.0
+
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.20.bb b/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.20.bb
index 2c39c4c44..608d66b1b 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.20.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.20.bb
@@ -29,6 +29,7 @@ SRC_URI = "git://github.com/FreeRADIUS/freeradius-server.git;branch=v3.0.x;lfs=0
file://0001-rlm_python3-add-PY_INC_DIR-in-search-dir.patch \
file://0001-raddb-certs-Makefile-fix-the-existed-certificate-err.patch \
file://0001-raddb-certs-Makefile-fix-the-occasional-verification.patch \
+ file://0001-workaround-error-with-autoconf-2.7.patch \
file://radiusd.service \
file://radiusd-volatiles.conf \
"
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls/0001-ssl_tls-Increase-size-of-padbuf-to-64.patch b/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls/0001-ssl_tls-Increase-size-of-padbuf-to-64.patch
new file mode 100644
index 000000000..f3ba04f51
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls/0001-ssl_tls-Increase-size-of-padbuf-to-64.patch
@@ -0,0 +1,34 @@
+From c3d7321d59e959b357a7d3d69782d9105f3d04aa Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 1 Mar 2021 21:04:57 -0800
+Subject: [PATCH] ssl_tls: Increase size of padbuf to 64
+
+This fixes warnings with gcc11
+
+git/library/ssl_tls.c: In function 'ssl_calc_finished_tls_sha384':
+git/library/ssl_tls.c:3267:5: error: 'mbedtls_sha512_finish_ret' accessing 64 bytes in a region of size 48 [-Werror=stringop-overflow=]
+ 3267 | finish( &sha512, padbuf );
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~
+git/library/ssl_tls.c:3267:5: note: referencing argument 2 of type 'unsigned char *'
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ library/ssl_tls.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/library/ssl_tls.c b/library/ssl_tls.c
+index a1a5859f0..4c98a4104 100644
+--- a/library/ssl_tls.c
++++ b/library/ssl_tls.c
+@@ -3205,7 +3205,7 @@ static void ssl_calc_finished_tls_sha384(
+ {
+ int len = 12;
+ const char *sender;
+- unsigned char padbuf[48];
++ unsigned char padbuf[64];
+ #if defined(MBEDTLS_USE_PSA_CRYPTO)
+ size_t hash_size;
+ psa_hash_operation_t sha384_psa = PSA_HASH_OPERATION_INIT;
+--
+2.30.1
+
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.25.0.bb b/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.25.0.bb
index 27c1b209d..481e7ea94 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.25.0.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.25.0.bb
@@ -25,6 +25,7 @@ SECTION = "libs"
S = "${WORKDIR}/git"
SRCREV = "1c54b5410fd48d6bcada97e30cac417c5c7eea67"
SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development"
+SRC_URI += "file://0001-ssl_tls-Increase-size-of-padbuf-to-64.patch"
inherit cmake
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/1571.patch b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/1571.patch
index 93ff6bcfa..37560f30c 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/1571.patch
+++ b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/1571.patch
@@ -11,7 +11,7 @@ Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
-@@ -89,6 +89,8 @@
+@@ -94,6 +94,8 @@
OUTPUT_NAME mosquitto
VERSION ${VERSION}
SOVERSION 1
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch
deleted file mode 100644
index 1397fc6a2..000000000
--- a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Description: Also install mqtt_protocol.h, as is done in Makefile
-Author: Gianfranco Costamagna <locutusofborg@debian.org>
-Bug-Debian: https://bugs.debian.org/951116
-Forwarded: https://github.com/eclipse/mosquitto/pull/1599
-Last-Update: 2020-02-15
-
---- a/lib/CMakeLists.txt
-+++ b/lib/CMakeLists.txt
-@@ -114,4 +114,4 @@
- install(TARGETS libmosquitto_static ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}")
- endif (WITH_STATIC_LIBRARIES)
-
--install(FILES mosquitto.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
-+install(FILES mqtt_protocol.h mosquitto.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.8.bb
index 36bfe099f..03a829fc8 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.8.bb
@@ -6,22 +6,21 @@ provides a lightweight method of carrying out messaging using a \
publish/subscribe model. "
HOMEPAGE = "http://mosquitto.org/"
SECTION = "console/network"
-LICENSE = "EPL-1.0 | EDL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20 \
+LICENSE = "EPL-2.0 | EDL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ca9a8f366c6babf593e374d0d7d58749 \
file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
- file://epl-v10;md5=8d383c379e91d20ba18a52c3e7d3a979 \
- file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \
+ file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
+ file://notice.html;md5=541f8f37af492858dab8d2c1b69ede69 \
"
-DEPENDS = "uthash"
+DEPENDS = "uthash cjson dlt-daemon"
SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
file://mosquitto.init \
file://1571.patch \
- file://install-protocol.patch \
"
-SRC_URI[md5sum] = "beb8d76d6e45f1e66d711006082a631f"
-SRC_URI[sha256sum] = "548d73d19fb787dd0530334e398fd256ef3a581181678488a741a995c4f007fb"
+SRC_URI[md5sum] = "542c30f32c4473b7c50dc2e4a1424cf6"
+SRC_URI[sha256sum] = "b15da8fc4edcb91d554e1259e220ea0173ef639ceaa4b465e06feb7e125b84bf"
inherit systemd update-rc.d useradd cmake
@@ -29,6 +28,7 @@ PACKAGECONFIG ??= "ssl dlt websockets \
${@bb.utils.filter('DISTRO_FEATURES','systemd', d)} \
"
+PACKAGECONFIG[manpages] = "-DDOCUMENTATION=ON,-DDOCUMENTATION=OFF,libxslt-native docbook-xsl-stylesheets-native"
PACKAGECONFIG[dns-srv] = "-DWITH_SRV=ON,-DWITH_SRV=OFF,c-ares"
PACKAGECONFIG[ssl] = "-DWITH_TLS=ON -DWITH_TLS_PSK=ON -DWITH_EC=ON,-DWITH_TLS=OFF -DWITH_TLS_PSK=OFF -DWITH_EC=OFF,openssl"
PACKAGECONFIG[systemd] = "-DWITH_SYSTEMD=ON,-DWITH_SYSTEMD=OFF,systemd"
@@ -59,6 +59,8 @@ PACKAGE_BEFORE_PN = "${PN}-examples"
FILES_${PN} = "${sbindir}/mosquitto \
${bindir}/mosquitto_passwd \
+ ${bindir}/mosquitto_ctrl \
+ ${libdir}/mosquitto_dynamic_security.so \
${sysconfdir}/mosquitto \
${sysconfdir}/init.d \
${systemd_unitdir}/system/mosquitto.service \
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.28.0.bb b/meta-openembedded/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.28.0.bb
index dcb23d05c..7a20e914f 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.28.0.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.28.0.bb
@@ -15,7 +15,6 @@ DEPENDS = " \
util-linux \
libndp \
libnewt \
- jansson \
curl \
"
@@ -89,6 +88,7 @@ PACKAGECONFIG[ifupdown] = "--enable-ifupdown,--disable-ifupdown"
PACKAGECONFIG[qt4-x11-free] = "--enable-qt,--disable-qt,qt4-x11-free"
PACKAGECONFIG[cloud-setup] = "--with-nm-cloud-setup=yes,--with-nm-cloud-setup=no"
PACKAGECONFIG[nmcli] = "--with-nmcli=yes,--with-nmcli=no,readline"
+PACKAGECONFIG[ovs] = "--enable-ovs,--disable-ovs,jansson"
PACKAGES =+ " \
${PN}-nmcli ${PN}-nmcli-doc \
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.10.18.bb b/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.10.18.bb
index 1a982368e..166bf5727 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.10.18.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/samba/samba_4.10.18.bb
@@ -3,8 +3,8 @@ SECTION = "console/network"
LICENSE = "GPL-3.0+ & LGPL-3.0+ & GPL-2.0+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
- file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b \
- file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 "
+ file://${COREBASE}/meta/files/common-licenses/LGPL-3.0-or-later;md5=c51d3eef3be114124d11349ca0d7e117 \
+ file://${COREBASE}/meta/files/common-licenses/GPL-2.0-or-later;md5=fed54355545ffd980b814dab4a3b312c"
SAMBA_MIRROR = "http://samba.org/samba/ftp"
MIRRORS += "\
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.6.0.bb b/meta-openembedded/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.7.0.bb
index ad7e92341..83406f507 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.6.0.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.7.0.bb
@@ -14,7 +14,7 @@ RPROVIDES_${PN} = "cyassl"
SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \
"
-SRCREV = "9c87f979a7f1d3a6d786b260653d566c1d31a1c4"
+SRCREV = "830de9a9fb99e30f9ac9caa0a7f7bba29c3b4863"
S = "${WORKDIR}/git"
inherit autotools