summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-daemons
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-daemons')
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.21.03.bb (renamed from meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.20.11.bb)4
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch105
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/squid/squid_4.14.bb (renamed from meta-openembedded/meta-networking/recipes-daemons/squid/squid_4.13.bb)6
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch51
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb1
5 files changed, 162 insertions, 5 deletions
diff --git a/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.20.11.bb b/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.21.03.bb
index ade2816f5..118c5fea3 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.20.11.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.21.03.bb
@@ -29,8 +29,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
file://0001-Fix-build-with-fno-common.patch \
file://0001-Use-correct-printf-format-for-__fsblkcnt_t.patch \
"
-SRC_URI[md5sum] = "9c7871a2b45f262b7aee2e9d073798e4"
-SRC_URI[sha256sum] = "11b62e6d20c449a297da0c0c15b560747c9ec884305beffed4ca4c192fa9f22c"
+SRC_URI[md5sum] = "0433650ba9c25f2cf36145e11bf96a2a"
+SRC_URI[sha256sum] = "ed40386852e34bbec0ca7e9534ce315b93a17b587614c8118aea1ecd082e1723"
UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/opensaf/files/releases"
diff --git a/meta-openembedded/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch b/meta-openembedded/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch
new file mode 100644
index 000000000..28a410c26
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch
@@ -0,0 +1,105 @@
+From 1f8b5f0e1cc27634a7310be4c9674112f919d974 Mon Sep 17 00:00:00 2001
+From: uhliarik <luhliari@redhat.com>
+Date: Thu, 18 Feb 2021 01:08:40 +0000
+Subject: [PATCH] Fix build on Fedora Rawhide (#772)
+
+* add SYSTEMD_LIBS to all binaries using client_side.cc, fixing linking
+* add `<limits>` to all sources using std::numeric_limits, fixing gcc-11
+ builds
+---
+Upstream-Status: Backport [https://github.com/kraj/squid/commit/1f8b5f0e1cc27634a7310be4c9674112f919d974]
+ src/Makefile.am | 4 ++++
+ src/ip/QosConfig.cc | 1 +
+ src/ipc/mem/PageStack.cc | 1 +
+ src/proxyp/Parser.cc | 1 +
+ src/security/ServerOptions.cc | 2 ++
+ src/ssl/helper.cc | 2 ++
+ 6 files changed, 11 insertions(+)
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2320,6 +2320,7 @@ tests_test_http_range_LDADD = \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_test_http_range_LDFLAGS = $(LIBADD_DL)
+@@ -2624,6 +2625,7 @@ tests_testHttpRequest_LDADD = \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testHttpRequest_LDFLAGS = $(LIBADD_DL)
+@@ -3487,6 +3489,7 @@ tests_testURL_LDADD = \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testURL_LDFLAGS = $(LIBADD_DL)
+@@ -3646,6 +3649,7 @@ nodist_tests_testYesNoNone_SOURCES = \
+ tests_testYesNoNone_LDADD= \
+ base/libbase.la \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testYesNoNone_LDFLAGS = $(LIBADD_DL)
+--- a/src/ip/QosConfig.cc
++++ b/src/ip/QosConfig.cc
+@@ -21,6 +21,7 @@
+ #include "Parsing.h"
+
+ #include <cerrno>
++#include <limits>
+
+ CBDATA_CLASS_INIT(acl_tos);
+
+--- a/src/ipc/mem/PageStack.cc
++++ b/src/ipc/mem/PageStack.cc
+@@ -14,6 +14,7 @@
+ #include "Debug.h"
+ #include "ipc/mem/Page.h"
+ #include "ipc/mem/PageStack.h"
++#include <limits>
+
+ /// used to mark a stack slot available for storing free page offsets
+ const Ipc::Mem::PageStack::Value Writable = 0;
+--- a/src/security/ServerOptions.cc
++++ b/src/security/ServerOptions.cc
+@@ -24,6 +24,8 @@
+ #endif
+ #endif
+
++#include <limits>
++
+ Security::ServerOptions &
+ Security::ServerOptions::operator =(const Security::ServerOptions &old) {
+ if (this != &old) {
+--- a/src/ssl/helper.cc
++++ b/src/ssl/helper.cc
+@@ -19,6 +19,8 @@
+ #include "ssl/helper.h"
+ #include "wordlist.h"
+
++#include <limits>
++
+ Ssl::CertValidationHelper::LruCache *Ssl::CertValidationHelper::HelperCache = nullptr;
+
+ #if USE_SSL_CRTD
+--- a/src/acl/ConnMark.cc
++++ b/src/acl/ConnMark.cc
+@@ -16,6 +16,8 @@
+ #include "http/Stream.h"
+ #include "sbuf/Stream.h"
+
++#include <limits>
++
+ bool
+ Acl::ConnMark::empty() const
+ {
diff --git a/meta-openembedded/meta-networking/recipes-daemons/squid/squid_4.13.bb b/meta-openembedded/meta-networking/recipes-daemons/squid/squid_4.14.bb
index 873d09344..6d154c87e 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/squid/squid_4.13.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/squid/squid_4.14.bb
@@ -24,15 +24,15 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.bz2
file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
file://0001-tools.cc-fixed-unused-result-warning.patch \
file://0001-splay.cc-fix-bind-is-not-a-member-of-std.patch \
+ file://0001-Fix-build-on-Fedora-Rawhide-772.patch \
"
SRC_URI_remove_toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch"
-SRC_URI[md5sum] = "31e524a416715d6bfef30e072d2ca076"
-SRC_URI[sha256sum] = "d09d3c31e3a7d158bda75501e763bd1cd3c3a99f5af6781ec1fd30eed2f771ed"
+SRC_URI[sha256sum] = "4ad08884f065f8e1dac166aa13db6a872cde419a1717dff4c82c2c5337ee5756"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://errors/COPYRIGHT;md5=4c3268f394af77fbbf541875cef96a6c \
+ file://errors/COPYRIGHT;md5=0e03cd976052c45697ad5d96e7dff8dc \
"
DEPENDS = "libtool krb5 openldap db cyrus-sasl"
diff --git a/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch b/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch
new file mode 100644
index 000000000..29ce85cc1
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch
@@ -0,0 +1,51 @@
+From 7bc261076ec94efa3197beaca39eba095d162b5e Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Fri, 26 Feb 2021 16:32:27 +0800
+Subject: [PATCH] seccompsandbox.c: allow newfstatat and pselect6 syscalls in
+ the seccomp sandbox
+
+Allow newfstatat and pselect6 in the seccomp sanbox for glibc 2.33.
+
+Fixes the following OOPS error:
+root@qemux86-64:~# tnftp 192.168.1.1
+Connected to 192.168.1.1.
+220 (vsFTPd 3.0.3)
+Name (192.168.1.1:root): anonymous
+331 Please specify the password.
+Password:
+230 Login successful.
+Remote system type is UNIX.
+Using binary mode to transfer files.
+ftp> ls
+OOPS: priv_sock_get_cmd
+
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ seccompsandbox.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/seccompsandbox.c b/seccompsandbox.c
+index 377c50e..f601241 100644
+--- a/seccompsandbox.c
++++ b/seccompsandbox.c
+@@ -267,6 +267,7 @@ seccomp_sandbox_setup_data_connections()
+ 3, IPPROTO_TCP);
+ allow_nr(__NR_bind);
+ allow_nr(__NR_select);
++ allow_nr(__NR_pselect6);
+ if (tunable_port_enable)
+ {
+ allow_nr(__NR_connect);
+@@ -411,6 +412,7 @@ seccomp_sandbox_setup_postlogin(const struct vsf_session* p_sess)
+ allow_nr(__NR_getdents);
+ allow_nr(__NR_getdents64);
+ allow_nr(__NR_sysinfo);
++ allow_nr(__NR_newfstatat);
+ /* Misc */
+ allow_nr(__NR_umask);
+
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb b/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
index df0d7f455..024b776de 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
@@ -22,6 +22,7 @@ SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)} \
file://0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch \
+ file://0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch \
"
UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/v/vsftpd/"