summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-daemons
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-daemons')
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch30
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch4
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb (renamed from meta-openembedded/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb)5
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-i586-build-issues-with-string-length-overflow.patch115
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Make-iscsid-systemd-usage-optional.patch88
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Use-pkg-config-in-Makefiles-for-newer-libraries.patch92
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.878.bb (renamed from meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb)9
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/lldpd/files/0001-priv-include-limits.h-for-PATH_MAX.patch27
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/lldpd/lldpd_1.0.4.bb (renamed from meta-openembedded/meta-networking/recipes-daemons/lldpd/lldpd_1.0.3.bb)5
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch37
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.49.bb (renamed from meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.47.bb)7
11 files changed, 68 insertions, 351 deletions
diff --git a/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch b/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch
new file mode 100644
index 000000000..2a583466e
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch
@@ -0,0 +1,30 @@
+From d0d5ac317dab11610a5fc91ca3e7f5ad72ce2236 Mon Sep 17 00:00:00 2001
+From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
+Date: Tue, 29 Oct 2019 13:19:37 +0800
+Subject: [PATCH] Bug fix for pid_t not found on musl.
+
+When compiling version 5.1.6 on musl, the following error occurs:
+log.h:49:8: error: unknown type name 'pid_t'
+
+Upstream-Status: Pending
+
+Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
+---
+ lib/defaults.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/defaults.c b/lib/defaults.c
+index a6ea116..b3ecfa5 100644
+--- a/lib/defaults.c
++++ b/lib/defaults.c
+@@ -21,6 +21,7 @@
+ #include <string.h>
+ #include <sys/utsname.h>
+ #include <sys/stat.h>
++#include <sys/types.h>
+ #include <stdarg.h>
+
+ #include "config.h"
+--
+2.20.1
+
diff --git a/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch b/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch
index 410827b33..b991acad3 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch
+++ b/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch
@@ -9,7 +9,7 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-update patch to version 5.1.5
+update patch to version 5.1.6
Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
configure.in | 2 +-
@@ -20,7 +20,7 @@ index 493b9f1..268d06b 100644
--- a/configure.in
+++ b/configure.in
@@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl
- AC_INIT(.autofs-5.1.5)
+ AC_INIT(.autofs-5.1.6)
# for pkg-config macros
-m4_include([/usr/share/aclocal/pkg.m4])
diff --git a/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb b/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
index 9e43549e8..aeadc9d5d 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
@@ -25,11 +25,12 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
file://pkgconfig-libnsl.patch \
file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \
file://0001-Do-not-hardcode-path-for-pkg.m4.patch \
+ file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \
"
-SRC_URI[md5sum] = "03b13168ec7bd66a6f2d5f6fea705eee"
-SRC_URI[sha256sum] = "86a8e56ea9d72bb53ff8cdfeefb5cafe983592c6b0178fb99c4a731e59879181"
+SRC_URI[md5sum] = "e6800e0afd6009ecdff148088c564050"
+SRC_URI[sha256sum] = "82094cad44f4e5c4f93eff2789cd66b57d7ab3fa646b7722d97608571001e694"
UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/"
diff --git a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-i586-build-issues-with-string-length-overflow.patch b/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-i586-build-issues-with-string-length-overflow.patch
deleted file mode 100644
index f945c636f..000000000
--- a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-i586-build-issues-with-string-length-overflow.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-From 24ce8f62e042e69497e1299212504c356179e15b Mon Sep 17 00:00:00 2001
-From: Lee Duncan <lduncan@suse.com>
-Date: Tue, 6 Nov 2018 11:16:06 -0800
-Subject: [PATCH] Fix i586 build issues with string length overflow.
-
-Gcc7 warns of possible string print overflow, on i586,
-when printing password length (via a macro), generating
-errors like:
-
-[ 59s] ^~~~~~~~~~~~~~~~~~~~
-[ 59s] In file included from /usr/include/stdio.h:862:0,
-[ 59s] from idbm.h:27,
-[ 59s] from context.h:22,
-[ 59s] from idbm.c:59:
-[ 59s] /usr/include/bits/stdio2.h:64:10: note:
-'__builtin___snprintf_chk' output between 2 and 11 bytes into a
-destination of size 8
-[ 59s] return __builtin___snprintf_chk (__s, __n,
-__USE_FORTIFY_LEVEL - 1,
-[ 59s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-~~~~~~~~~~
-[ 59s] __bos (__s), __fmt, __va_arg_pack ());
-[ 59s] ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-[ 59s] cc1: all warnings being treated as errors
-[ 59s] make[1]: *** [<builtin>: idbm.o] Error 1
-[ 59s] make[1]: Leaving directory
-
-The fix is to limit the size of the string printed, so that no
-overflow is possible.
-
-The print macros in usr/idbm.c were updated, as well, to match
-the newer version in libopeniscsiusr/idbm.c, also to help the
-i586 build.
-
-Upstream-Status: Backport[https://github.com/open-iscsi/open-iscsi/commit/24ce8f62e042e69497e1299212504c356179e15b]
-
-Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
----
- libopeniscsiusr/idbm.c | 2 +-
- usr/idbm.c | 11 ++++++-----
- 2 files changed, 7 insertions(+), 6 deletions(-)
-
-diff --git a/libopeniscsiusr/idbm.c b/libopeniscsiusr/idbm.c
-index 7724de2..055dd9a 100644
---- a/libopeniscsiusr/idbm.c
-+++ b/libopeniscsiusr/idbm.c
-@@ -676,7 +676,7 @@ updated:
- if (!passwd_done && !strcmp(#_param, name)) { \
- passwd_done = 1; \
- name = #_param "_length"; \
-- snprintf(passwd_len, 8, "%d", (int)strlen(value)); \
-+ snprintf(passwd_len, 8, "%.7d", (int)strlen(value) & 0xffff); \
- value = passwd_len; \
- goto setup_passwd_len; \
- }
-diff --git a/usr/idbm.c b/usr/idbm.c
-index a0207e2..89a6c27 100644
---- a/usr/idbm.c
-+++ b/usr/idbm.c
-@@ -30,6 +30,7 @@
- #include <fcntl.h>
- #include <sys/stat.h>
- #include <sys/file.h>
-+#include <inttypes.h>
-
- #include "idbm.h"
- #include "idbm_fields.h"
-@@ -65,7 +66,7 @@ static struct idbm *db;
- #define __recinfo_int(_key, _info, _rec, _name, _show, _n, _mod) do { \
- _info[_n].type = TYPE_INT; \
- strlcpy(_info[_n].name, _key, NAME_MAXVAL); \
-- snprintf(_info[_n].value, VALUE_MAXVAL, "%d", _rec->_name); \
-+ snprintf(_info[_n].value, VALUE_MAXVAL, "%" PRIi32, _rec->_name); \
- _info[_n].data = &_rec->_name; \
- _info[_n].data_len = sizeof(_rec->_name); \
- _info[_n].visible = _show; \
-@@ -76,7 +77,7 @@ static struct idbm *db;
- #define __recinfo_uint8(_key, _info, _rec, _name, _show, _n, _mod) do { \
- _info[_n].type = TYPE_UINT8; \
- strlcpy(_info[_n].name, _key, NAME_MAXVAL); \
-- snprintf(_info[_n].value, VALUE_MAXVAL, "%d", _rec->_name); \
-+ snprintf(_info[_n].value, VALUE_MAXVAL, "%" PRIu8, _rec->_name); \
- _info[_n].data = &_rec->_name; \
- _info[_n].data_len = sizeof(_rec->_name); \
- _info[_n].visible = _show; \
-@@ -87,7 +88,7 @@ static struct idbm *db;
- #define __recinfo_uint16(_key, _info, _rec, _name, _show, _n, _mod) do { \
- _info[_n].type = TYPE_UINT16; \
- strlcpy(_info[_n].name, _key, NAME_MAXVAL); \
-- snprintf(_info[_n].value, VALUE_MAXVAL, "%d", _rec->_name); \
-+ snprintf(_info[_n].value, VALUE_MAXVAL, "%" PRIu16, _rec->_name); \
- _info[_n].data = &_rec->_name; \
- _info[_n].data_len = sizeof(_rec->_name); \
- _info[_n].visible = _show; \
-@@ -98,7 +99,7 @@ static struct idbm *db;
- #define __recinfo_uint32(_key, _info, _rec, _name, _show, _n, _mod) do { \
- _info[_n].type = TYPE_UINT32; \
- strlcpy(_info[_n].name, _key, NAME_MAXVAL); \
-- snprintf(_info[_n].value, VALUE_MAXVAL, "%d", _rec->_name); \
-+ snprintf(_info[_n].value, VALUE_MAXVAL, "%" PRIu32, _rec->_name); \
- _info[_n].data = &_rec->_name; \
- _info[_n].data_len = sizeof(_rec->_name); \
- _info[_n].visible = _show; \
-@@ -1041,7 +1042,7 @@ updated:
- if (!passwd_done && !strcmp(#_param, name)) { \
- passwd_done = 1; \
- name = #_param "_length"; \
-- snprintf(passwd_len, 8, "%d", (int)strlen(value)); \
-+ snprintf(passwd_len, 8, "%.7" PRIi32, (int)strlen(value) & 0xffff); \
- value = passwd_len; \
- goto setup_passwd_len; \
- }
---
-2.7.4
-
diff --git a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Make-iscsid-systemd-usage-optional.patch b/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Make-iscsid-systemd-usage-optional.patch
deleted file mode 100644
index 08248d358..000000000
--- a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Make-iscsid-systemd-usage-optional.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 365efb2fd3062065af4b6eb3dc1661b96557dae8 Mon Sep 17 00:00:00 2001
-From: Changqing Li <changqing.li@windriver.com>
-Date: Wed, 21 Aug 2019 16:37:53 +0800
-Subject: [PATCH] Make iscsid systemd usage optional
-
-Upstream-Status: Backport[https://github.com/open-iscsi/open-iscsi
-/commit/f71581bd641dc26d330cb8b97e5ec272dd08f811]
-
-Signed-off-by: Changqing Li <changqing.li@windriver.com>
----
- Makefile | 5 +++++
- usr/Makefile | 2 ++
- usr/iscsid.c | 6 ++++++
- 3 files changed, 13 insertions(+)
-
-diff --git a/Makefile b/Makefile
-index c533e9d..1ef0921 100644
---- a/Makefile
-+++ b/Makefile
-@@ -39,6 +39,11 @@ ifneq (,$(CFLAGS))
- export CFLAGS
- endif
-
-+# export systemd disablement if set
-+ifneq ($(NO_SYSTEMD),)
-+export NO_SYSTEMD
-+endif
-+
- # Random comments:
- # using '$(MAKE)' instead of just 'make' allows make to run in parallel
- # over multiple makefile.
-diff --git a/usr/Makefile b/usr/Makefile
-index f9445ad..0203127 100644
---- a/usr/Makefile
-+++ b/usr/Makefile
-@@ -41,7 +41,9 @@ CFLAGS += $(WARNFLAGS) -I../include -I. -D_GNU_SOURCE \
- CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
- ISCSI_LIB = -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr
- LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod)
-+ifneq ($(NO_SYSTEMD),)
- LDFLAGS += $(shell $(PKG_CONFIG) --libs libsystemd)
-+endif
- PROGRAMS = iscsid iscsiadm iscsistart
-
- # libc compat files
-diff --git a/usr/iscsid.c b/usr/iscsid.c
-index 0c98440..164325e 100644
---- a/usr/iscsid.c
-+++ b/usr/iscsid.c
-@@ -34,7 +34,9 @@
- #include <sys/wait.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#ifndef NO_SYSTEMD
- #include <systemd/sd-daemon.h>
-+#endif
-
- #include "iscsid.h"
- #include "mgmt_ipc.h"
-@@ -339,6 +341,7 @@ static void missing_iname_warn(char *initiatorname_file)
- /* called right before we enter the event loop */
- static void set_state_to_ready(void)
- {
-+#ifndef NO_SYSTEMD
- if (sessions_to_recover)
- sd_notify(0, "READY=1\n"
- "RELOADING=1\n"
-@@ -346,14 +349,17 @@ static void set_state_to_ready(void)
- else
- sd_notify(0, "READY=1\n"
- "STATUS=Ready to process requests\n");
-+#endif
- }
-
- /* called when recovery process has been reaped */
- static void set_state_done_reloading(void)
- {
-+#ifndef NO_SYSTEMD
- sessions_to_recover = 0;
- sd_notifyf(0, "READY=1\n"
- "STATUS=Ready to process requests\n");
-+#endif
- }
-
- int main(int argc, char *argv[])
---
-2.7.4
-
diff --git a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Use-pkg-config-in-Makefiles-for-newer-libraries.patch b/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Use-pkg-config-in-Makefiles-for-newer-libraries.patch
deleted file mode 100644
index 37b764e85..000000000
--- a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Use-pkg-config-in-Makefiles-for-newer-libraries.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From e9b49664e969fd5cad1abef7b8b59e1fb8d02a47 Mon Sep 17 00:00:00 2001
-From: Lee Duncan <lduncan@suse.com>
-Date: Mon, 12 Nov 2018 13:10:04 -0800
-Subject: [PATCH] Use pkg-config in Makefiles for newer libraries.
-
-These two recently-added libraries can be in different
-locations on different distros, so use pkg-config to
-added the appropriate actions in the make files.
-
-Upstream-Status: Backport[https://github.com/open-iscsi/open-iscsi/commit/
-623a81123c494f5c69dc6616bd72e838862e2f1f#diff-c4bf6688222ad28c9719cfaf88c16329]
-
-Signed-off-by: Changqing Li <changqing.li@windriver.com>
----
- libopeniscsiusr/Makefile | 8 +++++++-
- usr/Makefile | 11 ++++++++---
- 2 files changed, 15 insertions(+), 4 deletions(-)
-
-diff --git a/libopeniscsiusr/Makefile b/libopeniscsiusr/Makefile
-index bf7c96c..a045a45 100644
---- a/libopeniscsiusr/Makefile
-+++ b/libopeniscsiusr/Makefile
-@@ -23,6 +23,8 @@ endif
- INCLUDE_DIR ?= $(prefix)/include
- PKGCONF_DIR ?= $(LIB_DIR)/pkgconfig
-
-+PKG_CONFIG = /usr/bin/pkg-config
-+
- LIBISCSI_USR_DIR=$(TOPDIR)/libopeniscsiusr
-
- LIBISCSI_USR_VERSION_MAJOR=0
-@@ -43,13 +45,17 @@ OBJS = context.o misc.o session.o sysfs.o iface.o idbm.o node.o default.o
-
- CFLAGS ?= -O2 -g
- CFLAGS += -Wall -Werror -Wextra -fvisibility=hidden -fPIC
-+CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
-+
-+LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod)
-
- LIBADD =
-
- all: $(LIBS) $(LIBS_MAJOR) $(TESTS) doc
-
- $(LIBS): $(OBJS)
-- $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname=$@ -o $@ $(OBJS) $(LIBADD)
-+ @echo CFLAGS= $(CFLAGS)
-+ $(CC) $(CFLAGS) -shared -Wl,-soname=$@ -o $@ $(OBJS) $(LDFLAGS) $(LIBADD)
- ln -sf $@ $(DEVLIB)
-
- $(LIBS_MAJOR): $(LIBS)
-diff --git a/usr/Makefile b/usr/Makefile
-index f9445ad..f1c35aa 100644
---- a/usr/Makefile
-+++ b/usr/Makefile
-@@ -32,11 +32,16 @@ IPC_OBJ=ioctl.o
- endif
- endif
-
-+PKG_CONFIG = /usr/bin/pkg-config
-+
- CFLAGS ?= -O2 -g
- WARNFLAGS ?= -Wall -Wstrict-prototypes
- CFLAGS += $(WARNFLAGS) -I../include -I. -D_GNU_SOURCE \
- -I$(TOPDIR)/libopeniscsiusr
-+CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
- ISCSI_LIB = -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr
-+LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod)
-+LDFLAGS += $(shell $(PKG_CONFIG) --libs libsystemd)
- PROGRAMS = iscsid iscsiadm iscsistart
-
- # libc compat files
-@@ -60,14 +65,14 @@ all: $(PROGRAMS)
-
- iscsid: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(DISCOVERY_SRCS) \
- iscsid.o session_mgmt.o discoveryd.o mntcheck.o
-- $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ -lisns -lcrypto -lrt -lmount $(ISCSI_LIB)
-+ $(CC) $(CFLAGS) $^ -o $@ -lisns -lcrypto -lrt -lmount $(LDFLAGS) $(ISCSI_LIB)
-
- iscsiadm: $(ISCSI_LIB_SRCS) $(DISCOVERY_SRCS) iscsiadm.o session_mgmt.o mntcheck.o
-- $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ -lisns -lcrypto -lmount $(ISCSI_LIB)
-+ $(CC) $(CFLAGS) $^ -o $@ -lisns -lcrypto -lmount $(LDFLAGS) $(ISCSI_LIB)
-
- iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
- iscsistart.o statics.o
-- $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ -lrt $(ISCSI_LIB)
-+ $(CC) $(CFLAGS) $^ -o $@ -lrt $(LDFLAGS) $(ISCSI_LIB)
- clean:
- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
-
---
-2.7.4
-
diff --git a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb b/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.878.bb
index 3cef70f5e..b75e54b9c 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.878.bb
@@ -8,21 +8,19 @@ HOMEPAGE = "http://www.open-iscsi.com/"
LICENSE = "GPLv2 & LGPLv2.1"
SECTION = "net"
DEPENDS = "openssl flex-native bison-native open-isns util-linux kmod"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRCREV ?= "120ac127654c4644d46a74799fffe527ab1f4f42"
+SRCREV ?= "288add22d6b61cc68ede358faeec9affb15019cd"
SRC_URI = "git://github.com/open-iscsi/open-iscsi \
- file://0001-Fix-i586-build-issues-with-string-length-overflow.patch \
file://initd.debian \
file://99_iscsi-initiator-utils \
file://iscsi-initiator \
file://iscsi-initiator.service \
file://iscsi-initiator-targets.service \
file://set_initiatorname \
- file://0001-Use-pkg-config-in-Makefiles-for-newer-libraries.patch \
- file://0001-Make-iscsid-systemd-usage-optional.patch \
"
S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
@@ -36,6 +34,8 @@ EXTRA_OECONF = " \
--host=${BUILD_SYS} \
"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', '--without-systemd', d)}"
+
EXTRA_OEMAKE = ' \
OS="${TARGET_SYS}" \
TARGET="${TARGET_OS}" \
@@ -46,6 +46,7 @@ EXTRA_OEMAKE = ' \
NO_SYSTEMD=1 \
'
+
do_configure () {
cd ${S}/iscsiuio ; autoreconf --install; ./configure ${EXTRA_OECONF}
}
diff --git a/meta-openembedded/meta-networking/recipes-daemons/lldpd/files/0001-priv-include-limits.h-for-PATH_MAX.patch b/meta-openembedded/meta-networking/recipes-daemons/lldpd/files/0001-priv-include-limits.h-for-PATH_MAX.patch
deleted file mode 100644
index 9ea4a9ffb..000000000
--- a/meta-openembedded/meta-networking/recipes-daemons/lldpd/files/0001-priv-include-limits.h-for-PATH_MAX.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From c6a283bfcbfefe9c89113e81b0f792c12c4eefb8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
-Date: Mon, 25 Mar 2019 18:43:03 +0100
-Subject: [PATCH] priv: include limits.h for PATH_MAX
-
-Upstream-Status: Backport
-
-Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
----
- src/daemon/priv.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/daemon/priv.c b/src/daemon/priv.c
-index f4d6bdf..ba5ae58 100644
---- a/src/daemon/priv.c
-+++ b/src/daemon/priv.c
-@@ -27,6 +27,7 @@
- #include <unistd.h>
- #include <signal.h>
- #include <errno.h>
-+#include <limits.h>
- #include <sys/wait.h>
- #include <sys/stat.h>
- #include <sys/socket.h>
---
-2.17.1
-
diff --git a/meta-openembedded/meta-networking/recipes-daemons/lldpd/lldpd_1.0.3.bb b/meta-openembedded/meta-networking/recipes-daemons/lldpd/lldpd_1.0.4.bb
index e650b5795..8fdaf848f 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/lldpd/lldpd_1.0.3.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/lldpd/lldpd_1.0.4.bb
@@ -9,11 +9,10 @@ SRC_URI = "\
http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
file://lldpd.init.d \
file://lldpd.default \
- file://0001-priv-include-limits.h-for-PATH_MAX.patch \
"
-SRC_URI[md5sum] = "04844328f053ee343344d892efb8a00c"
-SRC_URI[sha256sum] = "39fced395168015416bfe78b95414facf066f841f349024433aa20ab54e4c360"
+SRC_URI[md5sum] = "33e8d58623f99184e4e709cbbfe45db3"
+SRC_URI[sha256sum] = "5319bc032fabf1008d5d91e280276aa7f1bbfbb70129d8526cd4526d7c22724f"
inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
diff --git a/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch b/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch
index 16a611e3c..2606a3667 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch
+++ b/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch
@@ -8,30 +8,39 @@ Upstream-Status: Inappropriate [config]
Signed-off-by: Yauhen Kharuzhy <yauhen.kharuzhy@promwad.com>
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
+Update for 1.0.49.
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
+
---
- configure.ac | 12 ------------
- 1 file changed, 12 deletions(-)
+ configure.ac | 15 ---------------
+ 1 file changed, 15 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 3a4209b..695ce68 100644
+index 079e6f0..9a1ec06 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -91,18 +91,6 @@ AX_CHECK_LINK_FLAG([-Wl,-z,relro], [LDFLAGS="$LDFLAGS -Wl,-z,relro"])
+@@ -96,21 +96,6 @@ AX_CHECK_LINK_FLAG([-Wl,-z,relro], [LDFLAGS="$LDFLAGS -Wl,-z,relro"])
AX_CHECK_LINK_FLAG([-Wl,-z,now], [LDFLAGS="$LDFLAGS -Wl,-z,now"])
AX_CHECK_LINK_FLAG([-Wl,-z,noexecstack], [LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"])
--if test -d /usr/local/include; then
-- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
--fi
--
--if test -d /usr/kerberos/include; then
-- CPPFLAGS="$CPPFLAGS -I/usr/kerberos/include"
--fi
--
--if test -d /usr/local/lib; then
-- LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-if test "x$cross_compiling" != "xyes"; then
+- for path in \
+- /usr/kerberos \
+- /usr/local /opt /usr/local/opt \
+- /usr/openssl@1.1 /opt/openssl@1.1 /usr/local/opt/openssl@1.1 \
+- /usr/openssl /opt/openssl /usr/local/opt/openssl; do
+- if test -d $path/include; then
+- CPPFLAGS="$CPPFLAGS -I${path}/include"
+- fi
+- if test -d $path/lib; then
+- LDFLAGS="$LDFLAGS -L${path}/lib"
+- fi
+- done
-fi
-
CPPFLAGS="$CPPFLAGS -D_FORTIFY_SOURCE=2"
dnl Checks for header files
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.47.bb b/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.49.bb
index e7c530be3..5a8e9c130 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.47.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.49.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Pure-FTPd is a free (BSD license), secure, production-quality and
HOMEPAGE = "http://www.pureftpd.org/project/pure-ftpd"
SECTION = "net"
LICENSE = "BSD-0-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0595b4261a04bc2d27f30b9c90796c1f"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e25e28bc568d70eb26c3a91387c86ccb"
DEPENDS = "libcap virtual/crypt"
@@ -11,11 +11,10 @@ SRC_URI = "http://download.pureftpd.org/pub/pure-ftpd/releases/pure-ftpd-${PV}.t
file://0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch \
file://nostrip.patch \
"
-SRC_URI[md5sum] = "f000e519918682ee6b65090352177d4a"
-SRC_URI[sha256sum] = "4740c316f5df879a2d68464489fb9b8b90113fe7dce58e2cdd2054a4768f27ad"
+SRC_URI[md5sum] = "451879495ba61c1d7dcfca8dd231119f"
+SRC_URI[sha256sum] = "767bf458c70b24f80c0bb7a1bbc89823399e75a0a7da141d30051a2b8cc892a5"
inherit autotools
-EXTRA_OECONF = "--with-minimal"
PACKAGECONFIG[libsodium] ="ac_cv_lib_sodium_crypto_pwhash_scryptsalsa208sha256_str=yes, \
ac_cv_lib_sodium_crypto_pwhash_scryptsalsa208sha256_str=no, libsodium"