summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb4
-rw-r--r--meta-openembedded/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb b/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb
index 4a2ab3efb..0f62b5790 100644
--- a/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb
+++ b/meta-openembedded/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb
@@ -18,12 +18,12 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
SRC_URI[md5sum] = "7608579722c491e42f5f63b3f88a95fb"
SRC_URI[sha256sum] = "4711cacf013e298754abd70058ccc995758177fb425f1c2d30e71adfc1d00aa5"
-do_configure_prepend() {
+do_configure:prepend() {
sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg
sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg
}
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
${PYTHON_PN}-pyasn1 \
diff --git a/meta-openembedded/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb b/meta-openembedded/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
index 01ca63746..84acc8681 100644
--- a/meta-openembedded/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
+++ b/meta-openembedded/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
@@ -26,7 +26,7 @@ UPSTREAM_CHECK_COMMITS = "1"
inherit setuptools3 ptest
-do_install_append() {
+do_install:append() {
mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3
}
@@ -36,6 +36,6 @@ do_install_ptest() {
sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
}
-RDEPENDS_${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
+RDEPENDS:${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-pycrypto"