summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb b/meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
index 876462d2f..4bf9944aa 100644
--- a/meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
+++ b/meta-openembedded/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
@@ -23,7 +23,7 @@ S = "${WORKDIR}/dlm-dlm-${PV}"
DEPENDS = "corosync systemd"
-inherit pkgconfig systemd distro_features_check
+inherit pkgconfig systemd features_check
PACKAGECONFIG ??= ""
@@ -36,6 +36,10 @@ export EXTRA_OEMAKE = ""
DONTBUILD = "${@bb.utils.contains('PACKAGECONFIG', 'pacemaker', '', 'fence', d)}"
+do_compile_prepend_toolchain-clang() {
+ sed -i -e "s/-fstack-clash-protection//g" ${S}/*/Makefile
+}
+
do_compile_prepend() {
sed -i "s/libsystemd-daemon/libsystemd/g" ${S}/dlm_controld/Makefile
sed -i -e "s/ ${DONTBUILD}//g" ${S}/Makefile